aboutsummaryrefslogtreecommitdiff
path: root/math/spot
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-10-10 14:41:44 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-10-10 19:05:35 +0000
commit889aaf267174fcd1b96776227f99266c28e91783 (patch)
tree3a5fc37a142fc400c292445461ca687dc30bff47 /math/spot
parentc1e0a52d1a752710db753a4c7a864e0e071a1140 (diff)
downloadports-889aaf267174fcd1b96776227f99266c28e91783.tar.gz
ports-889aaf267174fcd1b96776227f99266c28e91783.zip
math/{,py-}spot: Minor improvements
* Allow to test the Python binding from math/spot * Remove unnecessary patch * Correct C++ standard level
Diffstat (limited to 'math/spot')
-rw-r--r--math/spot/Makefile4
-rw-r--r--math/spot/files/patch-spot_misc_tmpfile.cc10
2 files changed, 4 insertions, 10 deletions
diff --git a/math/spot/Makefile b/math/spot/Makefile
index 5c46eacd16f0..39020795ff02 100644
--- a/math/spot/Makefile
+++ b/math/spot/Makefile
@@ -14,7 +14,11 @@ USES= charsetfix compiler:c++17-lang gmake libtool
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
+.if !defined(WITH_PYTHON) # math/py-spot is a separate port but tests don't work there. To test run: make test WITH_PYTHON=yes
CONFIGURE_ARGS= --disable-python --disable-static
+.else
+CONFIGURE_ARGS= --disable-static
+.endif
INSTALL_TARGET= install-strip
diff --git a/math/spot/files/patch-spot_misc_tmpfile.cc b/math/spot/files/patch-spot_misc_tmpfile.cc
deleted file mode 100644
index 063d33233e71..000000000000
--- a/math/spot/files/patch-spot_misc_tmpfile.cc
+++ /dev/null
@@ -1,10 +0,0 @@
---- spot/misc/tmpfile.cc.orig 2022-10-08 19:11:32 UTC
-+++ spot/misc/tmpfile.cc
-@@ -23,6 +23,7 @@
- #include <stdlib.h>
- #include <unistd.h>
- #include <string.h>
-+#include <stdlib.h>
-
- using namespace std::string_literals;
-