aboutsummaryrefslogtreecommitdiff
path: root/math/sprng
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2021-03-02 21:18:43 +0000
committerThierry Thomas <thierry@FreeBSD.org>2021-03-02 21:18:43 +0000
commit09bd67d4f4aff85a009b3f87dc054515d60abeb4 (patch)
tree0aace971b73a9af4c5c8c78c41f3050bf875c874 /math/sprng
parent4d2c0028d08e66e31439825845d165fb631ef46a (diff)
downloadports-09bd67d4f4aff85a009b3f87dc054515d60abeb4.tar.gz
ports-09bd67d4f4aff85a009b3f87dc054515d60abeb4.zip
Set USES=mpi.
Notes
Notes: svn path=/head/; revision=566986
Diffstat (limited to 'math/sprng')
-rw-r--r--math/sprng/Makefile8
-rw-r--r--math/sprng/pkg-plist20
2 files changed, 14 insertions, 14 deletions
diff --git a/math/sprng/Makefile b/math/sprng/Makefile
index 0dca86e57a61..853e1e174b81 100644
--- a/math/sprng/Makefile
+++ b/math/sprng/Makefile
@@ -27,11 +27,11 @@ TEST_TARGET= check
PORTEXAMPLES= *
-OPTIONS_DEFINE= EXAMPLES MPI
-OPTIONS_DEFAULT= EXAMPLES MPI
+OPTIONS_DEFINE= EXAMPLES MPICH
+OPTIONS_DEFAULT= EXAMPLES MPICH
OPTIONS_SUB= yes
-MPI_LIB_DEPENDS= libmpi.so:net/mpich
-MPI_CONFIGURE_WITH= mpi
+MPICH_USES= mpi:mpich
+MPICH_CONFIGURE_WITH= mpi
ASCII_TEXTS= checkcmrg checklcg checklcg64 checklfg checkmlfg checkpmlcg \
checksprng timecmrg timelcg timelcg64 timelfg timemlfg timepmlcg\
diff --git a/math/sprng/pkg-plist b/math/sprng/pkg-plist
index efcdfa21ec72..68060d31f76a 100644
--- a/math/sprng/pkg-plist
+++ b/math/sprng/pkg-plist
@@ -1,4 +1,4 @@
-%%MPI%%bin/2streams_mpi.tmp
+%%MPICH%%bin/2streams_mpi.tmp
bin/FIPS_140_2.tmp
bin/alphabit.tmp
bin/bigCrush.tmp
@@ -30,26 +30,26 @@ bin/convertf.tmp
bin/coupon.tmp
bin/crush.tmp
bin/equidist.tmp
-%%MPI%%bin/fsprng-simple_mpi.tmp
-%%MPI%%bin/fsprng_mpi.tmp
+%%MPICH%%bin/fsprng-simple_mpi.tmp
+%%MPICH%%bin/fsprng_mpi.tmp
bin/gap.tmp
bin/libsprng.a
bin/maxt.tmp
-%%MPI%%bin/message-simple_mpi.tmp
-%%MPI%%bin/message_mpi.tmp
+%%MPICH%%bin/message-simple_mpi.tmp
+%%MPICH%%bin/message_mpi.tmp
bin/metropolis.tmp
bin/perm.tmp
bin/pi-simple.tmp
-%%MPI%%bin/pi-simple_mpi.tmp
+%%MPICH%%bin/pi-simple_mpi.tmp
bin/pif-simple.tmp
bin/poker.tmp
bin/rabbit.tmp
bin/random_walk.tmp
bin/runs.tmp
bin/seed-simple.tmp
-%%MPI%%bin/seed-simple_mpi.tmp
+%%MPICH%%bin/seed-simple_mpi.tmp
bin/seed.tmp
-%%MPI%%bin/seed_mpi.tmp
+%%MPICH%%bin/seed_mpi.tmp
bin/seedf-simple.tmp
bin/seedf.tmp
bin/serial.tmp
@@ -59,9 +59,9 @@ bin/smallCrush.tmp
bin/spawn.tmp
bin/spawnf.tmp
bin/sprng-simple.tmp
-%%MPI%%bin/sprng-simple_mpi.tmp
+%%MPICH%%bin/sprng-simple_mpi.tmp
bin/sprng.tmp
-%%MPI%%bin/sprng_mpi.tmp
+%%MPICH%%bin/sprng_mpi.tmp
bin/sprngf-simple.tmp
bin/sprngf.tmp
bin/subroutinef.tmp