aboutsummaryrefslogtreecommitdiff
path: root/math/suitesparse/Makefile
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2020-04-11 18:11:30 +0000
committerThierry Thomas <thierry@FreeBSD.org>2020-04-11 18:11:30 +0000
commit87ad2788dc2b2f832ebb3605857cd84b5de55797 (patch)
treeed85a3efd90abd0f83bb2c0af1ccb2d3950a2534 /math/suitesparse/Makefile
parentbf90090be064ec94319b26011f99aad2d3e21b46 (diff)
downloadports-87ad2788dc2b2f832ebb3605857cd84b5de55797.tar.gz
ports-87ad2788dc2b2f832ebb3605857cd84b5de55797.zip
- Same site web, but mow the sources are on GihtHub;
- Upgrade to v5.7.2 Many release notes at <https://github.com/DrTimothyAldenDavis/SuiteSparse/releases> - Add some missing modules to pkg-descr.
Notes
Notes: svn path=/head/; revision=531447
Diffstat (limited to 'math/suitesparse/Makefile')
-rw-r--r--math/suitesparse/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/math/suitesparse/Makefile b/math/suitesparse/Makefile
index 42655e0a6190..f8ce8e6303c8 100644
--- a/math/suitesparse/Makefile
+++ b/math/suitesparse/Makefile
@@ -2,12 +2,9 @@
# $FreeBSD$
PORTNAME= suitesparse
-DISTVERSION= 5.4.0
-PORTREVISION= 6
+PORTVERSION= 5.7.2
+DISTVERSIONPREFIX= v
CATEGORIES= math
-MASTER_SITES= http://faculty.cse.tamu.edu/davis/SuiteSparse/ \
- https://mirror.sobukus.de/files/src/suitesparse/
-DISTNAME= SuiteSparse-${PORTVERSION}
MAINTAINER= fortran@FreeBSD.org
COMMENT= SuiteSparse is a set of packages for sparse matrices calculation
@@ -17,9 +14,12 @@ LICENSE_COMB= dual
LIB_DEPENDS= libmetis.so:math/metis
+USE_GITHUB= yes
+GH_ACCOUNT= DrTimothyAldenDavis
+GH_PROJECT= SuiteSparse
+
USES= cmake:insource compiler:${OPENMP}c++11-lib fortran gmake localbase:ldflags
USE_LDCONFIG= yes
-WRKSRC= ${WRKDIR}/SuiteSparse
ALL_TARGET= library # skip demos
INSTALL_TARGET= install # skip USES=cmake
MAKE_ENV= BLAS="${BLASLIB}" LAPACK="${LAPACKLIB}" \
@@ -29,7 +29,8 @@ MAKE_ENV= BLAS="${BLASLIB}" LAPACK="${LAPACKLIB}" \
INSTALL="${STAGEDIR}${PREFIX}" \
INSTALL_DOC="${STAGEDIR}${DOCSDIR}" \
INSTALL_INCLUDE="${STAGEDIR}${PREFIX}/include/${PORTNAME}"
-CMAKE_ARGS= -DCMAKE_INSTALL_INCLUDEDIR:PATH="include/${PORTNAME}"
+CMAKE_ARGS= -DCMAKE_INSTALL_INCLUDEDIR:PATH="include/${PORTNAME}" \
+ -DBUILD_GRB_STATIC_LIBRARY:BOOL=ON
LDFLAGS+= -L${WRKSRC}/lib # prevent linking with shared libs from the preinstalled older versions
CONFLICTS_INSTALL= mongoose plinkseq # bin/mongoose