aboutsummaryrefslogtreecommitdiff
path: root/math/suitesparse
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2020-04-12 16:18:49 +0000
committerThierry Thomas <thierry@FreeBSD.org>2020-04-12 16:18:49 +0000
commitdc57ad6e75668bf63a15397f9c034582d951f7b9 (patch)
treeaa89d24f0ef6e57e5ad5c09095bf7fda572e1b7b /math/suitesparse
parentf1dca9e0b0d1b0121d95c64734d5bec641211971 (diff)
downloadports-dc57ad6e75668bf63a15397f9c034582d951f7b9.tar.gz
ports-dc57ad6e75668bf63a15397f9c034582d951f7b9.zip
Fix on i386, by using Gcc.
Unfortunately, SuiteSparse is now hit by the problem listed in PR 230888 (missing support of libatomic). Reported by: pkgfallout via antoine@
Notes
Notes: svn path=/head/; revision=531531
Diffstat (limited to 'math/suitesparse')
-rw-r--r--math/suitesparse/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/math/suitesparse/Makefile b/math/suitesparse/Makefile
index f8ce8e6303c8..d60d68a4a353 100644
--- a/math/suitesparse/Makefile
+++ b/math/suitesparse/Makefile
@@ -18,7 +18,7 @@ USE_GITHUB= yes
GH_ACCOUNT= DrTimothyAldenDavis
GH_PROJECT= SuiteSparse
-USES= cmake:insource compiler:${OPENMP}c++11-lib fortran gmake localbase:ldflags
+USES= cmake:insource fortran gmake localbase:ldflags
USE_LDCONFIG= yes
ALL_TARGET= library # skip demos
INSTALL_TARGET= install # skip USES=cmake
@@ -57,6 +57,16 @@ TBB_DESC= Intel threading building blocks
TBB_LIB_DEPENDS= libtbb.so:devel/tbb
TBB_MAKE_ENV= TBB="-ltbb" SPQR_CONFIG="-DHAVE_TBB"
+.include <bsd.port.options.mk>
+
+.if ${ARCH} == i386
+# See PR 230888 : Missing 64 bit atomic functions for i386
+USES+= compiler:gcc-c++11-lib
+LDFLAGS+= -latomic
+.else
+USES+= compiler:${OPENMP}c++11-lib
+.endif
+
post-extract:
${RM} -r ${WRKSRC}/metis-*