aboutsummaryrefslogtreecommitdiff
path: root/math/sundials
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-09-22 17:40:41 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-09-22 17:40:41 +0000
commit607fe7ab866b2dd2d18e099f5c68e718a3fad7a9 (patch)
treebe52eb04866ee01496b23257b0332af1712d318f /math/sundials
parentbe88507da6f1e9f50bbfdb380959ca5a49dcf915 (diff)
downloadports-607fe7ab866b2dd2d18e099f5c68e718a3fad7a9.tar.gz
ports-607fe7ab866b2dd2d18e099f5c68e718a3fad7a9.zip
Change 10 ports from net/mpich2 to net/mpich
mpich2 is the obsolete version 2.x, mpich is at the current version 3.x science/triqs science/PETSc math/py-slepc4py math/slepc math/py-petsc4py math/petiga math/sundials cad/elmerfem math/blocksolve95 math/spooles
Notes
Notes: svn path=/head/; revision=480424
Diffstat (limited to 'math/sundials')
-rw-r--r--math/sundials/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/math/sundials/Makefile b/math/sundials/Makefile
index 7bd94ae258d5..6a2607e72954 100644
--- a/math/sundials/Makefile
+++ b/math/sundials/Makefile
@@ -2,6 +2,7 @@
PORTNAME= sundials
DISTVERSION= 3.1.2
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= https://computation.llnl.gov/projects/sundials/download/
@@ -20,6 +21,7 @@ CMAKE_ARGS= -DPTHREAD_ENABLE:BOOL=ON \
PLIST_SUB= SHL3=${DISTVERSION} SHL1=${DISTVERSION:R:R} SHLX3=1.1.2 SHLX1=1
OPTIONS_DEFINE= BLAS EXAMPLES LAPACK MPI SUPERLUMT # OPENMP detection is broken in cmake: https://gitlab.kitware.com/cmake/cmake/issues/17474
+OPTIONS_DEFAULT= LAPACK
OPTIONS_GROUP= VECTORS
OPTIONS_GROUP_VECTORS= HYPRE PETSC
VECTORS_DESC= Alternative vector libraries
@@ -50,7 +52,7 @@ LAPACK_CMAKE_ON= -DSUNDIALS_INDEX_TYPE:STRING=int32_t \
-DFREEBSD_GCC_DIR:STRING=${LOCALBASE}/lib/gcc${GCC_DEFAULT:S/.//} # assumes that fortran:gcc is used
MPI_CMAKE_ON= -DMPI_ENABLE:BOOL=ON
-MPI_LIB_DEPENDS= libmpich.so:net/mpich2
+MPI_LIB_DEPENDS= libmpich.so:net/mpich
PETSC_CMAKE_BOOL= PETSC_ENABLE
PETSC_CMAKE_ON= -DPETSC_INCLUDE_DIR=${LOCALBASE}/include \