aboutsummaryrefslogtreecommitdiff
path: root/math/tablix
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-06-11 14:49:59 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-06-11 14:49:59 +0000
commit9f8b4bcde30c0ca3bf6cead5f48aa102536e0e92 (patch)
treec4f78cbaf45ab044db3e157be708afd711a4e841 /math/tablix
parent0533abe3e7aae5c19e0a0ce9c1e82ed5e94f63e8 (diff)
downloadports-9f8b4bcde30c0ca3bf6cead5f48aa102536e0e92.tar.gz
ports-9f8b4bcde30c0ca3bf6cead5f48aa102536e0e92.zip
Support LIBS like LDFLAGS.
- Add LIBS="${LIBS}" to MAKE_ENV and CONFIGURE_ENV. - Add an option helper for LIBS. - Adjust all ports that already use LIBS. Also remove references to PTHREAD_CFLAGS and PTHREAD_LIBS while here. - Some ports did not support having a LIBS environment variable and required additional patches. Somewhat simplified a linker command line looks like: ${CC} ${src_LDFLAGS} ${LDFLAGS} ${src_LIBS} ${LIBS} where src_LDFLAGS and src_LIBS are controlled by upstream and LDFLAGS and LIBS can be controlled by us. If possible -L and -l flags need to be added to LIBS to make sure they appear after any -L and -l flags set by upstream. Many ports currently add -L${LOCALBASE}/lib to LDFLAGS but this may appear too early on the command line causing installed libraries to be linked in instead of freshly built ones. Additional changes: benchmarks/netio: Replace WITH_IPV6 with an IPV6 option. comms/gnokii: Replace some patches with USES=pathfix. Also remove -fPIC. graphics/gimageview: USES=libtool and install desktop file in DESKTOPDIR. graphics/visionworkbench: Remove FreeBSD 7 support. multimedia/libmovtar: New LIB_DEPENDS syntax. multimedia/opencinematools: Use standard do-build. net/siproxd: USES=libtool:keepla (port actually needs .la files for plugins) net-mgmt/nagios: Remove -fPIC. net-mgmt/nagios4: Remove -fPIC. print/cups-base: Only add -lssp_nonshared on i386 and OSVERSION < 1000036. security/p11-kit: Replace PTHREAD_LIBS in CONFIGURE_ENV with ac_cv_func_pthread_mutexattr_init=no in CONFIGURE_ARGS. This skips a test in configure that falsely detects pthread_mutexattr_init in our libc. sysutils/dar: Fix iconv detection. x11/rxvt-unicode: Remove -lstdc++ and patch configure to remove a FreeBSD hack and use $CXX as linker as on other platforms. PR: 190592 Exp-run by: antoine Approved by: portmgr (antoine)
Notes
Notes: svn path=/head/; revision=357486
Diffstat (limited to 'math/tablix')
-rw-r--r--math/tablix/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/math/tablix/Makefile b/math/tablix/Makefile
index 093995bbca45..a1a77f3e9e09 100644
--- a/math/tablix/Makefile
+++ b/math/tablix/Makefile
@@ -14,16 +14,15 @@ COMMENT= Free software for solving timetabling problems
BUILD_DEPENDS= pvm:${PORTSDIR}/net/pvm
RUN_DEPENDS= pvm:${PORTSDIR}/net/pvm
-PVM_ROOT= ${PREFIX}/lib/pvm
+PVM_ROOT= ${LOCALBASE}/lib/pvm
USE_GNOME= libxml2
GNU_CONFIGURE= yes
USES= gettext gmake
-CONFIGURE_ENV= LIBS=-L${PREFIX}/lib \
- PVM_ROOT=${PVM_ROOT} PVM_LIB=${PREFIX}/lib
-CPPFLAGS+= -I${PREFIX}/include
-LDFLAGS+= -L${PREFIX}/lib
+CONFIGURE_ENV= PVM_ROOT=${PVM_ROOT} PVM_LIB=${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
MAN1= tablix2.1 tablix2_benchmark.1 tablix2_kernel.1 tablix2_output.1 \
tablix2_plot.1 tablix2_test.1