aboutsummaryrefslogtreecommitdiff
path: root/math/tmv
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2019-10-04 20:40:33 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2019-10-04 20:40:33 +0000
commita4e67553185dba8991ab121b756b4f99d867192a (patch)
treecd1f100e9a6f78153adc47a99c5d49e26627e9bc /math/tmv
parent13f6aa2bdd5c71033d58d6915803d299e3958047 (diff)
downloadports-a4e67553185dba8991ab121b756b4f99d867192a.tar.gz
ports-a4e67553185dba8991ab121b756b4f99d867192a.zip
math/tmv: fix build on GCC architectures
Instead of depending on libomp, set USES=compiler:openmp. Also don't link to libomp. PR: 241050 Approved by: linimon (mentor), yuri (maintainer)
Notes
Notes: svn path=/head/; revision=513778
Diffstat (limited to 'math/tmv')
-rw-r--r--math/tmv/Makefile6
-rw-r--r--math/tmv/files/Makefile2
2 files changed, 3 insertions, 5 deletions
diff --git a/math/tmv/Makefile b/math/tmv/Makefile
index 5bc7ba284309..16dd62f297fc 100644
--- a/math/tmv/Makefile
+++ b/math/tmv/Makefile
@@ -3,7 +3,7 @@
PORTNAME= tmv
DISTVERSIONPREFIX= v
DISTVERSION= 0.75
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
@@ -12,9 +12,7 @@ COMMENT= Fast, intuitive linear algebra library for C++
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/TMV_LICENSE
-LIB_DEPENDS= libomp.so:devel/openmp
-
-USES= gmake blaslapack:netlib localbase
+USES= compiler:openmp gmake blaslapack:netlib localbase
USE_GITHUB= yes
GH_ACCOUNT= rmjarvis
USE_LDCONFIG= yes
diff --git a/math/tmv/files/Makefile b/math/tmv/files/Makefile
index bce7afd38d59..4322519b9770 100644
--- a/math/tmv/files/Makefile
+++ b/math/tmv/files/Makefile
@@ -9,7 +9,7 @@ LST2= TMV_BandMatrix TMV_MultBV TMV_MultXB TMV_AddBB TMV_MultBM TMV_MultBB TMV_B
LIB2= libtmv_symband.so.0
CXXFLAGS+= -I../include -fopenmp -fPIC -DTMV_NDEBUG -DFBLAS -DNOLAP
-LDFLAGS+= -lblas -lomp
+LDFLAGS+= -lblas
SRCS1= $(addsuffix .cpp, $(LST1))
SRCS2= $(addsuffix .cpp, $(LST2))