aboutsummaryrefslogtreecommitdiff
path: root/math/tomsfastmath
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-08-29 14:40:22 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-08-29 14:40:22 +0000
commit341c6248aed73f05ed8e75174c10508d050f1a34 (patch)
treec5ab0cb3ae246f816d438d369bb71ab51d214b40 /math/tomsfastmath
parent27d523fd79942bd85a217a9bf100147ad45c5290 (diff)
downloadports-341c6248aed73f05ed8e75174c10508d050f1a34.tar.gz
ports-341c6248aed73f05ed8e75174c10508d050f1a34.zip
Notes
Diffstat (limited to 'math/tomsfastmath')
-rw-r--r--math/tomsfastmath/Makefile27
-rw-r--r--math/tomsfastmath/distinfo2
-rw-r--r--math/tomsfastmath/files/patch-makefile16
-rw-r--r--math/tomsfastmath/pkg-descr4
-rw-r--r--math/tomsfastmath/pkg-plist2
5 files changed, 51 insertions, 0 deletions
diff --git a/math/tomsfastmath/Makefile b/math/tomsfastmath/Makefile
new file mode 100644
index 000000000000..f57359dbd05b
--- /dev/null
+++ b/math/tomsfastmath/Makefile
@@ -0,0 +1,27 @@
+# Ports collection makefile for: tomsfastmath
+# Date created: 05 Aug 2005
+# Whom: Wesley Shields <wxs@csh.rit.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tomsfastmath
+PORTVERSION= 0.05
+CATEGORIES= math
+MASTER_SITES= http://libtomcrypt.org/tfm/files/
+DISTNAME= tfm-${PORTVERSION}
+
+MAINTAINER= wxs@csh.rit.edu
+COMMENT= Portable fixed precision math library for fast exponentiations
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+MAKEFILE= makefile
+USE_BZIP2= yes
+USE_GMAKE= yes
+ALL_TARGET= default
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's| ||' ${WRKSRC}/fp_montgomery_reduce.c
+
+.include <bsd.port.mk>
diff --git a/math/tomsfastmath/distinfo b/math/tomsfastmath/distinfo
new file mode 100644
index 000000000000..9ece9cb3edb1
--- /dev/null
+++ b/math/tomsfastmath/distinfo
@@ -0,0 +1,2 @@
+MD5 (tfm-0.05.tar.bz2) = 10d7b516c58738298293368c706a7c83
+SIZE (tfm-0.05.tar.bz2) = 219018
diff --git a/math/tomsfastmath/files/patch-makefile b/math/tomsfastmath/files/patch-makefile
new file mode 100644
index 000000000000..fd643d5705ca
--- /dev/null
+++ b/math/tomsfastmath/files/patch-makefile
@@ -0,0 +1,16 @@
+--- makefile.orig Fri Aug 5 10:44:08 2005
++++ makefile Fri Aug 5 10:45:03 2005
+@@ -49,11 +49,11 @@
+ HEADERS=tfm.h
+
+ ifndef LIBPATH
+- LIBPATH=/usr/lib
++ LIBPATH=${PREFIX}/lib
+ endif
+
+ ifndef INCPATH
+- INCPATH=/usr/include
++ INCPATH=${PREFIX}/include
+ endif
+
+ ifndef INSTALL_GROUP
diff --git a/math/tomsfastmath/pkg-descr b/math/tomsfastmath/pkg-descr
new file mode 100644
index 000000000000..7621b58a7529
--- /dev/null
+++ b/math/tomsfastmath/pkg-descr
@@ -0,0 +1,4 @@
+TomsFastMath is a portable fixed precision math library designed for
+very fast exponentiations.
+
+WWW: http://www.libtomcrypt.org/tfm
diff --git a/math/tomsfastmath/pkg-plist b/math/tomsfastmath/pkg-plist
new file mode 100644
index 000000000000..46d3ff738cc8
--- /dev/null
+++ b/math/tomsfastmath/pkg-plist
@@ -0,0 +1,2 @@
+include/tfm.h
+lib/libtfm.a