aboutsummaryrefslogtreecommitdiff
path: root/math/topcom
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-12-06 00:47:35 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-12-06 00:47:35 +0000
commit7d8065129894a7360ea86c2da0e2bf3eaadf6369 (patch)
tree9bd203d096001baaff56528c56c0749a2a601c58 /math/topcom
parent6972d58b6968bcaea2074d51517318a25f0e8c27 (diff)
downloadports-7d8065129894a7360ea86c2da0e2bf3eaadf6369.tar.gz
ports-7d8065129894a7360ea86c2da0e2bf3eaadf6369.zip
New port: math/topcom: Computing triangulations of point configurations and oriented matroids
Notes
Notes: svn path=/head/; revision=486728
Diffstat (limited to 'math/topcom')
-rw-r--r--math/topcom/Makefile37
-rw-r--r--math/topcom/distinfo3
-rw-r--r--math/topcom/pkg-descr6
-rw-r--r--math/topcom/pkg-plist99
4 files changed, 145 insertions, 0 deletions
diff --git a/math/topcom/Makefile b/math/topcom/Makefile
new file mode 100644
index 000000000000..222d90b592a2
--- /dev/null
+++ b/math/topcom/Makefile
@@ -0,0 +1,37 @@
+# $FreeBSD$
+
+PORTNAME= topcom
+DISTVERSIONPREFIX= Release_
+DISTVERSION= 0.17.8
+CATEGORIES= math
+MASTER_SITES= http://www.rambau.wm.uni-bayreuth.de/Software/
+DISTNAME= ${PORTNAME:tu}-${DISTVERSION}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Computing triangulations of point configurations and oriented matroids
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libcddgmp.so:math/cddlib \
+ libgmp.so:math/gmp
+
+USES= autoreconf gmake localbase:ldflags
+GNU_CONFIGURE= yes
+
+CFLAGS+= -I${LOCALBASE}/include/cdd/
+LDFLAGS+= -lgmp -lgmpxx -lcddgmp
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
+
+post-extract:
+ @${RM} -r ${WRKSRC}/external
+
+post-patch:
+ @${FIND} ${WRKSRC} -name "Makefile*" \
+ | ${XARGS} ${REINPLACE_CMD} ' \
+ s|\.\./external/lib/libcddgmp\.a|${LOCALBASE}/lib/libcddgmp.so| ; \
+ s|\.\./external/lib/libgmp\.a|${LOCALBASE}/lib/libgmp.so| ; \
+ s|\.\./external/lib/libgmpxx\.a|${LOCALBASE}/lib/libgmpxx.so|'
+
+.include <bsd.port.mk>
diff --git a/math/topcom/distinfo b/math/topcom/distinfo
new file mode 100644
index 000000000000..dde574ff54cd
--- /dev/null
+++ b/math/topcom/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1544052159
+SHA256 (TOPCOM-0.17.8.tar.gz) = 3f83b98f51ee859ec321bacabf7b172c25884f14848ab6c628326b987bd8aaab
+SIZE (TOPCOM-0.17.8.tar.gz) = 8994044
diff --git a/math/topcom/pkg-descr b/math/topcom/pkg-descr
new file mode 100644
index 000000000000..197c97e7f338
--- /dev/null
+++ b/math/topcom/pkg-descr
@@ -0,0 +1,6 @@
+TOPCOM is a package for computing Triangulations Of Point Configurations and
+Oriented Matroids. It was very much inspired by the maple program PUNTOS, which
+was written by Jesus de Loera. TOPCOM is entirely written in C++, so there is a
+significant speed up compared to PUNTOS.
+
+WWW: http://www.rambau.wm.uni-bayreuth.de/TOPCOM/
diff --git a/math/topcom/pkg-plist b/math/topcom/pkg-plist
new file mode 100644
index 000000000000..8d35b5d72618
--- /dev/null
+++ b/math/topcom/pkg-plist
@@ -0,0 +1,99 @@
+bin/B_A
+bin/B_A_center
+bin/B_D
+bin/checkregularity
+bin/chiro2allfinetriangs
+bin/chiro2alltriangs
+bin/chiro2circuits
+bin/chiro2cocircuits
+bin/chiro2dual
+bin/chiro2finetriang
+bin/chiro2finetriangs
+bin/chiro2mintriang
+bin/chiro2nallfinetriangs
+bin/chiro2nalltriangs
+bin/chiro2nfinetriangs
+bin/chiro2ntriangs
+bin/chiro2placingtriang
+bin/chiro2triangs
+bin/cocircuits2facets
+bin/cross
+bin/cube
+bin/cyclic
+bin/hypersimplex
+bin/lattice
+bin/points2allfinetriangs
+bin/points2alltriangs
+bin/points2chiro
+bin/points2facets
+bin/points2finetriang
+bin/points2finetriangs
+bin/points2flips
+bin/points2nallfinetriangs
+bin/points2nalltriangs
+bin/points2nfinetriangs
+bin/points2nflips
+bin/points2ntriangs
+bin/points2placingtriang
+bin/points2triangs
+bin/points2volume
+bin/santos_22_triang
+bin/santos_dim4_triang
+bin/santos_triang
+include/Admissibles.hh
+include/Array.hh
+include/CheckTriang.hh
+include/Chirotope.hh
+include/Circuits.hh
+include/Cocircuits.hh
+include/CommandlineOptions.hh
+include/CompressedIntegerSet.hh
+include/ComputeTriangs.hh
+include/Facets.hh
+include/FastSimplicialComplex.hh
+include/Field.hh
+include/FineTriang.hh
+include/Flip.hh
+include/Global.hh
+include/HashKey.hh
+include/HashMap.hh
+include/HashSet.hh
+include/IndexTableArray.hh
+include/Integer.h
+include/IntegerSet.hh
+include/InteriorFacets.hh
+include/LPinterface.hh
+include/MarkedFlips.hh
+include/Matrix.hh
+include/Pair.hh
+include/PartialTriang.hh
+include/Permutation.hh
+include/PlacingTriang.hh
+include/PlainArray.hh
+include/PlainHashIndexTable.hh
+include/PlainHashMap.hh
+include/PlainHashSet.hh
+include/PlainHashTable.hh
+include/PointConfiguration.hh
+include/Rational.h
+include/RealChiro.hh
+include/RefCount.hh
+include/RegularityCheck.hh
+include/SPXinterface.hh
+include/SimplicialComplex.hh
+include/SimplicialComplexTemplate.hh
+include/SimplicialComplexTemplate_Declarations.hh
+include/SimplicialComplexTemplate_Definitions.hh
+include/SparseIntegerSet.hh
+include/SparseSimplicialComplex.hh
+include/StairCaseMatrix.hh
+include/SymmetricBFS.hh
+include/Symmetry.hh
+include/TriangFlips.hh
+include/TriangNode.hh
+include/Vector.hh
+include/VertexFacetTable.hh
+include/VertexFacetTableArray.hh
+include/VirtualChiro.hh
+lib/libCHECKREG.a
+lib/libTOPCOM.a