aboutsummaryrefslogtreecommitdiff
path: root/math/triangle
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-08-05 00:44:37 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-08-05 00:44:37 +0000
commit3b645af29ddf9763d295f798be4eceaf5158c124 (patch)
treeed03178b322b78f36ad2b1240e486f0f75396bb2 /math/triangle
parent9570014a753975d835354aa4b07dc4e2d1ae5a4e (diff)
downloadports-3b645af29ddf9763d295f798be4eceaf5158c124.tar.gz
ports-3b645af29ddf9763d295f798be4eceaf5158c124.zip
math/triangle: Install the header; build and install the shared library
Reason: other packages expect headers/library. Other port changes: * Order the USExx section * Simplify the test target * Change WWW to https
Notes
Notes: svn path=/head/; revision=476383
Diffstat (limited to 'math/triangle')
-rw-r--r--math/triangle/Makefile24
-rw-r--r--math/triangle/pkg-descr2
2 files changed, 16 insertions, 10 deletions
diff --git a/math/triangle/Makefile b/math/triangle/Makefile
index 123a4c427439..81ed26a3ff4a 100644
--- a/math/triangle/Makefile
+++ b/math/triangle/Makefile
@@ -3,7 +3,7 @@
PORTNAME= triangle
PORTVERSION= 1.6
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= math
MASTER_SITES= NL/voronoi
DISTNAME= ${PORTNAME}
@@ -14,19 +14,25 @@ COMMENT= Two-Dimensional Quality Mesh Generator and Delaunay Triangulator
NO_CDROM= No commercial use without prior arrangement with the author
-NO_WRKSUBDIR= yes
USES= zip
-USE_XORG= x11
+NO_WRKSUBDIR= yes
MAKEFILE= makefile
+USE_XORG= x11
+USE_LDCONFIG= yes
+
+PLIST_FILES= bin/${PORTNAME} bin/showme \
+ include/${PORTNAME}.h \
+ lib/lib${PORTNAME}.so
-PLIST_FILES= bin/triangle bin/showme
+post-build:
+ @cd ${WRKSRC} && ${CC} ${CFLAGS} ${LDFLAGS} -shared -fPIC -o lib${PORTNAME}.so ${PORTNAME}.c
do-install:
- ${INSTALL_PROGRAM} ${PLIST_FILES:S|^bin|${WRKSRC}|} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${WRKSRC}/showme ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.h ${STAGEDIR}${PREFIX}/include
+ ${INSTALL_DATA} ${WRKSRC}/lib${PORTNAME}.so ${STAGEDIR}${PREFIX}/lib
-.if defined(MAINTAINER_MODE)
-test: build
- (cd ${INSTALL_WRKSRC} && ./triangle -p A.poly && ./showme A.1.poly)
-.endif
+do-test: build
+ @cd ${INSTALL_WRKSRC} && ./${PORTNAME} -p A.poly && ./showme A.1.poly
.include <bsd.port.mk>
diff --git a/math/triangle/pkg-descr b/math/triangle/pkg-descr
index 7a8d3d7dd95d..28ae533d624a 100644
--- a/math/triangle/pkg-descr
+++ b/math/triangle/pkg-descr
@@ -8,4 +8,4 @@ especially those generated by Triangle, my two-dimensional quality mesh
generator and Delaunay triangulator.
Show Me can also write PostScript images to files.
-WWW: http://www.cs.cmu.edu/~quake/triangle.html
+WWW: https://www.cs.cmu.edu/~quake/triangle.html