aboutsummaryrefslogtreecommitdiff
path: root/math/triangle
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
commit3e4ed01146cfe2bdca465bd0e4d199341f62a0b6 (patch)
treed573ea09b2bf6be67cb497df199932da9e2707c4 /math/triangle
parent40049f4af2200d0dcf33596508688623fc75f764 (diff)
downloadports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.tar.gz
ports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=211584
Diffstat (limited to 'math/triangle')
-rw-r--r--math/triangle/Makefile4
-rw-r--r--math/triangle/files/patch-makefile2
2 files changed, 3 insertions, 3 deletions
diff --git a/math/triangle/Makefile b/math/triangle/Makefile
index b02cee8cd8b0..269ecd6a2ade 100644
--- a/math/triangle/Makefile
+++ b/math/triangle/Makefile
@@ -7,7 +7,7 @@
PORTNAME= triangle
PORTVERSION= 1.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math
MASTER_SITES= http://cm.bell-labs.com/netlib/voronoi/
DISTNAME= ${PORTNAME}
@@ -20,7 +20,7 @@ NO_CDROM= "Triangle must not be sold for profit"
NO_WRKSUBDIR= yes
USE_ZIP= yes
-USE_XLIB= yes
+USE_XORG= x11
MAKEFILE= makefile
PLIST_FILES= bin/triangle bin/showme
diff --git a/math/triangle/files/patch-makefile b/math/triangle/files/patch-makefile
index abd4ddd335d2..c20ae2a85670 100644
--- a/math/triangle/files/patch-makefile
+++ b/math/triangle/files/patch-makefile
@@ -14,7 +14,7 @@
# CSWITCHES = -O -DNO_TIMER -DLINUX -I/usr/X11R6/include -L/usr/X11R6/lib
-CSWITCHES = -O -DLINUX -I/usr/X11R6/include -L/usr/X11R6/lib
-+CSWITCHES = ${CFLAGS} -I${X11BASE}/include -L${X11BASE}/lib
++CSWITCHES = ${CFLAGS} -I${LOCALBASE}/include -L${LOCALBASE}/lib
# TRILIBDEFS is a list of definitions used to compile an object code version
# of Triangle (triangle.o) to be called by another program. The file