aboutsummaryrefslogtreecommitdiff
path: root/math/tvmet
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-06-06 18:11:49 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-06-06 18:11:49 +0000
commitcaa36f0a9862c6be1688bf1437cb90329a89eae5 (patch)
tree53abbb3667bcda66e4a9b71d95f63d2134c0a322 /math/tvmet
parent35a505c2e005656da15341010d783984f44bd6a1 (diff)
downloadports-caa36f0a9862c6be1688bf1437cb90329a89eae5.tar.gz
ports-caa36f0a9862c6be1688bf1437cb90329a89eae5.zip
- Update to 1.7.1
- Provide WITH_CPPUNIT knob PR: ports/81959 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Notes
Notes: svn path=/head/; revision=136923
Diffstat (limited to 'math/tvmet')
-rw-r--r--math/tvmet/Makefile12
-rw-r--r--math/tvmet/distinfo4
-rw-r--r--math/tvmet/files/patch-Makefile.in11
-rw-r--r--math/tvmet/pkg-plist122
4 files changed, 85 insertions, 64 deletions
diff --git a/math/tvmet/Makefile b/math/tvmet/Makefile
index 2bfe065c1a8e..bba4e2e7f1c1 100644
--- a/math/tvmet/Makefile
+++ b/math/tvmet/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= tvmet
-PORTVERSION= 1.1.0
+PORTVERSION= 1.7.1
CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,10 +16,18 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Tiny Vector and Matrix template library
USE_BZIP2= yes
+USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-MAN1= tvmet-config.1
+MAN1= tvmet-config.1
+
+.if defined(WITH_CPPUNIT)
+LIB_DEPENDS+= cppunit-1.10.2:${PORTSDIR}/devel/cppunit
+CONFIGURE_ARGS+= --with-cppunit-prefix=${LOCALBASE}
+.else
+CONFIGURE_ENV+= ac_cv_path_CPPUNIT_CONFIG=no
+.endif
post-install:
.if !defined(NOPORTDOCS)
diff --git a/math/tvmet/distinfo b/math/tvmet/distinfo
index 0bb269a312bb..95e2a60fdf0d 100644
--- a/math/tvmet/distinfo
+++ b/math/tvmet/distinfo
@@ -1,2 +1,2 @@
-MD5 (tvmet-1.1.0.tar.bz2) = 1b1df56775837073cfab4553519a8969
-SIZE (tvmet-1.1.0.tar.bz2) = 207814
+MD5 (tvmet-1.7.1.tar.bz2) = e6e44e38ff51229e1b3e215286131f08
+SIZE (tvmet-1.7.1.tar.bz2) = 522923
diff --git a/math/tvmet/files/patch-Makefile.in b/math/tvmet/files/patch-Makefile.in
deleted file mode 100644
index 02550123f9cb..000000000000
--- a/math/tvmet/files/patch-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.in.orig Tue Feb 11 00:36:50 2003
-+++ Makefile.in Tue Feb 11 04:12:23 2003
-@@ -88,7 +88,7 @@
-
- ACLOCAL_AMFLAGS = -I config
-
--SUBDIRS = include doc regression tests benchmark examples
-+SUBDIRS = include regression tests benchmark
- DIST_SUBDIRS = include doc regression tests benchmark examples config
-
- m4sources = \
diff --git a/math/tvmet/pkg-plist b/math/tvmet/pkg-plist
index a3373ec0e30d..690479b2c17c 100644
--- a/math/tvmet/pkg-plist
+++ b/math/tvmet/pkg-plist
@@ -1,108 +1,132 @@
@comment $FreeBSD$
bin/tvmet-config
+include/tvmet/AliasProxy.h
include/tvmet/BinaryFunctionals.h
include/tvmet/CommaInitializer.h
include/tvmet/CompileTimeError.h
include/tvmet/Extremum.h
include/tvmet/Functional.h
+include/tvmet/Io.h
include/tvmet/Matrix.h
+include/tvmet/MatrixBinaryFunctions.h
include/tvmet/MatrixEval.h
include/tvmet/MatrixFunctions.h
include/tvmet/MatrixImpl.h
include/tvmet/MatrixOperators.h
+include/tvmet/MatrixUnaryFunctions.h
include/tvmet/NumericTraits.h
include/tvmet/RunTimeError.h
include/tvmet/TvmetBase.h
include/tvmet/TypePromotion.h
include/tvmet/UnaryFunctionals.h
include/tvmet/Vector.h
+include/tvmet/VectorBinaryFunctions.h
include/tvmet/VectorEval.h
include/tvmet/VectorFunctions.h
include/tvmet/VectorImpl.h
include/tvmet/VectorOperators.h
+include/tvmet/VectorUnaryFunctions.h
include/tvmet/config/config-gcc.h
include/tvmet/config/config-icc.h
include/tvmet/config/config-kcc.h
include/tvmet/config/config-pgi.h
+include/tvmet/config/config-vc71.h
+include/tvmet/config/config-vc71.h.in
include/tvmet/config.h
+include/tvmet/loop/Gemm.h
+include/tvmet/loop/Gemmt.h
+include/tvmet/loop/Gemtm.h
+include/tvmet/loop/Gemtv.h
+include/tvmet/loop/Gemv.h
+include/tvmet/loop/Matrix.h
+include/tvmet/loop/Vector.h
include/tvmet/meta/Gemm.h
include/tvmet/meta/Gemmt.h
include/tvmet/meta/Gemtm.h
+include/tvmet/meta/Gemtv.h
include/tvmet/meta/Gemv.h
include/tvmet/meta/Matrix.h
include/tvmet/meta/Vector.h
include/tvmet/tvmet.h
include/tvmet/util/General.h
+include/tvmet/util/Incrementor.h
+include/tvmet/util/Random.h
include/tvmet/util/Timer.h
include/tvmet/xpr/BinOperator.h
-include/tvmet/xpr/ConstRef.h
include/tvmet/xpr/Eval.h
-include/tvmet/xpr/Functions.h
+include/tvmet/xpr/Identity.h
include/tvmet/xpr/Literal.h
include/tvmet/xpr/MMProduct.h
include/tvmet/xpr/MMProductTransposed.h
include/tvmet/xpr/MMtProduct.h
include/tvmet/xpr/MVProduct.h
include/tvmet/xpr/Matrix.h
+include/tvmet/xpr/MatrixBinaryFunctions.h
+include/tvmet/xpr/MatrixCol.h
+include/tvmet/xpr/MatrixDiag.h
include/tvmet/xpr/MatrixFunctions.h
include/tvmet/xpr/MatrixOperators.h
+include/tvmet/xpr/MatrixRow.h
include/tvmet/xpr/MatrixTranspose.h
+include/tvmet/xpr/MatrixUnaryFunctions.h
include/tvmet/xpr/MtMProduct.h
+include/tvmet/xpr/MtVProduct.h
include/tvmet/xpr/Null.h
include/tvmet/xpr/UnOperator.h
include/tvmet/xpr/Vector.h
+include/tvmet/xpr/VectorBinaryFunctions.h
include/tvmet/xpr/VectorFunctions.h
include/tvmet/xpr/VectorOperators.h
-include/tvmet/xpr/Xpr.h
+include/tvmet/xpr/VectorUnaryFunctions.h
share/aclocal/tvmet.m4
-%%PORTDOCS%%share/doc/tvmet/Util.h
-%%PORTDOCS%%share/doc/tvmet/bench_daxpy.png
-%%PORTDOCS%%share/doc/tvmet/bench_matrix_matrix_product.png
-%%PORTDOCS%%share/doc/tvmet/bench_matrix_vector_product.png
-%%PORTDOCS%%share/doc/tvmet/bench_vector_add.png
-%%PORTDOCS%%share/doc/tvmet/bench_vector_inner_product.png
-%%PORTDOCS%%share/doc/tvmet/benchmark.dox
-%%PORTDOCS%%share/doc/tvmet/build.dox
-%%PORTDOCS%%share/doc/tvmet/changelog.dox
-%%PORTDOCS%%share/doc/tvmet/compiler.dox
-%%PORTDOCS%%share/doc/tvmet/credits.dox
-%%PORTDOCS%%share/doc/tvmet/dox_functions.cc
-%%PORTDOCS%%share/doc/tvmet/dox_operators.cc
-%%PORTDOCS%%share/doc/tvmet/faq.dox
-%%PORTDOCS%%share/doc/tvmet/functions.dox
-%%PORTDOCS%%share/doc/tvmet/install.dox
-%%PORTDOCS%%share/doc/tvmet/intro.dox
-%%PORTDOCS%%share/doc/tvmet/license.dox
-%%PORTDOCS%%share/doc/tvmet/links.dox
-%%PORTDOCS%%share/doc/tvmet/misc.dox
-%%PORTDOCS%%share/doc/tvmet/notes.dox
-%%PORTDOCS%%share/doc/tvmet/operators.dox
-%%PORTDOCS%%share/doc/tvmet/projects.dox
-%%PORTDOCS%%share/doc/tvmet/sflogo.png
-%%PORTDOCS%%share/doc/tvmet/tvmet.css
-%%PORTDOCS%%share/doc/tvmet/usage.dox
-%%PORTDOCS%%share/doc/tvmet/works.dox
-%%PORTDOCS%%share/examples/tvmet/cmm.cc
-%%PORTDOCS%%share/examples/tvmet/cmv.cc
-%%PORTDOCS%%share/examples/tvmet/diag.cc
-%%PORTDOCS%%share/examples/tvmet/matrix_col.cc
-%%PORTDOCS%%share/examples/tvmet/mm.cc
-%%PORTDOCS%%share/examples/tvmet/mv.cc
-%%PORTDOCS%%share/examples/tvmet/ray.cc
-%%PORTDOCS%%share/examples/tvmet/xpr_print_m1.cc
-%%PORTDOCS%%share/examples/tvmet/xpr_print_m2.cc
-%%PORTDOCS%%share/examples/tvmet/xpr_print_m3.cc
-%%PORTDOCS%%share/examples/tvmet/xpr_print_m4.cc
-%%PORTDOCS%%share/examples/tvmet/xpr_print_mv1.cc
-%%PORTDOCS%%share/examples/tvmet/xpr_print_mv2.cc
-%%PORTDOCS%%share/examples/tvmet/xpr_print_v1.cc
-%%PORTDOCS%%share/examples/tvmet/xpr_print_v2.cc
-%%PORTDOCS%%share/examples/tvmet/xpr_print_v3.cc
-%%PORTDOCS%%share/examples/tvmet/xpr_print_v4.cc
-%%PORTDOCS%%@dirrm share/examples/tvmet
-%%PORTDOCS%%@dirrm share/doc/tvmet
+%%PORTDOCS%%%%DOCSDIR%%/Util.h
+%%PORTDOCS%%%%DOCSDIR%%/aat.png
+%%PORTDOCS%%%%DOCSDIR%%/ata.png
+%%PORTDOCS%%%%DOCSDIR%%/axpy.png
+%%PORTDOCS%%%%DOCSDIR%%/benchmark.dox
+%%PORTDOCS%%%%DOCSDIR%%/build.dox
+%%PORTDOCS%%%%DOCSDIR%%/compiler.dox
+%%PORTDOCS%%%%DOCSDIR%%/dox_functions.cc
+%%PORTDOCS%%%%DOCSDIR%%/dox_operators.cc
+%%PORTDOCS%%%%DOCSDIR%%/faq.dox
+%%PORTDOCS%%%%DOCSDIR%%/intro.dox
+%%PORTDOCS%%%%DOCSDIR%%/license.dox
+%%PORTDOCS%%%%DOCSDIR%%/links.dox
+%%PORTDOCS%%%%DOCSDIR%%/matrix_matrix.png
+%%PORTDOCS%%%%DOCSDIR%%/matrix_vector.png
+%%PORTDOCS%%%%DOCSDIR%%/misc.dox
+%%PORTDOCS%%%%DOCSDIR%%/notes.dox
+%%PORTDOCS%%%%DOCSDIR%%/projects.dox
+%%PORTDOCS%%%%DOCSDIR%%/tvmet.css
+%%PORTDOCS%%%%DOCSDIR%%/usage.dox
+%%PORTDOCS%%%%DOCSDIR%%/works.dox
+%%PORTDOCS%%%%EXAMPLESDIR%%/alias.cc
+%%PORTDOCS%%%%EXAMPLESDIR%%/aliasing.cc
+%%PORTDOCS%%%%EXAMPLESDIR%%/cmm.cc
+%%PORTDOCS%%%%EXAMPLESDIR%%/cmv.cc
+%%PORTDOCS%%%%EXAMPLESDIR%%/diag.cc
+%%PORTDOCS%%%%EXAMPLESDIR%%/frob_matrix_norm.cc
+%%PORTDOCS%%%%EXAMPLESDIR%%/hspiess.cc
+%%PORTDOCS%%%%EXAMPLESDIR%%/matrix_col.cc
+%%PORTDOCS%%%%EXAMPLESDIR%%/mm.cc
+%%PORTDOCS%%%%EXAMPLESDIR%%/mv.cc
+%%PORTDOCS%%%%EXAMPLESDIR%%/ray.cc
+%%PORTDOCS%%%%EXAMPLESDIR%%/redwards.cc
+%%PORTDOCS%%%%EXAMPLESDIR%%/xpr_print_m1.cc
+%%PORTDOCS%%%%EXAMPLESDIR%%/xpr_print_m2.cc
+%%PORTDOCS%%%%EXAMPLESDIR%%/xpr_print_m3.cc
+%%PORTDOCS%%%%EXAMPLESDIR%%/xpr_print_m4.cc
+%%PORTDOCS%%%%EXAMPLESDIR%%/xpr_print_mv1.cc
+%%PORTDOCS%%%%EXAMPLESDIR%%/xpr_print_mv2.cc
+%%PORTDOCS%%%%EXAMPLESDIR%%/xpr_print_v1.cc
+%%PORTDOCS%%%%EXAMPLESDIR%%/xpr_print_v2.cc
+%%PORTDOCS%%%%EXAMPLESDIR%%/xpr_print_v3.cc
+%%PORTDOCS%%%%EXAMPLESDIR%%/xpr_print_v4.cc
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm include/tvmet/xpr
@dirrm include/tvmet/util
@dirrm include/tvmet/meta
+@dirrm include/tvmet/loop
@dirrm include/tvmet/config
@dirrm include/tvmet