aboutsummaryrefslogtreecommitdiff
path: root/math/ump
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
commit3e4ed01146cfe2bdca465bd0e4d199341f62a0b6 (patch)
treed573ea09b2bf6be67cb497df199932da9e2707c4 /math/ump
parent40049f4af2200d0dcf33596508688623fc75f764 (diff)
downloadports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.tar.gz
ports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=211584
Diffstat (limited to 'math/ump')
-rw-r--r--math/ump/Makefile11
-rw-r--r--math/ump/files/patch-Makefile4
2 files changed, 6 insertions, 9 deletions
diff --git a/math/ump/Makefile b/math/ump/Makefile
index 60c147c11f2d..b6019971cc28 100644
--- a/math/ump/Makefile
+++ b/math/ump/Makefile
@@ -7,10 +7,9 @@
PORTNAME= ump
PORTVERSION= 0.8.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= u-m-p
+MASTER_SITES= SF/u-m-p
MAINTAINER= nivit@FreeBSD.org
COMMENT= A graphical, easy to use math program
@@ -21,14 +20,12 @@ LATEST_LINK= math-ump
USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME= gtk20
-USE_GL= yes
-USE_X_PREFIX= yes
+USE_GL= glu
ALL_TARGET= ${PORTNAME}
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-MAKE_ENV+= CXX="${CXX}" CC="${CC}" DATADIR="${DATADIR}" \
- X11BASE="${X11BASE}"
+MAKE_ENV+= CXX="${CXX}" CC="${CC}" DATADIR="${DATADIR}"
FIND_DIRS= -type d
FIND_DATA= -type f
diff --git a/math/ump/files/patch-Makefile b/math/ump/files/patch-Makefile
index 7bda4aeff1fd..8ebe30a21800 100644
--- a/math/ump/files/patch-Makefile
+++ b/math/ump/files/patch-Makefile
@@ -20,7 +20,7 @@
FLAGS += -DPLOT_3D
## You might have to change this path
-GL_LIB = -lGL -lGLU -L/usr/X11/lib
-+GL_LIB = -lGL -lGLU -L$(X11BASE)/lib
++GL_LIB = -lGL -lGLU -L$(LOCALBASE)/lib
## The next path will be required on some Mac-systems to compile
##FLAGS += -I/usr/X11/include/GL
@@ -42,7 +42,7 @@
+FLAGS += -DDONT_HAVE_LOG2
+## X11 includes
-+FLAGS += -I$(X11BASE)/include
++FLAGS += -I$(LOCALBASE)/include
## If you'd like to compile with debuging info avaliable
##FLAGS += -ggdb