aboutsummaryrefslogtreecommitdiff
path: root/math/ump
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2006-07-10 15:44:43 +0000
committerErwin Lansing <erwin@FreeBSD.org>2006-07-10 15:44:43 +0000
commit6712d8c300663fa3c10e18281e2c2919f9b8beba (patch)
tree739ea599e8b528b1ed8f19470c62723e4448d43e /math/ump
parent73b224f1d8b5a744b48743206dd62828ad89d53d (diff)
downloadports-6712d8c300663fa3c10e18281e2c2919f9b8beba.tar.gz
ports-6712d8c300663fa3c10e18281e2c2919f9b8beba.zip
Update to 0.8.4
PR: 100022 Submitted by: Nicola Vitale <nivit@email.it> (maintainer)
Notes
Notes: svn path=/head/; revision=167358
Diffstat (limited to 'math/ump')
-rw-r--r--math/ump/Makefile6
-rw-r--r--math/ump/distinfo12
-rw-r--r--math/ump/files/patch-Makefile49
-rw-r--r--math/ump/files/patch-src-main.cpp8
-rw-r--r--math/ump/pkg-plist5
5 files changed, 45 insertions, 35 deletions
diff --git a/math/ump/Makefile b/math/ump/Makefile
index 592d9f5c4908..59977b9199f8 100644
--- a/math/ump/Makefile
+++ b/math/ump/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= ump
-PORTVERSION= 0.8.3.2
+PORTVERSION= 0.8.4
CATEGORIES= math
MASTER_SITES= http://home.swipnet.se/${PORTNAME}/downloads/ \
http://nivi.interfree.it/distfiles/${PORTNAME}/
@@ -34,8 +34,8 @@ FIND_DIRS= -type d
FIND_DATA= -type f
.if !defined(NOPORTDOCS)
-DOCSDIST= ${PORTNAME}-${PORTVERSION:C/\.[0-9]$//}-doc
-DISTFILES+= ${DOCSDIST}${EXTRACT_SUFX}
+DOCSDIST= ${PORTNAME}-${PORTVERSION}-doc
+DISTFILES+= ${PORTNAME}-documentation${EXTRACT_SUFX}
.endif
.include <bsd.port.pre.mk>
diff --git a/math/ump/distinfo b/math/ump/distinfo
index bfab4943937d..84eeac1827e9 100644
--- a/math/ump/distinfo
+++ b/math/ump/distinfo
@@ -1,6 +1,6 @@
-MD5 (ump-0.8.3.2-src.tar.bz2) = 01eca52831936984c08625af4589f009
-SHA256 (ump-0.8.3.2-src.tar.bz2) = db4a05f727a815918fec5a4733271ba875e305e0e163d5cfc776bdc2563d10d1
-SIZE (ump-0.8.3.2-src.tar.bz2) = 127121
-MD5 (ump-0.8.3-doc.tar.bz2) = 8b810fe6b7dcbc72aef96c3905046129
-SHA256 (ump-0.8.3-doc.tar.bz2) = 72196d62ba32108e83e6d9b5cc1716e451e9172ad6f3ecaafc369582858b2f96
-SIZE (ump-0.8.3-doc.tar.bz2) = 67390
+MD5 (ump-0.8.4-src.tar.bz2) = e33d98078ddd407d72a3bdebcd2d73da
+SHA256 (ump-0.8.4-src.tar.bz2) = 9c985e00ce4153e0c51104e1827fe27aac22ef4280bb4659b2c744793e5ecf54
+SIZE (ump-0.8.4-src.tar.bz2) = 131645
+MD5 (ump-documentation.tar.bz2) = 894df8966d7c76e1c765636c9352ee05
+SHA256 (ump-documentation.tar.bz2) = 11f648ae892a621b15c5e815a07c4fddfcb196a00ba12b30c5715a9b405f70db
+SIZE (ump-documentation.tar.bz2) = 67908
diff --git a/math/ump/files/patch-Makefile b/math/ump/files/patch-Makefile
index 8cabf98a0a9c..b4a69ff27818 100644
--- a/math/ump/files/patch-Makefile
+++ b/math/ump/files/patch-Makefile
@@ -1,6 +1,6 @@
---- Makefile.orig Wed Apr 5 14:41:05 2006
-+++ Makefile Thu May 4 16:50:55 2006
-@@ -2,25 +2,24 @@
+--- Makefile Sun Jul 9 12:51:41 2006
++++ Makefile.port Mon Jul 10 14:07:04 2006
+@@ -2,19 +2,19 @@
APP_NAME = ump
## Change this directory name as you like, it's the installation directory
@@ -23,26 +23,29 @@
+GL_LIB = -lGL -lGLU -L$(X11BASE)/lib
+ ## This will give auto completion in the main window, but it requires GTK+2.6
+@@ -25,7 +25,7 @@
## Choose your optimization level
##FLAGS += -O0
-FLAGS += -O2
++##FLAGS += -O2
##FLAGS += -O3
##FLAGS += -Os
-@@ -35,7 +34,10 @@
+@@ -40,8 +40,10 @@
## Uncomment one or both of these if the compilation failes
## due to trunc undefined or log2 undefined
##FLAGS += -DDONT_HAVE_TRUNC
-##FLAGS += -DDONT_HAVE_LOG2
+FLAGS += -DDONT_HAVE_LOG2
-+
-+# include X11 libs
-+FLAGS += -I$(X11BASE)/include
++# X11 includes
++FLAGS += -I$(X11BASE)/include
-@@ -82,7 +84,7 @@
+ ## If you'd like to compile with debuging info avaliable
+@@ -87,7 +89,7 @@
# $< means the name of the first prerequisite
$(APP_NAME): Makefile $(OBJ_FILES) main.o $(GUI_OBJ) addon_functions.o $(ASM_FILES)
@@ -51,8 +54,8 @@
clean:
-rm -f $(OBJ_FILES)
-@@ -93,18 +95,16 @@
- -rm -f translation_svenska.c
+@@ -99,18 +101,16 @@
+ -rm -f inliner
text: Makefile $(OBJ_FILES) addon_functions.text.o $(ASM_FILES)
- g++ $(FLAGS) $(FILES) $(OBJ_FILES) addon_functions.text.o $(ASM_FILES) -DNO_GTK -o $(APP_NAME) -DDATA_DIR=\"$(DATA_DIR)\" -DFLAGS="\"$(FLAGS)\"" $(GL_LIB)
@@ -73,20 +76,20 @@
uninstall:
rm -f $(BIN_DIR)/$(APP_NAME)
-@@ -114,106 +114,106 @@
+@@ -120,107 +120,107 @@
main.o: $(FILES) Makefile $(GUI_HEADER) $(SRC)/vector.h $(SRC)/integer.h $(SRC)/real.h $(SRC)/complex.h $(SRC)/matrix.h $(SRC)/math2.h $(SRC)/vartypes.h $(SRC)/picture.h $(SRC)/addon_functions.h $(SRC)/ump_3d_viewer.h
-- g++ $(FLAGS) $(ASM_FLAG) -c $(GTK_CFLAGS) $(FILES) -o $@ -DDATA_DIR=\"$(DATA_DIR)\" -DFLAGS="\"$(FLAGS)\""
-+ $(CXX) $(FLAGS) $(ASM_FLAG) -c $(GTK_CFLAGS) $(FILES) -o $@ -DDATA_DIR=\"$(DATA_DIR)\" -DFLAGS="\"$(FLAGS)\""
+- g++ $(FLAGS) -c $(GTK_CFLAGS) $(FILES) -o $@ -DDATA_DIR=\"$(DATA_DIR)\" -DFLAGS="\"$(FLAGS)\""
++ $(CXX) $(FLAGS) -c $(GTK_CFLAGS) $(FILES) -o $@ -DDATA_DIR=\"$(DATA_DIR)\" -DFLAGS="\"$(FLAGS)\""
picture2gtk.o: $(SRC)/picture2gtk.cpp Makefile $(SRC)/picture2gtk.h $(SRC)/vartypes.h $(SRC)/picture.h
- g++ $(FLAGS) -c $(GTK_CFLAGS) $< -o $@
+ $(CXX) $(FLAGS) -c $(GTK_CFLAGS) $< -o $@
ump_advancedwin.o: $(SRC)/ump_advancedwin.cpp Makefile $(SRC)/vector.h $(SRC)/integer.h $(SRC)/real.h $(SRC)/complex.h $(SRC)/matrix.h $(SRC)/math2.h $(SRC)/picture.h $(GUI_HEADER) $(SRC)/vartypes.h
-- g++ $(FLAGS) -c $(GTK_CFLAGS) $< -o $@
-+ $(CXX) $(FLAGS) -c $(GTK_CFLAGS) $< -o $@
+- g++ $(FLAGS) $(AUTO_COMPLETION) -c $(GTK_CFLAGS) $< -o $@
++ $(CXX) $(FLAGS) $(AUTO_COMPLETION) -c $(GTK_CFLAGS) $< -o $@
ump_3d_viewer.o: $(SRC)/ump_3d_viewer.cpp Makefile $(SRC)/ump_3d_viewer.h $(SRC)/main.h $(SRC)/vector.h $(SRC)/integer.h $(SRC)/real.h $(SRC)/complex.h $(SRC)/matrix.h $(SRC)/math2.h $(SRC)/picture.h $(SRC)/vartypes.h
- g++ $(FLAGS) -c $< -o $@
@@ -96,11 +99,11 @@
- g++ $(FLAGS) -c $(GTK_CFLAGS) $< -o $@
+ $(CXX) $(FLAGS) -c $(GTK_CFLAGS) $< -o $@
- ump_graphwin.o: $(SRC)/ump_graphwin.cpp Makefile $(GUI_HEADER) $(SRC)/vartypes.h $(SRC)/picture.h $(SRC)/integer.h $(SRC)/real.h $(SRC)/complex.h $(SRC)/matrix.h $(SRC)/math2.h $(SRC)/vector.h
+ ump_graphwin.o: $(SRC)/ump_graphwin.cpp Makefile $(GUI_HEADER) $(SRC)/vartypes.h $(SRC)/picture.h $(SRC)/integer.h $(SRC)/real.h $(SRC)/complex.h $(SRC)/matrix.h $(SRC)/math2.h $(SRC)/vector.h $(SRC)/gradient_editor.h
- g++ $(FLAGS) -c $(GTK_CFLAGS) $< -o $@
+ $(CXX) $(FLAGS) -c $(GTK_CFLAGS) $< -o $@
- ump_prefwin.o: $(SRC)/ump_prefwin.cpp Makefile $(SRC)/vector.h $(SRC)/integer.h $(SRC)/picture.h $(SRC)/real.h $(SRC)/complex.h $(SRC)/matrix.h $(SRC)/math2.h $(GUI_HEADER) $(SRC)/vartypes.h
+ ump_prefwin.o: $(SRC)/ump_prefwin.cpp Makefile $(SRC)/vector.h $(SRC)/integer.h $(SRC)/picture.h $(SRC)/real.h $(SRC)/complex.h $(SRC)/matrix.h $(SRC)/math2.h $(GUI_HEADER) $(SRC)/vartypes.h $(SRC)/ump_picturewin.h
- g++ $(FLAGS) -c $(GTK_CFLAGS) $< -o $@
+ $(CXX) $(FLAGS) -c $(GTK_CFLAGS) $< -o $@
@@ -128,7 +131,9 @@
- g++ $(FLAGS) -c -DNO_GTK $(SRC)/addon_functions.cpp -o $@
+ $(CXX) $(FLAGS) -c -DNO_GTK $(SRC)/addon_functions.cpp -o $@
-
+ gradient_editor.o: $(SRC)/gradient_editor.cpp $(SRC)/gradient_editor.h $(SRC)/vector.h $(SRC)/vartypes.h $(SRC)/picture.h
+- g++ $(FLAGS) -c $(GTK_CFLAGS) $< -o $@
++ $(CXX) $(FLAGS) -c $(GTK_CFLAGS) $< -o $@
vartypes.o: $(SRC)/vartypes.cpp Makefile $(SRC)/vartypes.h
- g++ $(FLAGS) -c $< -o $@
@@ -143,8 +148,8 @@
+ $(CXX) $(FLAGS) -c $< -o $@
integer.o: $(SRC)/integer.cpp Makefile $(SRC)/integer.h $(SRC)/vartypes.h
-- g++ $(FLAGS) $(ASM_FLAG) -c $< -o $@
-+ $(CXX) $(FLAGS) $(ASM_FLAG) -c $< -o $@
+- g++ $(FLAGS) -c $< -o $@
++ $(CXX) $(FLAGS) -c $< -o $@
real.o: $(SRC)/real.cpp Makefile $(SRC)/integer.h $(SRC)/real.h $(SRC)/vartypes.h
- g++ $(FLAGS) -c $< -o $@
@@ -201,13 +206,13 @@
## Here we create the converter and convert the Swedish translation file into an inline-file
inliner: $(SRC)/inliner.c Makefile
- gcc $< -o $@
-+ $(CC) $(CFLAGS) $< -o $@
++ $(CC) $< -o $@
translation_svenska.c: translations/Svenska inliner
./inliner $< translation_svenska $@
translation_svenska.o: translation_svenska.c
- gcc $< -c -o $@
-+ $(CC) $(CFLAGS) $< -c -o $@
++ $(CC) $< -c -o $@
diff --git a/math/ump/files/patch-src-main.cpp b/math/ump/files/patch-src-main.cpp
index 66bd4b5c028e..51870e795b28 100644
--- a/math/ump/files/patch-src-main.cpp
+++ b/math/ump/files/patch-src-main.cpp
@@ -1,7 +1,7 @@
---- src/main.cpp Sat Apr 22 01:10:27 2006
-+++ src/main.cpp.port Wed May 3 15:13:45 2006
-@@ -692,7 +692,7 @@
-
+--- src/main.cpp Sun Jun 25 12:48:31 2006
++++ src/main.cpp.port Mon Jul 10 14:08:33 2006
+@@ -682,7 +682,7 @@
+
setup_file.replace_escape_sequences = true;
- try{ setup_file.read( DATA_DIR "/ump.conf" ); }
diff --git a/math/ump/pkg-plist b/math/ump/pkg-plist
index 6694db95c21b..f2e3739cbfd6 100644
--- a/math/ump/pkg-plist
+++ b/math/ump/pkg-plist
@@ -16,7 +16,10 @@ etc/ump.conf.dist
%%PORTDOCS%%%%DOCSDIR%%/degree.html
%%PORTDOCS%%%%DOCSDIR%%/delete.html
%%PORTDOCS%%%%DOCSDIR%%/e.html
+%%PORTDOCS%%%%DOCSDIR%%/equal.html
%%PORTDOCS%%%%DOCSDIR%%/exit.html
+%%PORTDOCS%%%%DOCSDIR%%/factorize.html
+%%PORTDOCS%%%%DOCSDIR%%/fibonacci.html
%%PORTDOCS%%%%DOCSDIR%%/frac.html
%%PORTDOCS%%%%DOCSDIR%%/function_list.html
%%PORTDOCS%%%%DOCSDIR%%/gcd.html
@@ -40,6 +43,7 @@ etc/ump.conf.dist
%%PORTDOCS%%%%DOCSDIR%%/matrix_editor_result.jpeg
%%PORTDOCS%%%%DOCSDIR%%/matrix_editor_right_side.jpeg
%%PORTDOCS%%%%DOCSDIR%%/not.html
+%%PORTDOCS%%%%DOCSDIR%%/not_equal.html
%%PORTDOCS%%%%DOCSDIR%%/or.html
%%PORTDOCS%%%%DOCSDIR%%/pi.html
%%PORTDOCS%%%%DOCSDIR%%/picture.html
@@ -69,6 +73,7 @@ etc/ump.conf.dist
%%DATADIR%%/ump-files/White.ump
%%DATADIR%%/ump-files/Yellow.ump
%%DATADIR%%/ump-files/factorize.ump
+%%DATADIR%%/ump-files/fibonacci.ump
%%DATADIR%%/ump-files/gcd.ump
%%DATADIR%%/ump-files/identity.ump
%%DATADIR%%/ump-files/isMersenne.ump