aboutsummaryrefslogtreecommitdiff
path: root/math/verdict
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2022-11-17 20:38:56 +0000
committerThierry Thomas <thierry@FreeBSD.org>2022-11-17 20:46:48 +0000
commitc51d758dcc5831defa9da24f2452ceaf6d4f9384 (patch)
tree2e068c0a4b11bd64002f74aaa34c2cd65da08e89 /math/verdict
parent68dcf2c91fa47302d8224fbebb7bec190cc0efe9 (diff)
downloadports-c51d758dcc5831defa9da24f2452ceaf6d4f9384.tar.gz
ports-c51d758dcc5831defa9da24f2452ceaf6d4f9384.zip
math/verdict: compute quality functions of 2 and 3-dimensional regions
New port required by science/paraview.
Diffstat (limited to 'math/verdict')
-rw-r--r--math/verdict/Makefile27
-rw-r--r--math/verdict/distinfo3
-rw-r--r--math/verdict/files/patch-CMakeLists.txt11
-rw-r--r--math/verdict/pkg-descr11
-rw-r--r--math/verdict/pkg-plist11
5 files changed, 63 insertions, 0 deletions
diff --git a/math/verdict/Makefile b/math/verdict/Makefile
new file mode 100644
index 000000000000..77a73f9dceca
--- /dev/null
+++ b/math/verdict/Makefile
@@ -0,0 +1,27 @@
+PORTNAME= verdict
+PORTVERSION= 1.4.0
+CATEGORIES= math
+
+MAINTAINER= thierry@FreeBSD.org
+COMMENT= Compute quality functions of 2 and 3-dimensional regions
+WWW= https://github.com/sandialabs/verdict
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libgtest.so:devel/googletest
+
+USE_GITHUB= yes
+GH_ACCOUNT= sandialabs
+
+USES= cmake:testing
+CMAKE_ON= BUILD_SHARED_LIBS
+
+OPTIONS_DEFINE= DOCS
+
+do-install-DOCS-on:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/SAND2007-2853p.pdf ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
+
diff --git a/math/verdict/distinfo b/math/verdict/distinfo
new file mode 100644
index 000000000000..3f0a331cea58
--- /dev/null
+++ b/math/verdict/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1668613891
+SHA256 (sandialabs-verdict-1.4.0_GH0.tar.gz) = 40efa47bced00df650cead5f1525695bb751eaf9145f136177d6c8a718847481
+SIZE (sandialabs-verdict-1.4.0_GH0.tar.gz) = 2193232
diff --git a/math/verdict/files/patch-CMakeLists.txt b/math/verdict/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..ee0f215588e0
--- /dev/null
+++ b/math/verdict/files/patch-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.orig 2022-03-02 17:46:29 UTC
++++ CMakeLists.txt
+@@ -98,7 +98,7 @@ install(FILES
+ # Install documentation
+ install(FILES
+ README.md
+- DESTINATION ${CMAKE_INSTALL_DOCDIR}/verdict/${verdict_VERSION}/ COMPONENT VerdictDevelopment)
++ DESTINATION ${CMAKE_INSTALL_DOCDIR}/ COMPONENT VerdictDevelopment)
+
+ # Install required header files
+ install(FILES
diff --git a/math/verdict/pkg-descr b/math/verdict/pkg-descr
new file mode 100644
index 000000000000..5d45b7af5462
--- /dev/null
+++ b/math/verdict/pkg-descr
@@ -0,0 +1,11 @@
+Verdict is a collection of subroutines for evaluating the geometric qualities
+of triangles, quadrilaterals, tetrahedra, and hexahedra using a variety of
+metrics. A metric is a real number assigned to one of these shapes depending
+on its particular vertex coordinates. These metrics are used to evaluate the
+input to finite element, finite volume, boundary element, and other types
+of solvers that approximate the solution to partial differential equations
+defined over regions of space. The geometric qualities of these regions is
+usually strongly tied to the accuracy these solvers are able to obtain in their
+approximations.
+
+See also <https://gitlab.kitware.com/verdict/verdict/>.
diff --git a/math/verdict/pkg-plist b/math/verdict/pkg-plist
new file mode 100644
index 000000000000..62b1487ab6c6
--- /dev/null
+++ b/math/verdict/pkg-plist
@@ -0,0 +1,11 @@
+include/verdict.h
+include/verdict_config.h
+lib/cmake/verdict/VerdictConfig.cmake
+lib/cmake/verdict/VerdictConfigVersion.cmake
+lib/cmake/verdict/VerdictTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/verdict/VerdictTargets.cmake
+lib/libverdict.so
+lib/libverdict.so.1.4
+lib/libverdict.so.1.4.0
+%%PORTDOCS%%%%DOCSDIR%%/README.md
+%%PORTDOCS%%%%DOCSDIR%%/SAND2007-2853p.pdf