aboutsummaryrefslogtreecommitdiff
path: root/math/vtk6
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-04-01 14:16:16 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-04-01 14:16:16 +0000
commit8d6597e0bb9591c40fc6d0c6e2159fca51178d56 (patch)
treed3548a0f08ca434f11cb4415a93d98037409413b /math/vtk6
parenta9dcad2fffcc27906b85c5a15fdb3e50fdc1e2e2 (diff)
downloadports-8d6597e0bb9591c40fc6d0c6e2159fca51178d56.tar.gz
ports-8d6597e0bb9591c40fc6d0c6e2159fca51178d56.zip
Remove ${PORTSDIR}/ from dependencies, categories m, n, o, and p.
With hat: portmgr Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=412348
Diffstat (limited to 'math/vtk6')
-rw-r--r--math/vtk6/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/math/vtk6/Makefile b/math/vtk6/Makefile
index b88b7d59de5d..af06336ff382 100644
--- a/math/vtk6/Makefile
+++ b/math/vtk6/Makefile
@@ -14,10 +14,10 @@ COMMENT= The Visualization Toolkit
LICENSE= BSD3CLAUSE
-LIB_DEPENDS= libtiff.so:${PORTSDIR}/graphics/tiff \
- libpng.so:${PORTSDIR}/graphics/png \
- libfreetype.so:${PORTSDIR}/print/freetype2 \
- libexpat.so:${PORTSDIR}/textproc/expat2
+LIB_DEPENDS= libtiff.so:graphics/tiff \
+ libpng.so:graphics/png \
+ libfreetype.so:print/freetype2 \
+ libexpat.so:textproc/expat2
#
# TODO
@@ -99,7 +99,7 @@ CMAKE_ARGS+= -DVTK_Group_${g}:BOOL=OFF
.endfor
.if ${PORT_OPTIONS:MOSMESA}
-LIB_DEPENDS+= libOSMesa.so:${PORTSDIR}/graphics/libosmesa
+LIB_DEPENDS+= libOSMesa.so:graphics/libosmesa
CMAKE_ARGS+= -DVTK_OPENGL_HAS_OSMESA:BOOL=ON \
-DOSMESA_INCLUDE_DIR:PATH=${LOCALBASE}/include/Mesa \
-DOSMESA_LIBRARY:FILEPATH=${LOCALBASE}/lib/libOSMesa.so \
@@ -118,7 +118,7 @@ CMAKE_ARGS+= -DBUILD_EXAMPLES:BOOL=ON
.endif
.if ${PORT_OPTIONS:MMPI}
-LIB_DEPENDS+= libmpi.so:${PORTSDIR}/net/openmpi
+LIB_DEPENDS+= libmpi.so:net/openmpi
CMAKE_ARGS+= -DMPIEXEC=${LOCALBASE}/mpi/openmpi/bin/mpiexec
PLIST_SUB+= MPI=""
.else
@@ -184,7 +184,7 @@ CMAKE_ARGS+= -DVTK_WRAP_PYTHON:BOOL=ON \
-DModule_vtkRenderingMatplotlib:BOOL=ON \
-DModule_vtkPythonInterpreter:BOOL=ON
PLIST_SUB+= PYTHON=""
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/matplotlib/__init__.py:${PORTSDIR}/math/py-matplotlib
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/matplotlib/__init__.py:math/py-matplotlib
.else
CMAKE_ARGS+= -DVTK_WRAP_PYTHON:BOOL=OFF
PLIST_SUB+= PYTHON="@comment "
@@ -212,7 +212,7 @@ PLIST_SUB+= WRAP="@comment "
.if ${PORT_OPTIONS:MDOCS}
CMAKE_ARGS+= -DBUILD_DOCUMENTATION:BOOL=ON
-BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen
+BUILD_DEPENDS+= doxygen:devel/doxygen
.else
CMAKE_ARGS+= -DBUILD_DOCUMENTATION:BOOL=OFF
.endif