aboutsummaryrefslogtreecommitdiff
path: root/math/vtk8
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-04-26 22:04:10 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-04-26 22:04:10 +0000
commit16f524ab646b9ae0d9e453eedc8fbc7eaa026764 (patch)
tree8b4d88267fa1d27f2faef1d8b6eb8a908824b92a /math/vtk8
parentaf24a3a1a4bac34e96d625f1eb27b091d7b82960 (diff)
downloadports-16f524ab646b9ae0d9e453eedc8fbc7eaa026764.tar.gz
ports-16f524ab646b9ae0d9e453eedc8fbc7eaa026764.zip
math/vtk8: Update 8.1.2 -> 8.2.0
science/liggght is updated 3.8.0 -> 3.8.0-26 because only later revisions support vtk8-8.2.0 3 dependent ports bumped.
Notes
Notes: svn path=/head/; revision=533086
Diffstat (limited to 'math/vtk8')
-rw-r--r--math/vtk8/Makefile9
-rw-r--r--math/vtk8/distinfo6
-rw-r--r--math/vtk8/files/patch-GUISupport_Qt_CMakeLists.txt19
-rw-r--r--math/vtk8/files/patch-IO_EnSight_vtkEnSight6BinaryReader.cxx13
-rw-r--r--math/vtk8/files/patch-IO_EnSight_vtkEnSightGoldBinaryReader.cxx13
-rw-r--r--math/vtk8/files/patch-ThirdParty_hdf5_vtkhdf5_CMakeInstallation.cmake16
-rw-r--r--math/vtk8/files/patch-ThirdParty_libproj4_vtklibproj4_CMakeLists.txt16
-rw-r--r--math/vtk8/files/patch-ThirdParty_libproj_vtklibproj_src_pj__mutex.c11
-rw-r--r--math/vtk8/files/patch-ThirdParty_verdict_vtkverdict_CMakeLists.txt4
-rw-r--r--math/vtk8/files/patch-Wrapping_Tcl_CMakeLists.txt11
10 files changed, 30 insertions, 88 deletions
diff --git a/math/vtk8/Makefile b/math/vtk8/Makefile
index 10250e6de756..ff434a6596ee 100644
--- a/math/vtk8/Makefile
+++ b/math/vtk8/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= vtk
-DISTVERSION= 8.1.2
-PORTREVISION= 6
+DISTVERSION= 8.2.0
CATEGORIES= math graphics
MASTER_SITES= http://www.vtk.org/files/release/${VTK_SHORT_VER}/
PKGNAMESUFFIX= 8
@@ -122,7 +121,11 @@ USES+= gl
USE_GL= gl glu
.endif
-post-install: # autoplist: thousands of files, complex dependencies on options
+post-install:
+ ## 8.2 installs cmake files into a wrong location
+ #@cd ${STAGEDIR}${PREFIX} && \
+ # ${MV} lib/vtk-${VTK_SHORT_VER}/cmake lib/
+ # autoplist: thousands of files, complex dependencies on options
@cd ${STAGEDIR}${PREFIX} && \
${FIND} * -type f -or -type l >> ${TMPPLIST}
diff --git a/math/vtk8/distinfo b/math/vtk8/distinfo
index 23a96c6113df..5cc3a3a28ff4 100644
--- a/math/vtk8/distinfo
+++ b/math/vtk8/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1541961840
-SHA256 (VTK-8.1.2.tar.gz) = 0995fb36857dd76ccfb8bb07350c214d9f9099e80b1e66b4a8909311f24ff0db
-SIZE (VTK-8.1.2.tar.gz) = 33479307
+TIMESTAMP = 1587775906
+SHA256 (VTK-8.2.0.tar.gz) = 34c3dc775261be5e45a8049155f7228b6bd668106c72a3c435d95730d17d57bb
+SIZE (VTK-8.2.0.tar.gz) = 35511819
diff --git a/math/vtk8/files/patch-GUISupport_Qt_CMakeLists.txt b/math/vtk8/files/patch-GUISupport_Qt_CMakeLists.txt
index 8507327efd93..43e82e2f9310 100644
--- a/math/vtk8/files/patch-GUISupport_Qt_CMakeLists.txt
+++ b/math/vtk8/files/patch-GUISupport_Qt_CMakeLists.txt
@@ -1,15 +1,12 @@
---- GUISupport/Qt/CMakeLists.txt.orig 2018-05-11 14:34:24 UTC
+--- GUISupport/Qt/CMakeLists.txt.orig 2019-01-30 17:15:13 UTC
+++ GUISupport/Qt/CMakeLists.txt
-@@ -145,7 +145,7 @@ if(VTK_BUILD_QT_DESIGNER_PLUGIN AND add_
- find_package(Qt5 COMPONENTS ${qt_component} REQUIRED QUIET)
- add_definitions(${Qt5${qt_component}_DEFINITIONS})
- include_directories(${Qt5${qt_component}_INCLUDE_DIRS})
-- qt5_wrap_cpp(PluginMocSrcs ${PluginMocHeaders} TARGET QVTKWidgetPlugin)
-+ qt5_wrap_cpp(PluginMocSrcs ${PluginMocHeaders} TARGET QVTKWidgetPlugin-${VTK_MAJOR_VERSION}.${VTK_MINOR_VERSION})
- set(QT_LIBRARIES Qt5::${qt_component})
- else()
- find_package(Qt4 COMPONENTS QtCore QtGui QtDesignerComponents REQUIRED QUIET)
-@@ -157,16 +157,16 @@ if(VTK_BUILD_QT_DESIGNER_PLUGIN AND add_
+@@ -128,21 +128,21 @@ if(VTK_BUILD_QT_DESIGNER_PLUGIN AND add_qvtkwidget)
+ find_package(Qt5 COMPONENTS ${qt_component} REQUIRED QUIET)
+ add_definitions(${Qt5${qt_component}_DEFINITIONS})
+ include_directories(${Qt5${qt_component}_INCLUDE_DIRS})
+- qt5_wrap_cpp(PluginMocSrcs ${PluginMocHeaders} TARGET QVTKWidgetPlugin)
++ qt5_wrap_cpp(PluginMocSrcs ${PluginMocHeaders} TARGET QVTKWidgetPlugin-${VTK_MAJOR_VERSION}.${VTK_MINOR_VERSION})
+ set(QT_LIBRARIES Qt5::${qt_component})
# add QVTK plugin from sources
# stand-alone as it doesn't depend on QVTK library
diff --git a/math/vtk8/files/patch-IO_EnSight_vtkEnSight6BinaryReader.cxx b/math/vtk8/files/patch-IO_EnSight_vtkEnSight6BinaryReader.cxx
deleted file mode 100644
index 8665a1892011..000000000000
--- a/math/vtk8/files/patch-IO_EnSight_vtkEnSight6BinaryReader.cxx
+++ /dev/null
@@ -1,13 +0,0 @@
---- IO/EnSight/vtkEnSight6BinaryReader.cxx.orig 2017-11-21 07:34:56 UTC
-+++ IO/EnSight/vtkEnSight6BinaryReader.cxx
-@@ -36,8 +36,8 @@
- #if defined(_WIN32)
- # define VTK_STAT_STRUCT struct _stat64
- # define VTK_STAT_FUNC _stat64
--#elif defined _DARWIN_FEATURE_64_BIT_INODE && !defined __FreeBSD__
--// FreeBSD and OSX now deprecate stat64
-+#elif defined _DARWIN_FEATURE_64_BIT_INODE || defined __FreeBSD__
-+// FreeBSD and OSX use stat
- # define VTK_STAT_STRUCT struct stat
- # define VTK_STAT_FUNC stat
- #else
diff --git a/math/vtk8/files/patch-IO_EnSight_vtkEnSightGoldBinaryReader.cxx b/math/vtk8/files/patch-IO_EnSight_vtkEnSightGoldBinaryReader.cxx
deleted file mode 100644
index 03d79b34fad8..000000000000
--- a/math/vtk8/files/patch-IO_EnSight_vtkEnSightGoldBinaryReader.cxx
+++ /dev/null
@@ -1,13 +0,0 @@
---- IO/EnSight/vtkEnSightGoldBinaryReader.cxx.orig 2017-11-21 07:32:21 UTC
-+++ IO/EnSight/vtkEnSightGoldBinaryReader.cxx
-@@ -37,8 +37,8 @@
- #if defined(_WIN32)
- # define VTK_STAT_STRUCT struct _stat64
- # define VTK_STAT_FUNC _stat64
--#elif defined _DARWIN_FEATURE_64_BIT_INODE && !defined __FreeBSD__
--// FreeBSD and OSX now deprecate stat64
-+#elif defined _DARWIN_FEATURE_64_BIT_INODE || defined __FreeBSD__
-+// FreeBSD and OSX use stat
- # define VTK_STAT_STRUCT struct stat
- # define VTK_STAT_FUNC stat
- #else
diff --git a/math/vtk8/files/patch-ThirdParty_hdf5_vtkhdf5_CMakeInstallation.cmake b/math/vtk8/files/patch-ThirdParty_hdf5_vtkhdf5_CMakeInstallation.cmake
deleted file mode 100644
index e0d79f2444b6..000000000000
--- a/math/vtk8/files/patch-ThirdParty_hdf5_vtkhdf5_CMakeInstallation.cmake
+++ /dev/null
@@ -1,16 +0,0 @@
-So that this port doesn't clash with science/paraview:
-
---- ThirdParty/hdf5/vtkhdf5/CMakeInstallation.cmake.orig 2017-01-20 17:51:20 UTC
-+++ ThirdParty/hdf5/vtkhdf5/CMakeInstallation.cmake
-@@ -105,11 +105,6 @@ configure_file (
- ${HDF5_RESOURCES_DIR}/libhdf5.settings.cmake.in
- ${HDF5_BINARY_DIR}/libhdf5.settings @ONLY
- )
--install (
-- FILES ${HDF5_BINARY_DIR}/libhdf5.settings
-- DESTINATION ${HDF5_INSTALL_CMAKE_DIR}/${HDF5_PACKAGE}
-- COMPONENT libraries
--)
-
- #-----------------------------------------------------------------------------
- # Configure the HDF518_Examples.cmake file and the examples
diff --git a/math/vtk8/files/patch-ThirdParty_libproj4_vtklibproj4_CMakeLists.txt b/math/vtk8/files/patch-ThirdParty_libproj4_vtklibproj4_CMakeLists.txt
deleted file mode 100644
index 728203e98bd1..000000000000
--- a/math/vtk8/files/patch-ThirdParty_libproj4_vtklibproj4_CMakeLists.txt
+++ /dev/null
@@ -1,16 +0,0 @@
---- ThirdParty/libproj4/vtklibproj4/CMakeLists.txt.orig 2017-08-30 20:55:05 UTC
-+++ ThirdParty/libproj4/vtklibproj4/CMakeLists.txt
-@@ -50,10 +50,10 @@ find_package (Threads)
-
- include(CheckIncludeFiles)
- include(CheckSymbolExists)
--CHECK_SYMBOL_EXISTS(PTHREAD_MUTEX_RECURSIVE pthread.h HAVE_PTHREAD_MUTEX_RECURSIVE_DEFN)
--if (HAVE_PTHREAD_MUTEX_RECURSIVE_DEFN)
-+#CHECK_SYMBOL_EXISTS(PTHREAD_MUTEX_RECURSIVE pthread.h HAVE_PTHREAD_MUTEX_RECURSIVE_DEFN) # test fails, reported upstream: https://gitlab.kitware.com/vtk/vtk/issues/17178
-+#if (HAVE_PTHREAD_MUTEX_RECURSIVE_DEFN)
- add_definitions(-DHAVE_PTHREAD_MUTEX_RECURSIVE=1)
--endif()
-+#endif()
-
- # Set a default build type for single-configuration cmake generators if
- # no build type is set.
diff --git a/math/vtk8/files/patch-ThirdParty_libproj_vtklibproj_src_pj__mutex.c b/math/vtk8/files/patch-ThirdParty_libproj_vtklibproj_src_pj__mutex.c
new file mode 100644
index 000000000000..bd453a0dc9ca
--- /dev/null
+++ b/math/vtk8/files/patch-ThirdParty_libproj_vtklibproj_src_pj__mutex.c
@@ -0,0 +1,11 @@
+--- ThirdParty/libproj/vtklibproj/src/pj_mutex.c.orig 2020-04-25 01:23:01 UTC
++++ ThirdParty/libproj/vtklibproj/src/pj_mutex.c
+@@ -124,7 +124,7 @@ void pj_acquire_lock()
+ pthread_mutex_lock( &pj_precreated_lock);
+
+ pthread_mutexattr_init(&mutex_attr);
+-#ifdef HAVE_PTHREAD_MUTEX_RECURSIVE
++#if defined(HAVE_PTHREAD_MUTEX_RECURSIVE) || defined(__FreeBSD__)
+ pthread_mutexattr_settype(&mutex_attr, PTHREAD_MUTEX_RECURSIVE);
+ #else
+ pthread_mutexattr_settype(&mutex_attr, PTHREAD_MUTEX_RECURSIVE_NP);
diff --git a/math/vtk8/files/patch-ThirdParty_verdict_vtkverdict_CMakeLists.txt b/math/vtk8/files/patch-ThirdParty_verdict_vtkverdict_CMakeLists.txt
index 2d3871c2d909..f7e860060a89 100644
--- a/math/vtk8/files/patch-ThirdParty_verdict_vtkverdict_CMakeLists.txt
+++ b/math/vtk8/files/patch-ThirdParty_verdict_vtkverdict_CMakeLists.txt
@@ -1,6 +1,6 @@
---- ThirdParty/verdict/vtkverdict/CMakeLists.txt.orig 2017-08-30 20:55:05 UTC
+--- ThirdParty/verdict/vtkverdict/CMakeLists.txt.orig 2019-01-30 17:15:13 UTC
+++ ThirdParty/verdict/vtkverdict/CMakeLists.txt
-@@ -123,14 +123,14 @@ endif ()
+@@ -128,14 +128,14 @@ endif ()
# Installation stuff
#
IF(NOT verdict_INSTALL_NO_DEVELOPMENT)
diff --git a/math/vtk8/files/patch-Wrapping_Tcl_CMakeLists.txt b/math/vtk8/files/patch-Wrapping_Tcl_CMakeLists.txt
deleted file mode 100644
index c6320f475a17..000000000000
--- a/math/vtk8/files/patch-Wrapping_Tcl_CMakeLists.txt
+++ /dev/null
@@ -1,11 +0,0 @@
---- Wrapping/Tcl/CMakeLists.txt.orig 2017-08-30 20:55:05 UTC
-+++ Wrapping/Tcl/CMakeLists.txt
-@@ -247,7 +247,7 @@ endforeach()
- # Configure the Tcl package index file for the install tree.
- SET(VTK_TCL_SCRIPT_DIR "[file dirname [info script]]")
- IF(UNIX)
-- SET(VTK_TCL_LIBRARY_DIR "[file dirname [file dirname [file dirname [info script]]]]")
-+ SET(VTK_TCL_LIBRARY_DIR "[file dirname [info script]]")
- ELSE()
- SET(VTK_TCL_LIBRARY_DIR
- "[file join [file dirname [file dirname [file dirname [file dirname [info script]]]]] bin]")