aboutsummaryrefslogtreecommitdiff
path: root/math/xspread
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-03-28 23:04:06 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-03-28 23:04:06 +0000
commitf51a5a458c54de5e052b4a9d08b45a4df3ee67fe (patch)
tree4e0c224a7fc67ac1a85dd444fb52bfe36940ca04 /math/xspread
parent02702cf90a51c8d2c4789ba98476376d5de5cf84 (diff)
downloadports-f51a5a458c54de5e052b4a9d08b45a4df3ee67fe.tar.gz
ports-f51a5a458c54de5e052b4a9d08b45a4df3ee67fe.zip
- Add LICENSE_FILE
- Switch to options helpers - Regenerate patches with `make makepatch`
Notes
Notes: svn path=/head/; revision=412074
Diffstat (limited to 'math/xspread')
-rw-r--r--math/xspread/Makefile21
-rw-r--r--math/xspread/files/patch-Makefile.in6
-rw-r--r--math/xspread/files/patch-config_h.in4
-rw-r--r--math/xspread/files/patch-interp.c6
4 files changed, 17 insertions, 20 deletions
diff --git a/math/xspread/Makefile b/math/xspread/Makefile
index 03c9e7660f28..7aa94f5f1b59 100644
--- a/math/xspread/Makefile
+++ b/math/xspread/Makefile
@@ -16,8 +16,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Spreadsheet program for X and terminals
LICENSE= GPLv2+
-
-OPTIONS_DEFINE= X11 DOCS
+LICENSE_FILE= ${WRKSRC}/GNU_GENERAL
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}.orig
@@ -27,16 +26,12 @@ PORTDOCS= *
PLIST_FILES= bin/pxspread bin/xspread man/man1/pxspread.1.gz \
man/man1/xspread.1.gz
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= X11 DOCS
-.if ${PORT_OPTIONS:MX11}
-USE_XORG= x11 xau xcb xdmcp xt
-LIB_DEPENDS+= libpthread-stubs.so:${PORTSDIR}/devel/libpthread-stubs
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-.else
-CONFIGURE_ENV+= ac_cv_header_X11_X_h=no
-.endif
+X11_USE= XORG=x11,xau,xcb,xdmcp,xt
+X11_LIB_DEPENDS= libpthread-stubs.so:${PORTSDIR}/devel/libpthread-stubs
+X11_USES= localbase
+X11_CONFIGURE_ENV_OFF= ac_cv_header_X11_X_h=no
post-patch:
@${REINPLACE_CMD} 's|/usr/local/lib/libXt|${LOCALBASE}/lib/libXt|' \
@@ -49,7 +44,9 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/xspread ${STAGEDIR}${PREFIX}/bin/xspread
${INSTALL_MAN} ${WRKSRC}/pxspread.man ${STAGEDIR}${MANPREFIX}/man/man1/pxspread.1
${INSTALL_MAN} ${WRKSRC}/xspread.man ${STAGEDIR}${MANPREFIX}/man/man1/xspread.1
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/x/notes ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC} && ${COPYTREE_SHARE} "doc documents sample_files tests" ${STAGEDIR}${DOCSDIR} "! -name *.tmp")
diff --git a/math/xspread/files/patch-Makefile.in b/math/xspread/files/patch-Makefile.in
index 3efc318e60cd..8b3f11b62400 100644
--- a/math/xspread/files/patch-Makefile.in
+++ b/math/xspread/files/patch-Makefile.in
@@ -1,5 +1,5 @@
---- Makefile.in.orig Tue Nov 7 11:17:18 1995
-+++ Makefile.in Tue Sep 28 01:41:35 1999
+--- Makefile.in.orig 1995-11-07 02:17:18 UTC
++++ Makefile.in
@@ -1,7 +1,7 @@
# Common prefix for installation directories.
@@ -9,7 +9,7 @@
exec_prefix = $(prefix)
# Where to put the executables.
bindir = $(exec_prefix)/bin
-@@ -19,7 +19,7 @@
+@@ -19,7 +19,7 @@ CC = @CC@
CFLAGS = @CFLAGS@
DEFS = @DEFS@
LIBS = @LIBS@
diff --git a/math/xspread/files/patch-config_h.in b/math/xspread/files/patch-config_h.in
index be040a76ebfc..4988bf37e610 100644
--- a/math/xspread/files/patch-config_h.in
+++ b/math/xspread/files/patch-config_h.in
@@ -1,5 +1,5 @@
---- config_h.in.orig Tue Nov 7 11:17:21 1995
-+++ config_h.in Tue Sep 28 04:00:50 1999
+--- config_h.in.orig 1995-11-07 02:17:21 UTC
++++ config_h.in
@@ -12,7 +12,7 @@
#define SAVENAME "SC.SAVE"
diff --git a/math/xspread/files/patch-interp.c b/math/xspread/files/patch-interp.c
index da022c4c23ec..b3b52477548e 100644
--- a/math/xspread/files/patch-interp.c
+++ b/math/xspread/files/patch-interp.c
@@ -1,6 +1,6 @@
---- interp.c.orig Tue Nov 7 03:17:26 1995
-+++ interp.c Fri Mar 10 13:34:37 2000
-@@ -516,7 +516,7 @@
+--- interp.c.orig 1995-11-07 02:17:26 UTC
++++ interp.c
+@@ -516,7 +516,7 @@ int mo, day, yr;
mdays[1] = 28 + (yr%4 == 0);
if (mo < 1 || mo > 12 || day < 1 || day > mdays[--mo] ||