aboutsummaryrefslogtreecommitdiff
path: root/math/yacas/Makefile
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2016-04-08 11:10:10 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2016-04-08 11:10:10 +0000
commit6621dfd6c0cb438e33bf25889bf0766d6dcb339a (patch)
tree4e3c5b332ac8dc3c418cc8e3999a48050f517cbd /math/yacas/Makefile
parent0286c79feb5d263bbbcd133d4966c50e40a96b1a (diff)
downloadports-6621dfd6c0cb438e33bf25889bf0766d6dcb339a.tar.gz
ports-6621dfd6c0cb438e33bf25889bf0766d6dcb339a.zip
Notes
Diffstat (limited to 'math/yacas/Makefile')
-rw-r--r--math/yacas/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/math/yacas/Makefile b/math/yacas/Makefile
index 41ae1330c852..b088c9c87001 100644
--- a/math/yacas/Makefile
+++ b/math/yacas/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= yacas
-PORTVERSION= 1.4.0
+PORTVERSION= 1.4.2
DISTVERSIONPREFIX= v
CATEGORIES= math
@@ -12,6 +12,12 @@ COMMENT= Yet Another Computer Algebra System
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
+OPTIONS_DEFINE= DOCS
+DOCS_CMAKE_ON= -DENABLE_DOCS:BOOL=ON -DDOCSDIR:STRING=${DOCSDIR_REL}
+DOCS_BUILD_DEPENDS= sphinx-autogen:textproc/py-sphinx
+
+PORTDOCS= *
+
TEST_DEPENDS= bash:shells/bash
USES= cmake:outsource compiler:c++11-lib
@@ -19,6 +25,8 @@ USE_LDCONFIG= yes
USE_GITHUB= yes
GH_ACCOUNT= grzegorzmazur
+PLIST_SUB= SHLIB_VERSION=${PORTVERSION:S/.//}.0
+
.include <bsd.port.pre.mk>
.if ${CHOSEN_COMPILER_TYPE} == "gcc"