aboutsummaryrefslogtreecommitdiff
path: root/math/yacas/Makefile
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2016-03-04 11:30:12 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2016-03-04 11:30:12 +0000
commitb2e89824f865a584f1b5c25c9f6dbc90629155d3 (patch)
tree932281b77e4c4c75dd7a978e56a16c5e996524b9 /math/yacas/Makefile
parent58028440f768792b433b5427139a291dccd610a6 (diff)
downloadports-b2e89824f865a584f1b5c25c9f6dbc90629155d3.tar.gz
ports-b2e89824f865a584f1b5c25c9f6dbc90629155d3.zip
Notes
Diffstat (limited to 'math/yacas/Makefile')
-rw-r--r--math/yacas/Makefile32
1 files changed, 10 insertions, 22 deletions
diff --git a/math/yacas/Makefile b/math/yacas/Makefile
index 17ec563b429e..c03b28dd86d1 100644
--- a/math/yacas/Makefile
+++ b/math/yacas/Makefile
@@ -2,30 +2,22 @@
# $FreeBSD$
PORTNAME= yacas
-PORTVERSION= 1.3.6
-PORTREVISION= 1
+PORTVERSION= 1.4.0
CATEGORIES= math
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-source/${PORTVERSION:R}/
+DISTVERSIONPREFIX= v
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= gahr@FreeBSD.org
COMMENT= Yet Another Computer Algebra System
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= compiler:c++11-lib libtool
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-html-dir=${DOCSDIR}
-INSTALL_TARGET= install-strip
-USE_LDCONFIG= yes
-
-PORTDOCS= *
-
-OPTIONS_DEFINE= DOCS
+TEST_DEPENDS= bash:${PORTSDIR}/shells/bash
-DOCS_USES= perl5
-DOCS_USE= perl5=build
-DOCS_CONFIGURE_ENABLE= html-doc
+USES= cmake:outsource compiler:c++11-lib
+USE_LDCONFIG= yes
+USE_GITHUB= yes
+GH_ACCOUNT= grzegorzmazur
.include <bsd.port.pre.mk>
@@ -34,17 +26,13 @@ CPPFLAGS+= -D_GLIBCXX_USE_C99
.endif
post-patch:
- @${REINPLACE_CMD} -e \
- 's|%%DATADIR%%|${DATADIR}|' ${WRKSRC}/src/yacasmain.cpp
# Can't use USES=shebangfix here, cause the path appears several
# times in the file.
@${REINPLACE_CMD} -e \
's| /bin/bash| ${LOCALBASE}/bin/bash|g' \
${WRKSRC}/tests/test-yacas
-regression-test: build
-# This requires bash. I don't add it as a dependency to the port, as
-# it's not needed for the general use.
- @(cd ${WRKSRC} && ${DO_MAKE_BUILD} check)
+do-test:
+ cd ${BUILD_WRKSRC} && ${MAKE} test
.include <bsd.port.post.mk>