aboutsummaryrefslogtreecommitdiff
path: root/math/yacas
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-06-29 12:42:04 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-06-29 12:42:04 +0000
commit222461c302e52a3848555e999ecc7a10f98b278e (patch)
tree4fad0f8d9c328a570a49371daf5f0078d7075272 /math/yacas
parentb6155c63444b79580e9bd13727472581d1ed66f1 (diff)
downloadports-222461c302e52a3848555e999ecc7a10f98b278e.tar.gz
ports-222461c302e52a3848555e999ecc7a10f98b278e.zip
Convert to new option framework
Notes
Notes: svn path=/head/; revision=300215
Diffstat (limited to 'math/yacas')
-rw-r--r--math/yacas/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/math/yacas/Makefile b/math/yacas/Makefile
index 8e03a5181c49..902e6ecb2978 100644
--- a/math/yacas/Makefile
+++ b/math/yacas/Makefile
@@ -17,26 +17,28 @@ COMMENT= Yet Another Computer Algebra System
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-OPTIONS= TESTS "Run bundled self-tests after build" on
+OPTIONS_DEFINE= TESTS DOCS
+OPTIONS_DEFAULT= TESTS
+TESTS_DESC= Run bundled self-tests after build
USE_PERL5_BUILD=yes
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
MAKE_JOBS_SAFE= yes
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${ARCH} == "sparc64"
BROKEN= Does not compile with GCC 4.2
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
CONFIGURE_ARGS+= --enable-html-doc --with-html-dir=${DOCSDIR}
.else
CONFIGURE_ARGS+= --disable-html-doc
.endif
-.if !defined(WITHOUT_TESTS)
+.if ${PORT_OPTIONS:MTESTS}
BUILD_DEPENDS+= bash:${PORTSDIR}/shells/bash
.endif
@@ -45,9 +47,9 @@ post-patch:
's| /bin/bash| ${LOCALBASE}/bin/bash|' ${WRKSRC}/tests/test-yacas
post-build:
-.if !defined(WITHOUT_TESTS)
+.if ${PORT_OPTIONS:MTESTS}
@(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} \
${MAKEFILE} check ${MAKE_ARGS})
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>