aboutsummaryrefslogtreecommitdiff
path: root/math/yacas
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2016-05-10 09:58:00 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2016-05-10 09:58:00 +0000
commit7be97a1bb4c7d3e994b0d94a1ca39d3332eced02 (patch)
tree94b4c65a1f3b67cbb021ec7536cdd1910d27252a /math/yacas
parent24bd216d00f42439c86fca50234093cc0bbccd93 (diff)
downloadports-7be97a1bb4c7d3e994b0d94a1ca39d3332eced02.tar.gz
ports-7be97a1bb4c7d3e994b0d94a1ca39d3332eced02.zip
math/yacas: update to 1.5.0
Notes
Notes: svn path=/head/; revision=414932
Diffstat (limited to 'math/yacas')
-rw-r--r--math/yacas/Makefile12
-rw-r--r--math/yacas/distinfo4
-rw-r--r--math/yacas/files/patch-CMakeLists-docs.txt18
-rw-r--r--math/yacas/files/patch-docs_CMakeLists.txt10
-rw-r--r--math/yacas/files/patch-src_mathcommands.cpp10
-rw-r--r--math/yacas/files/patch-src_yacasmain.cpp10
-rw-r--r--math/yacas/pkg-plist14
7 files changed, 21 insertions, 57 deletions
diff --git a/math/yacas/Makefile b/math/yacas/Makefile
index b088c9c87001..9f04f8e0840f 100644
--- a/math/yacas/Makefile
+++ b/math/yacas/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= yacas
-PORTVERSION= 1.4.2
+PORTVERSION= 1.5.0
DISTVERSIONPREFIX= v
CATEGORIES= math
@@ -18,6 +18,7 @@ DOCS_BUILD_DEPENDS= sphinx-autogen:textproc/py-sphinx
PORTDOCS= *
+TEST_TARGET= test
TEST_DEPENDS= bash:shells/bash
USES= cmake:outsource compiler:c++11-lib
@@ -36,11 +37,8 @@ CXXFLAGS+= -D_GLIBCXX_USE_C99
post-patch:
# Can't use USES=shebangfix here, cause the path appears several
# times in the file.
- @${REINPLACE_CMD} -e \
- 's| /bin/bash| ${LOCALBASE}/bin/bash|g' \
+ @${REINPLACE_CMD} -e 's| /bin/bash| ${LOCALBASE}/bin/bash|g' \
${WRKSRC}/tests/test-yacas
-
-do-test:
- cd ${BUILD_WRKSRC} && ${MAKE} test
-
+ @${REINPLACE_CMD} -e '/^install/s|^|#|' \
+ ${WRKSRC}/tests/CMakeLists.txt
.include <bsd.port.post.mk>
diff --git a/math/yacas/distinfo b/math/yacas/distinfo
index 9d0ac78664d8..905dbfbdc48a 100644
--- a/math/yacas/distinfo
+++ b/math/yacas/distinfo
@@ -1,2 +1,2 @@
-SHA256 (grzegorzmazur-yacas-v1.4.2_GH0.tar.gz) = 530fdc8902f6289ed5b6ddbbfa50910f74086657c97ece2a65a5111ccb1ec710
-SIZE (grzegorzmazur-yacas-v1.4.2_GH0.tar.gz) = 2032218
+SHA256 (grzegorzmazur-yacas-v1.5.0_GH0.tar.gz) = 2ae2516959633898f978002f4d676f3a56c376a4ccb5ab53a0727b1dccc7de7f
+SIZE (grzegorzmazur-yacas-v1.5.0_GH0.tar.gz) = 1303766
diff --git a/math/yacas/files/patch-CMakeLists-docs.txt b/math/yacas/files/patch-CMakeLists-docs.txt
deleted file mode 100644
index 90ca38b8fb26..000000000000
--- a/math/yacas/files/patch-CMakeLists-docs.txt
+++ /dev/null
@@ -1,18 +0,0 @@
---- CMakeLists-docs.txt.orig 2016-04-08 09:58:59 UTC
-+++ CMakeLists-docs.txt
-@@ -39,7 +39,7 @@ add_custom_target(yacas_docs ALL
- "${SPHINX_SINGLEHTML_DIR}"
- COMMENT "Building HTML documentation with Sphinx")
-
--install (DIRECTORY "${SPHINX_SINGLEHTML_DIR}" DESTINATION share/yacas/documentation COMPONENT doc)
-+install (DIRECTORY "${SPHINX_SINGLEHTML_DIR}" DESTINATION ${DOCSDIR} COMPONENT doc)
-
- if (ENABLE_OLD_DOCS)
-
-@@ -161,4 +161,4 @@ if (ENABLE_OLD_DOCS)
-
- install (FILES ${HTML_BOOKS} ${HTML_CHAPTERS} DESTINATION share/yacas/documentation COMPONENT doc)
-
--endif ()
-\ No newline at end of file
-+endif ()
diff --git a/math/yacas/files/patch-docs_CMakeLists.txt b/math/yacas/files/patch-docs_CMakeLists.txt
new file mode 100644
index 000000000000..6753623d4df9
--- /dev/null
+++ b/math/yacas/files/patch-docs_CMakeLists.txt
@@ -0,0 +1,10 @@
+--- docs/CMakeLists.txt.orig 2016-05-10 08:39:04 UTC
++++ docs/CMakeLists.txt
+@@ -38,6 +38,6 @@ add_custom_target(yacas_docs ALL
+ COMMENT "Building HTML documentation with Sphinx")
+
+ install (DIRECTORY "${SPHINX_SINGLEHTML_DIR}"
+- DESTINATION share/yacas/documentation
++ DESTINATION ${DOCSDIR}
+ COMPONENT doc
+ PATTERN ".buildinfo" EXCLUDE)
diff --git a/math/yacas/files/patch-src_mathcommands.cpp b/math/yacas/files/patch-src_mathcommands.cpp
deleted file mode 100644
index 9abc90cca6d4..000000000000
--- a/math/yacas/files/patch-src_mathcommands.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/mathcommands.cpp.orig 2016-03-11 09:22:12 UTC
-+++ src/mathcommands.cpp
-@@ -23,6 +23,7 @@
- #include "yacas/arggetter.h"
- #include "yacas/string_utils.h"
-
-+#include <string>
- #include <cstring>
- #include <limits.h>
- #include <stdlib.h>
diff --git a/math/yacas/files/patch-src_yacasmain.cpp b/math/yacas/files/patch-src_yacasmain.cpp
deleted file mode 100644
index 463ab465f772..000000000000
--- a/math/yacas/files/patch-src_yacasmain.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/yacasmain.cpp.orig 2016-03-11 09:22:12 UTC
-+++ src/yacasmain.cpp
-@@ -72,6 +72,7 @@
- #if defined (__FreeBSD__) || defined (__DragonFly__)
- #include <stddef.h>
- #include <unistd.h>
-+#include <sys/syslimits.h>
- #include <sys/types.h>
- #include <sys/sysctl.h>
- #endif
diff --git a/math/yacas/pkg-plist b/math/yacas/pkg-plist
index ce11c59782b8..80583b7d8c25 100644
--- a/math/yacas/pkg-plist
+++ b/math/yacas/pkg-plist
@@ -5,16 +5,13 @@ include/yacas/anumber.inl
include/yacas/arggetter.h
include/yacas/arrayclass.h
include/yacas/associationclass.h
-include/yacas/choices.h
include/yacas/commandline.h
include/yacas/core_yacasmain.h
include/yacas/corefunctions.h
-include/yacas/debugmem.h
include/yacas/deffile.h
include/yacas/errors.h
include/yacas/evalfunc.h
include/yacas/genericobject.h
-include/yacas/genericstructs.h
include/yacas/infixparser.h
include/yacas/lispatom.h
include/yacas/lispenvironment.h
@@ -25,7 +22,7 @@ include/yacas/lispglobals.h
include/yacas/lisphash.h
include/yacas/lispio.h
include/yacas/lispobject.h
-include/yacas/lispobject.inl
+include/yacas/lispoperator.h
include/yacas/lispparser.h
include/yacas/lispstring.h
include/yacas/lisptype.h
@@ -43,7 +40,6 @@ include/yacas/refcount.h
include/yacas/standard.h
include/yacas/standard.inl
include/yacas/stdcommandline.h
-include/yacas/stdfileio.h
include/yacas/string_utils.h
include/yacas/stringio.h
include/yacas/stubs.h
@@ -57,13 +53,10 @@ include/yacas/utf8/unchecked.h
include/yacas/win32commandline.h
include/yacas/xmltokenizer.h
include/yacas/yacas.h
+include/yacas/yacas_config.h
include/yacas/yacas_version.h
-include/yacas/yacasbase.h
include/yacas/yacasprivate.h
lib/libyacas.a
-lib/libyacas.so
-lib/libyacas.so.%%SHLIB_VERSION%%
-%%DATADIR%%/scripts/Makefile.am
%%DATADIR%%/scripts/array.rep/code.ys
%%DATADIR%%/scripts/array.rep/code.ys.def
%%DATADIR%%/scripts/assoc.rep/code.ys
@@ -136,7 +129,6 @@ lib/libyacas.so.%%SHLIB_VERSION%%
%%DATADIR%%/scripts/logic.rep/code.ys
%%DATADIR%%/scripts/logic.rep/code.ys.def
%%DATADIR%%/scripts/logic.rep/om.ys
-%%DATADIR%%/scripts/maketest
%%DATADIR%%/scripts/multivar.rep/code.ys
%%DATADIR%%/scripts/multivar.rep/code.ys.def
%%DATADIR%%/scripts/multivar.rep/makemulti.ys
@@ -181,6 +173,8 @@ lib/libyacas.so.%%SHLIB_VERSION%%
%%DATADIR%%/scripts/probability.rep/code.ys.def
%%DATADIR%%/scripts/pslq.rep/code.ys
%%DATADIR%%/scripts/pslq.rep/code.ys.def
+%%DATADIR%%/scripts/r_form.rep/code.ys
+%%DATADIR%%/scripts/r_form.rep/code.ys.def
%%DATADIR%%/scripts/rabinmiller.rep/code.ys
%%DATADIR%%/scripts/rabinmiller.rep/code.ys.def
%%DATADIR%%/scripts/radsimp.rep/code.ys