aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2015-09-17 18:07:25 +0000
committerKoop Mast <kwm@FreeBSD.org>2015-09-17 18:07:25 +0000
commit05360ec71eab4f178074bd97c1373e7659a59bbb (patch)
treea430ad3dbd823ddb88d16ecc11a7a7035985cf79 /math
parent7bc4660db0fb55cc34f11c9263904d676fc7445b (diff)
downloadports-05360ec71eab4f178074bd97c1373e7659a59bbb.tar.gz
ports-05360ec71eab4f178074bd97c1373e7659a59bbb.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/Makefile3
-rw-r--r--math/clblas/Makefile34
-rw-r--r--math/clblas/distinfo2
-rw-r--r--math/clblas/pkg-descr13
-rw-r--r--math/clblas/pkg-plist13
-rw-r--r--math/clfft/Makefile34
-rw-r--r--math/clfft/distinfo2
-rw-r--r--math/clfft/files/patch-src_include_sharedLibrary.h17
-rw-r--r--math/clfft/pkg-descr9
-rw-r--r--math/clfft/pkg-plist22
-rw-r--r--math/clrng/Makefile35
-rw-r--r--math/clrng/distinfo2
-rw-r--r--math/clrng/pkg-descr13
-rw-r--r--math/clrng/pkg-plist28
14 files changed, 227 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 52f25d51553a..4f3944706854 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -88,10 +88,13 @@
SUBDIR += chryzodus
SUBDIR += clarence
SUBDIR += clasp
+ SUBDIR += clblas
+ SUBDIR += clfft
SUBDIR += clipper
SUBDIR += cln
SUBDIR += cloog
SUBDIR += clp
+ SUBDIR += clrng
SUBDIR += cminpack
SUBDIR += cmlib
SUBDIR += coinmp
diff --git a/math/clblas/Makefile b/math/clblas/Makefile
new file mode 100644
index 000000000000..c7641ee7406f
--- /dev/null
+++ b/math/clblas/Makefile
@@ -0,0 +1,34 @@
+# Created by: Johannes Dieterich <dieterich@ogolem.org>
+# $FreeBSD$
+
+PORTNAME= clblas
+PORTVERSION= 2.6
+DISTVERSIONPREFIX= v
+CATEGORIES= math
+
+MAINTAINER= dieterich@ogolem.org
+COMMENT= Software library containing BLAS functions written in OpenCL
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= opencl>=0:${PORTSDIR}/devel/opencl
+LIB_DEPENDS= libOpenCL.so:${PORTSDIR}/devel/ocl-icd
+RUN_DEPENDS= opencl>=0:${PORTSDIR}/devel/opencl
+
+ONLY_FOR_ARCHS= amd64
+
+USE_GITHUB= yes
+GH_ACCOUNT= clMathLibraries
+GH_PROJECT= clBLAS
+
+USE_LDCONFIG= yes
+USES= cmake
+
+CMAKE_ARGS+= -DBUILD_TEST=OFF \
+ -DBUILD_KTEST=OFF \
+ -DSUFFIX_LIB=""
+
+CMAKE_SOURCE_PATH= ${WRKSRC}/src
+
+.include <bsd.port.mk>
diff --git a/math/clblas/distinfo b/math/clblas/distinfo
new file mode 100644
index 000000000000..327048ab720a
--- /dev/null
+++ b/math/clblas/distinfo
@@ -0,0 +1,2 @@
+SHA256 (clMathLibraries-clBLAS-v2.6_GH0.tar.gz) = 4607561a648949709bc7c368be4aaf7346174406e678454b643e31cfe861830c
+SIZE (clMathLibraries-clBLAS-v2.6_GH0.tar.gz) = 954586
diff --git a/math/clblas/pkg-descr b/math/clblas/pkg-descr
new file mode 100644
index 000000000000..119211ec8609
--- /dev/null
+++ b/math/clblas/pkg-descr
@@ -0,0 +1,13 @@
+clBLAS
+
+a software library containing BLAS functions written in OpenCL
+
+The primary goal of clBLAS is to make it easier for developers to utilize the
+inherent performance and power efficiency benefits of heterogeneous computing.
+clBLAS interfaces do not hide nor wrap OpenCL interfaces, but rather leaves
+OpenCL state management to the control of the user to allow for maximum
+performance and flexibility. The clBLAS library does generate and enqueue
+optimized OpenCL kernels, relieving the user from the task of writing,
+optimizing and maintaining kernel code themselves.
+
+WWW: https://github.com/clMathLibraries/clBLAS
diff --git a/math/clblas/pkg-plist b/math/clblas/pkg-plist
new file mode 100644
index 000000000000..6ee7581f9289
--- /dev/null
+++ b/math/clblas/pkg-plist
@@ -0,0 +1,13 @@
+bin/clBLAS-tune
+include/clAmdBlas.h
+include/clAmdBlas.version.h
+include/clBLAS-complex.h
+include/clBLAS.h
+include/clBLAS.version.h
+lib/cmake/clBLAS/clBLASConfig.cmake
+lib/cmake/clBLAS/clBLASConfigVersion.cmake
+lib/cmake/clBLAS/clBLASTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/clBLAS/clBLASTargets.cmake
+lib/libclBLAS.so
+lib/libclBLAS.so.2
+lib/libclBLAS.so.2.6.0
diff --git a/math/clfft/Makefile b/math/clfft/Makefile
new file mode 100644
index 000000000000..78a22fad9ea7
--- /dev/null
+++ b/math/clfft/Makefile
@@ -0,0 +1,34 @@
+# Created by: Johannes Dieterich <dieterich@ogolem.org>
+# $FreeBSD$
+
+PORTNAME= clfft
+PORTVERSION= 2.6.1
+DISTVERSIONPREFIX= v
+CATEGORIES= math
+
+MAINTAINER= dieterich@ogolem.org
+COMMENT= Software library containing FFT functions written in OpenCL
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= opencl>=0:${PORTSDIR}/devel/opencl
+LIB_DEPENDS= libOpenCL.so:${PORTSDIR}/devel/ocl-icd
+RUN_DEPENDS= opencl>=0:${PORTSDIR}/devel/opencl
+
+ONLY_FOR_ARCHS= amd64
+
+USE_GITHUB= yes
+GH_ACCOUNT= clMathLibraries
+GH_PROJECT= clFFT
+
+USE_LDCONFIG= yes
+USES= cmake
+
+CMAKE_ARGS+= -DBUILD_CLIENT=OFF \
+ -DBUILD_TEST=OFF \
+ -DSUFFIX_LIB=""
+
+CMAKE_SOURCE_PATH= ${WRKSRC}/src
+
+.include <bsd.port.mk>
diff --git a/math/clfft/distinfo b/math/clfft/distinfo
new file mode 100644
index 000000000000..8dd0ac4889db
--- /dev/null
+++ b/math/clfft/distinfo
@@ -0,0 +1,2 @@
+SHA256 (clMathLibraries-clFFT-v2.6.1_GH0.tar.gz) = 2b5b15b903baeef4dcea6bb8efbe6aba284510148c04d20f9b151a94ae71c050
+SIZE (clMathLibraries-clFFT-v2.6.1_GH0.tar.gz) = 893794
diff --git a/math/clfft/files/patch-src_include_sharedLibrary.h b/math/clfft/files/patch-src_include_sharedLibrary.h
new file mode 100644
index 000000000000..22a9956049e0
--- /dev/null
+++ b/math/clfft/files/patch-src_include_sharedLibrary.h
@@ -0,0 +1,17 @@
+--- src/include/sharedLibrary.h.orig 2015-08-07 18:40:37.855840000 -0400
++++ src/include/sharedLibrary.h 2015-08-07 18:40:42.675578000 -0400
+@@ -52,6 +52,14 @@
+ {
+ std::cerr << ::dlerror( ) << std::endl;
+ }
++#elif defined(__FreeBSD__)
++ tstring freebsdName = unixPrefix;
++ freebsdName += libraryName += ".so";
++ void* fileHandle = ::dlopen( freebsdName.c_str( ), RTLD_NOW );
++ if( !quiet && !fileHandle )
++ {
++ std::cerr << ::dlerror( ) << std::endl;
++ }
+ #else
+ #error "unsupported platform"
+ #endif
diff --git a/math/clfft/pkg-descr b/math/clfft/pkg-descr
new file mode 100644
index 000000000000..a8a86414d0a4
--- /dev/null
+++ b/math/clfft/pkg-descr
@@ -0,0 +1,9 @@
+clFFT
+
+a software library containing FFT functions written in OpenCL
+
+clFFT is a software library containing FFT functions written in OpenCL. In
+addition to GPU devices, the libraries also support running on CPU devices to
+facilitate debugging and heterogeneous programming.
+
+WWW: https://github.com/clMathLibraries/clFFt
diff --git a/math/clfft/pkg-plist b/math/clfft/pkg-plist
new file mode 100644
index 000000000000..6128268f1068
--- /dev/null
+++ b/math/clfft/pkg-plist
@@ -0,0 +1,22 @@
+bin/examples/fft1d
+bin/examples/fft2d
+bin/examples/fft3d
+include/clAmdFft.h
+include/clAmdFft.version.h
+include/clFFT.h
+include/clFFT.version.h
+lib/libStatTimer.so
+lib/libStatTimer.so.2
+lib/libStatTimer.so.2.6.1
+lib/libclFFT.so
+lib/libclFFT.so.2
+lib/libclFFT.so.2.6.1
+share/clFFT/clFFTConfig.cmake
+share/clFFT/clFFTConfigVersion.cmake
+share/clFFT/clFFTTargets-%%CMAKE_BUILD_TYPE%%.cmake
+share/clFFT/clFFTTargets.cmake
+share/clFFT/errorHandler.py
+share/clFFT/fftPerformanceTesting.py
+share/clFFT/measurePerformance.py
+share/clFFT/performanceUtility.py
+share/clFFT/plotPerformance.py
diff --git a/math/clrng/Makefile b/math/clrng/Makefile
new file mode 100644
index 000000000000..b98155379469
--- /dev/null
+++ b/math/clrng/Makefile
@@ -0,0 +1,35 @@
+# Created by: Johannes Dieterich <dieterich@ogolem.org>
+# $FreeBSD$
+
+PORTNAME= clrng
+DISTVERSION= 1.0.0-beta
+DISTVERSIONPREFIX= v
+CATEGORIES= math
+
+MAINTAINER= dieterich@ogolem.org
+COMMENT= Software library containing BLAS functions written in OpenCL
+
+LICENSE= BSD
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= opencl>=0:${PORTSDIR}/devel/opencl
+LIB_DEPENDS= libOpenCL.so:${PORTSDIR}/devel/ocl-icd
+RUN_DEPENDS= opencl>=0:${PORTSDIR}/devel/opencl
+
+ONLY_FOR_ARCHS= amd64
+
+USE_GITHUB= yes
+GH_ACCOUNT= clMathLibraries
+GH_PROJECT= clRNG
+
+USE_LDCONFIG= yes
+USES= cmake
+
+CMAKE_ARGS+= -DBUILD_CLIENT=OFF \
+ -DBUILD_TEST=OFF \
+ -DSUFFIX_LIB="" \
+ -DSUFFIX_BIN=""
+
+CMAKE_SOURCE_PATH= ${WRKSRC}/src
+
+.include <bsd.port.mk>
diff --git a/math/clrng/distinfo b/math/clrng/distinfo
new file mode 100644
index 000000000000..3e71629ccc21
--- /dev/null
+++ b/math/clrng/distinfo
@@ -0,0 +1,2 @@
+SHA256 (clMathLibraries-clRNG-v1.0.0-beta_GH0.tar.gz) = 12e46c89a577ea26ea8af2b11176b1c503c2b0a28a3766178f317f21f27324f4
+SIZE (clMathLibraries-clRNG-v1.0.0-beta_GH0.tar.gz) = 127591
diff --git a/math/clrng/pkg-descr b/math/clrng/pkg-descr
new file mode 100644
index 000000000000..288caa3c9ce9
--- /dev/null
+++ b/math/clrng/pkg-descr
@@ -0,0 +1,13 @@
+clRNG
+
+a library for uniform random number generation in OpenCL.
+
+Streams of random numbers act as virtual random number generators.
+They can be created on the host computer in unlimited numbers, and
+then used either on the host or on computing devices by work items
+to generate random numbers. Each stream also has equally-spaced
+substreams, which are occasionally useful. The API is currently
+implemented for four different RNGs, namely the MRG31k3p, MRG32k3a,
+LFSR113 and Philox-4x32-10 generators.
+
+WWW: https://github.com/clMathLibraries/clRNG
diff --git a/math/clrng/pkg-plist b/math/clrng/pkg-plist
new file mode 100644
index 000000000000..723550bab68d
--- /dev/null
+++ b/math/clrng/pkg-plist
@@ -0,0 +1,28 @@
+cl/include/clRNG.clh
+cl/include/lfsr113.clh
+cl/include/mrg31k3p.clh
+cl/include/mrg32k3a.clh
+cl/include/philox432.clh
+cl/include/private/Random123/array.h
+cl/include/private/Random123/features/clangfeatures.h
+cl/include/private/Random123/features/compilerfeatures.h
+cl/include/private/Random123/features/gccfeatures.h
+cl/include/private/Random123/features/msvcfeatures.h
+cl/include/private/Random123/features/open64features.h
+cl/include/private/Random123/features/openclfeatures.h
+cl/include/private/Random123/features/sse.h
+cl/include/private/Random123/philox.h
+cl/include/private/lfsr113.c.h
+cl/include/private/modular.c.h
+cl/include/private/mrg31k3p.c.h
+cl/include/private/mrg32k3a.c.h
+cl/include/private/philox432.c.h
+include/clRNG.h
+include/clRNG.version.h
+include/lfsr113.h
+include/mrg31k3p.h
+include/mrg32k3a.h
+include/philox432.h
+lib/libclRNG.so
+lib/libclRNG.so.1
+lib/libclRNG.so.1.0.0