aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2012-06-03 22:09:57 +0000
committerGabor Pali <pgj@FreeBSD.org>2012-06-03 22:09:57 +0000
commit08975e894244b9fa0e2b0c586398410a2fc655c4 (patch)
tree50b98f159ca30292fb446d429cb75026f5d5b816 /math
parentb9c7b8d985f2bd48f41b662b779de262856bcd92 (diff)
downloadports-08975e894244b9fa0e2b0c586398410a2fc655c4.tar.gz
ports-08975e894244b9fa0e2b0c586398410a2fc655c4.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/hs-Agda-executable/Makefile2
-rw-r--r--math/hs-Agda-executable/distinfo4
-rw-r--r--math/hs-Agda-executable/pkg-descr6
-rw-r--r--math/hs-Agda/Makefile11
-rw-r--r--math/hs-Agda/distinfo4
-rw-r--r--math/hs-Agda/files/patch-Agda.cabal22
-rw-r--r--math/hs-Agda/files/patch-src__full__Agda__Compiler__MAlonzo__Compiler.hs11
7 files changed, 40 insertions, 20 deletions
diff --git a/math/hs-Agda-executable/Makefile b/math/hs-Agda-executable/Makefile
index 00b4d90d41e7..2fd3a90c1d28 100644
--- a/math/hs-Agda-executable/Makefile
+++ b/math/hs-Agda-executable/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Agda-executable
-PORTVERSION= 2.3.0
+PORTVERSION= 2.3.0.1
CATEGORIES= math haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/math/hs-Agda-executable/distinfo b/math/hs-Agda-executable/distinfo
index de1da2624e63..6adb590872cb 100644
--- a/math/hs-Agda-executable/distinfo
+++ b/math/hs-Agda-executable/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/Agda-executable-2.3.0.tar.gz) = b75ce406ac9343dbc10a221f7552df2d5ddccc8ef38359d33465c02dbe992ad8
-SIZE (cabal/Agda-executable-2.3.0.tar.gz) = 1764
+SHA256 (cabal/Agda-executable-2.3.0.1.tar.gz) = 614594c414c828c87abb1913741db66447c09617d57b92e58ffe445ceffed694
+SIZE (cabal/Agda-executable-2.3.0.1.tar.gz) = 1765
diff --git a/math/hs-Agda-executable/pkg-descr b/math/hs-Agda-executable/pkg-descr
index 2d3f0c6925a1..489ce5aca373 100644
--- a/math/hs-Agda-executable/pkg-descr
+++ b/math/hs-Agda-executable/pkg-descr
@@ -1,5 +1,5 @@
-This package provides a command-line program for type-checking and
-compiling Agda programs. The program can also generate hyperlinked,
-highlighted HTML files from Agda sources.
+This package provides a command-line program for type-checking and compiling
+Agda programs. The program can also generate hyperlinked, highlighted HTML
+files from Agda sources.
WWW: http://wiki.portal.chalmers.se/agda/
diff --git a/math/hs-Agda/Makefile b/math/hs-Agda/Makefile
index 1d7ee3e08f04..3214dd20d9c2 100644
--- a/math/hs-Agda/Makefile
+++ b/math/hs-Agda/Makefile
@@ -6,17 +6,18 @@
#
PORTNAME= Agda
-PORTVERSION= 2.3.0
+PORTVERSION= 2.3.0.1
CATEGORIES= math haskell
MAINTAINER= haskell@FreeBSD.org
-COMMENT= A functional programming language and proof assistant
+COMMENT= A dependently typed functional programming language and proof assistant
+
CABAL_SETUP= Setup.hs
-USE_CABAL= binary>=0.4.4 hashable>=1.1 hashtables>=1.0 haskeline>=0.6.3.2 \
- haskell-src-exts>=1.9.6 mtl>=2 QuickCheck>=2.3 syb \
- utf8-string>=0.3 xhtml>=3000.2 zlib>=0.4.0.1
+USE_CABAL= hashable hashtables haskeline>=0.6.3.2 \
+ haskell-src-exts>=1.9.6 mtl QuickCheck>=2.3 syb>=0.1 \
+ xhtml zlib>=0.4.0.1
USE_ALEX= yes
USE_HAPPY= yes
USE_ICONV= yes
diff --git a/math/hs-Agda/distinfo b/math/hs-Agda/distinfo
index f847c1b64b49..5ed05c7e5708 100644
--- a/math/hs-Agda/distinfo
+++ b/math/hs-Agda/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/Agda-2.3.0.tar.gz) = 608e130bd33a1c14ea544b46bfb55c0c8e31ab43952572df38df90d086e30cdc
-SIZE (cabal/Agda-2.3.0.tar.gz) = 608029
+SHA256 (cabal/Agda-2.3.0.1.tar.gz) = 5cc016a6cf113979d92af05c10b1e92dead4bf87861086177a017ce1d7605338
+SIZE (cabal/Agda-2.3.0.1.tar.gz) = 612342
diff --git a/math/hs-Agda/files/patch-Agda.cabal b/math/hs-Agda/files/patch-Agda.cabal
index 172bb274914e..e0c9851b621d 100644
--- a/math/hs-Agda/files/patch-Agda.cabal
+++ b/math/hs-Agda/files/patch-Agda.cabal
@@ -1,20 +1,28 @@
---- ./Agda.cabal.orig 2011-11-23 09:12:57.000000000 +0100
-+++ ./Agda.cabal 2011-12-03 04:20:35.000000000 +0100
-@@ -71,7 +71,7 @@
+--- ./Agda.cabal.orig 2012-03-12 11:09:34.000000000 +0100
++++ ./Agda.cabal 2012-05-12 19:53:25.000000000 +0200
+@@ -71,13 +71,13 @@
if flag(use-locale)
- build-depends: base >= 4.2 && < 4.5
+ build-depends: base >= 4.2 && < 4.6
else
- build-depends: base == 4.1.*,
+ build-depends: base >= 4.1,
utf8-string == 0.3.*
if flag(epic)
- build-depends: epic >= 0.1.13 && < 0.2
+ build-depends: epic >= 0.1.13 && < 0.10
+- build-depends: mtl == 2.0.*,
++ build-depends: mtl >= 2.0,
+ QuickCheck >= 2.3 && < 2.5,
+- haskell-src-exts >= 1.9.6 && < 1.12,
++ haskell-src-exts >= 1.9.6,
+ containers >= 0.1 && < 0.5,
+ pretty >= 1.0 && < 1.2,
+ directory >= 1.0 && < 1.2,
@@ -334,7 +334,7 @@
if flag(use-locale)
- build-depends: base >= 4.2 && < 4.5
+ build-depends: base >= 4.2 && < 4.6
else
- build-depends: base == 4.1.*,
+ build-depends: base >= 4.1,
utf8-string == 0.3.*
- build-depends: filepath >= 1.1 && < 1.3,
+ build-depends: filepath >= 1.1 && < 1.4,
process >= 1.0.1.0 && < 1.2,
diff --git a/math/hs-Agda/files/patch-src__full__Agda__Compiler__MAlonzo__Compiler.hs b/math/hs-Agda/files/patch-src__full__Agda__Compiler__MAlonzo__Compiler.hs
new file mode 100644
index 000000000000..bae4ce30dd13
--- /dev/null
+++ b/math/hs-Agda/files/patch-src__full__Agda__Compiler__MAlonzo__Compiler.hs
@@ -0,0 +1,11 @@
+--- ./src/full/Agda/Compiler/MAlonzo/Compiler.hs.orig 2012-03-12 11:09:33.000000000 +0100
++++ ./src/full/Agda/Compiler/MAlonzo/Compiler.hs 2012-04-08 22:51:55.000000000 +0200
+@@ -466,7 +466,7 @@
+ ]
+ where
+ parse = HS.parseWithMode
+- HS.defaultParseMode{HS.extensions = [HS.ExplicitForall]}
++ HS.defaultParseMode{HS.extensions = [HS.ExplicitForAll]}
+
+ ok (HS.ParseOk d) = d
+ ok HS.ParseFailed{} = __IMPOSSIBLE__