aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-01-19 17:50:26 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-01-19 17:50:26 +0000
commit2ec6a27178acf21b98f950b4b5525d35e3ef5c01 (patch)
treeb460a128685883ee64a559dca9de1e84dfe09ca5 /math
parentf15f446bf61b85f3bc860eb1a2cfa70de9fa3e40 (diff)
Notes
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/poly2tri/Makefile26
-rw-r--r--math/poly2tri/distinfo3
-rw-r--r--math/poly2tri/pkg-descr3
4 files changed, 33 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index e1afa3ccc9bd..88fc4558ca03 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -672,6 +672,7 @@
SUBDIR += ploticus-nox11
SUBDIR += plplot
SUBDIR += plplot-ada
+ SUBDIR += poly2tri
SUBDIR += polylib
SUBDIR += primegen
SUBDIR += primesieve
diff --git a/math/poly2tri/Makefile b/math/poly2tri/Makefile
new file mode 100644
index 000000000000..209043aee69f
--- /dev/null
+++ b/math/poly2tri/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= poly2tri
+DISTVERSION= g20191130
+CATEGORIES= math
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= 2D constrained Delaunay triangulation library
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libglfw.so:graphics/glfw
+
+USES= gl localbase:ldflags waf
+USE_GITHUB= yes
+GH_ACCOUNT= jhasse
+GH_TAGNAME= e6e63dd29ef0805b3e40fe1832c2f1fe2307943a
+USE_GL= gl
+
+PLIST_FILES= bin/p2t
+
+post-stage:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/p2t
+
+.include <bsd.port.mk>
diff --git a/math/poly2tri/distinfo b/math/poly2tri/distinfo
new file mode 100644
index 000000000000..da456f6c12ed
--- /dev/null
+++ b/math/poly2tri/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1579454830
+SHA256 (jhasse-poly2tri-g20191130-e6e63dd29ef0805b3e40fe1832c2f1fe2307943a_GH0.tar.gz) = 4c8c67b4495992742592f8da95447193f14d439e92f8fb8b03470b1a25ae02a9
+SIZE (jhasse-poly2tri-g20191130-e6e63dd29ef0805b3e40fe1832c2f1fe2307943a_GH0.tar.gz) = 254974
diff --git a/math/poly2tri/pkg-descr b/math/poly2tri/pkg-descr
new file mode 100644
index 000000000000..df9783776b90
--- /dev/null
+++ b/math/poly2tri/pkg-descr
@@ -0,0 +1,3 @@
+2D constrained Delaunay triangulation library.
+
+WWW: https://github.com/jhasse/poly2tri