aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2021-03-30 10:24:25 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2021-03-30 10:24:25 +0000
commit42bf4c920b0b8b21c77d3a069a7db65a4f96e7a9 (patch)
tree31ca392aee68975f0ad29ec213a401415e060dbc /math
parentd9c9350b0982bd7a714245f0b0ec544d34458864 (diff)
downloadports-42bf4c920b0b8b21c77d3a069a7db65a4f96e7a9.tar.gz
ports-42bf4c920b0b8b21c77d3a069a7db65a4f96e7a9.zip
Add a patch from upstream fixing build with older ncurses
Notes
Notes: svn path=/head/; revision=569546
Diffstat (limited to 'math')
-rw-r--r--math/sc-im/Makefile3
-rw-r--r--math/sc-im/files/patch-ncurses26
2 files changed, 28 insertions, 1 deletions
diff --git a/math/sc-im/Makefile b/math/sc-im/Makefile
index 7591d38fec21..506ae885832d 100644
--- a/math/sc-im/Makefile
+++ b/math/sc-im/Makefile
@@ -25,7 +25,8 @@ LIBS+= -lxlsreader -lxlsxwriter
MAKE_ENV+= LDLIBS="${LIBS}"
MAKE_ARGS+= CC="${CC}" prefix="${PREFIX}" MANDIR="${MANPREFIX}/man/man1"
+.include <bsd.port.pre.mk>
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/sc-im
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/math/sc-im/files/patch-ncurses b/math/sc-im/files/patch-ncurses
new file mode 100644
index 000000000000..f851547bff3f
--- /dev/null
+++ b/math/sc-im/files/patch-ncurses
@@ -0,0 +1,26 @@
+From 34b4619e1c856dd4f48f9ea55cff603ca6d19a98 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Andr=C3=A9s?= <andmarti@gmail.com>
+Date: Mon, 22 Mar 2021 09:04:56 -0300
+Subject: [PATCH] work on issue #482. added init_extended_pair according to
+ NCURSES version macros..
+
+---
+ src/tui.c | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/src/tui.c b/src/tui.c
+index ae9d9a91..c6aa73fe 100644
+--- tui.c
++++ tui.c
+@@ -1480,7 +1480,11 @@ void ui_start_colors() {
+ * NOTE: calling init_pair with -1 sets it with default
+ * terminal foreground and background colors
+ */
++#if defined(NCURSES_VERSION_MAJOR) && (( NCURSES_VERSION_MAJOR > 5 && defined(NCURSES_VERSION_MINOR) && NCURSES_VERSION_MINOR > 0) || NCURSES_VERSION_MAJOR > 6)
+ init_extended_pair( i*def+j+1, i-1, j-1); // i is fg and j is bg
++#else
++ init_pair(i*def+j+1, i-1, j-1); // i is fg and j is bg
++#endif
+ }
+ }
+ }