aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-08-05 15:05:29 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-08-05 15:05:29 +0000
commit43f0c9f153cbb6a2e3db53e004582f6729057928 (patch)
tree6094da914716107bca7d35889c1b8aab5e6097c7 /math
parent51a9b4dec5856fd0ce0b884de19626c1cc420758 (diff)
downloadports-43f0c9f153cbb6a2e3db53e004582f6729057928.tar.gz
ports-43f0c9f153cbb6a2e3db53e004582f6729057928.zip
- Convert to new perl framework
- Trim Makefile header Approved by: tobez@ (maintainer)
Notes
Notes: svn path=/head/; revision=324276
Diffstat (limited to 'math')
-rw-r--r--math/p5-Bit-Vector/Makefile3
-rw-r--r--math/p5-GIS-Distance-Fast/Makefile9
-rw-r--r--math/p5-Geo-Coordinates-UTM/Makefile3
-rw-r--r--math/p5-Geo-Distance-XS/Makefile9
-rw-r--r--math/p5-Graph/Makefile3
-rw-r--r--math/p5-Math-Base85/Makefile9
-rw-r--r--math/p5-Math-BigInt/Makefile9
-rw-r--r--math/p5-Math-ConvexHull/Makefile9
-rw-r--r--math/p5-Set-IntSpan-Fast-XS/Makefile9
-rw-r--r--math/p5-Set-IntSpan-Fast/Makefile9
-rw-r--r--math/p5-Set-Window/Makefile3
-rw-r--r--math/p5-Statistics-Basic/Makefile9
-rw-r--r--math/p5-Statistics-ChiSquare/Makefile9
-rw-r--r--math/p5-Statistics-Descriptive/Makefile3
-rw-r--r--math/p5-Statistics-Distributions/Makefile9
-rw-r--r--math/p5-Statistics-LTU/Makefile9
-rw-r--r--math/p5-Statistics-OLS/Makefile9
17 files changed, 46 insertions, 77 deletions
diff --git a/math/p5-Bit-Vector/Makefile b/math/p5-Bit-Vector/Makefile
index 676b027239aa..7b11c114cf08 100644
--- a/math/p5-Bit-Vector/Makefile
+++ b/math/p5-Bit-Vector/Makefile
@@ -13,7 +13,8 @@ COMMENT= Library of advanced math functions that includes a Perl OO module
RUN_DEPENDS= p5-Carp-Clan>=0:${PORTSDIR}/devel/p5-Carp-Clan
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Bit::Vector.3 Bit::Vector::Overload.3 Bit::Vector::String.3
diff --git a/math/p5-GIS-Distance-Fast/Makefile b/math/p5-GIS-Distance-Fast/Makefile
index 70a5a6b08282..f1029f8f1212 100644
--- a/math/p5-GIS-Distance-Fast/Makefile
+++ b/math/p5-GIS-Distance-Fast/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: math/p5-GIS-Distance-Fast
-# Date created: 01 February 2010
-# Whom: Anton Berezin <tobez@FreeBSD.org>
-#
+# Created by: Anton Berezin <tobez@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= GIS-Distance-Fast
PORTVERSION= 0.07
@@ -18,7 +14,8 @@ COMMENT= C implementation of GIS::Distance formulas
BUILD_DEPENDS= p5-GIS-Distance>=0.07:${PORTSDIR}/math/p5-GIS-Distance
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= GIS::Distance::Fast.3 \
GIS::Distance::Formula::Cosine::Fast.3 \
diff --git a/math/p5-Geo-Coordinates-UTM/Makefile b/math/p5-Geo-Coordinates-UTM/Makefile
index 1bfed42c25dd..188c2408646d 100644
--- a/math/p5-Geo-Coordinates-UTM/Makefile
+++ b/math/p5-Geo-Coordinates-UTM/Makefile
@@ -11,7 +11,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
COMMENT= Perl extension for converting latitude/longitude to UTM
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Geo::Coordinates::UTM.3
diff --git a/math/p5-Geo-Distance-XS/Makefile b/math/p5-Geo-Distance-XS/Makefile
index ba2cd5726c80..ac203accfce4 100644
--- a/math/p5-Geo-Distance-XS/Makefile
+++ b/math/p5-Geo-Distance-XS/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: math/p5-Geo-Distance-XS
-# Date created: 30 September 2009
-# Whom: Anton Berezin <tobez@FreeBSD.org>
-#
+# Created by: Anton Berezin <tobez@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Geo-Distance-XS
PORTVERSION= 0.11
@@ -18,7 +14,8 @@ BUILD_DEPENDS= p5-Geo-Distance>=0.16:${PORTSDIR}/math/p5-Geo-Distance
RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Simple>=0.94:${PORTSDIR}/devel/p5-Test-Simple
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Geo::Distance::XS.3
diff --git a/math/p5-Graph/Makefile b/math/p5-Graph/Makefile
index ae9df7330f87..8868b374d79f 100644
--- a/math/p5-Graph/Makefile
+++ b/math/p5-Graph/Makefile
@@ -15,7 +15,8 @@ BUILD_DEPENDS= p5-Heap>=0:${PORTSDIR}/devel/p5-Heap \
p5-Scalar-List-Utils>=0:${PORTSDIR}/lang/p5-Scalar-List-Utils
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Graph.3 \
Graph::AdjacencyMap.3 \
diff --git a/math/p5-Math-Base85/Makefile b/math/p5-Math-Base85/Makefile
index f5e70d255325..53f456f7203b 100644
--- a/math/p5-Math-Base85/Makefile
+++ b/math/p5-Math-Base85/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: math/p5-Math-Base85
-# Date created: 17 Sep 2001
-# Whom: Anton Berezin <tobez@FreeBSD.org>
-#
+# Created by: Anton Berezin <tobez@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Math-Base85
PORTVERSION= 0.2
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
COMMENT= Perl extension for base 85 numbers, as referenced by RFC 1924
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Math::Base85.3
diff --git a/math/p5-Math-BigInt/Makefile b/math/p5-Math-BigInt/Makefile
index de95365e670d..060aa2c9ffb6 100644
--- a/math/p5-Math-BigInt/Makefile
+++ b/math/p5-Math-BigInt/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: math/p5-Math-BigInt
-# Date created: 12 October 2001
-# Whom: tobez
-#
+# Created by: tobez
# $FreeBSD$
-#
PORTNAME= Math-BigInt
PORTVERSION= 1.997
@@ -15,7 +11,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
COMMENT= Math::BigInt - Arbitrary size integer math package
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Math::BigFloat.3 \
Math::BigInt.3 \
diff --git a/math/p5-Math-ConvexHull/Makefile b/math/p5-Math-ConvexHull/Makefile
index 665ad3b22f93..307e403056a8 100644
--- a/math/p5-Math-ConvexHull/Makefile
+++ b/math/p5-Math-ConvexHull/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: math/p5-Math-ConvexHull
-# Date created: 24 October 2005
-# Whom: Anton Berezin <tobez@FreeBSD.org>
-#
+# Created by: Anton Berezin <tobez@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Math-ConvexHull
PORTVERSION= 1.04
@@ -15,7 +11,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
COMMENT= Calculate convex hulls using Graham's scan (n*log(n))
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Math::ConvexHull.3
diff --git a/math/p5-Set-IntSpan-Fast-XS/Makefile b/math/p5-Set-IntSpan-Fast-XS/Makefile
index 9ecef8fd681a..427d33208dfa 100644
--- a/math/p5-Set-IntSpan-Fast-XS/Makefile
+++ b/math/p5-Set-IntSpan-Fast-XS/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: math/p5-Set-IntSpan-Fast-XS
-# Date created: 02 July 2008
-# Whom: Anton Berezin <tobez@FreeBSD.org>
-#
+# Created by: Anton Berezin <tobez@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Set-IntSpan-Fast-XS
PORTVERSION= 0.05
@@ -19,7 +15,8 @@ BUILD_DEPENDS= p5-Data-Swap>=0.07:${PORTSDIR}/devel/p5-Data-Swap \
p5-Set-IntSpan-Fast>=1.13:${PORTSDIR}/math/p5-Set-IntSpan-Fast
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Set::IntSpan::Fast::XS.3
diff --git a/math/p5-Set-IntSpan-Fast/Makefile b/math/p5-Set-IntSpan-Fast/Makefile
index d37e12ef85a5..72ad10ae7957 100644
--- a/math/p5-Set-IntSpan-Fast/Makefile
+++ b/math/p5-Set-IntSpan-Fast/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: math/p5-Set-IntSpan-Fast
-# Date created: 15 February 2007
-# Whom: Anton Berezin <tobez@FreeBSD.org>
-#
+# Created by: Anton Berezin <tobez@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Set-IntSpan-Fast
PORTVERSION= 1.15
@@ -17,7 +13,8 @@ COMMENT= Fast handling of sets containing integer spans
BUILD_DEPENDS= p5-Data-Types>=0:${PORTSDIR}/devel/p5-Data-Types
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Set::IntSpan::Fast.3 Set::IntSpan::Fast::PP.3
diff --git a/math/p5-Set-Window/Makefile b/math/p5-Set-Window/Makefile
index 77edd6b129e4..144712f0b2dd 100644
--- a/math/p5-Set-Window/Makefile
+++ b/math/p5-Set-Window/Makefile
@@ -10,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
COMMENT= Perl module to manage an interval on the integer line
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Set::Window.3
diff --git a/math/p5-Statistics-Basic/Makefile b/math/p5-Statistics-Basic/Makefile
index 22691327d9ad..fe2290904e24 100644
--- a/math/p5-Statistics-Basic/Makefile
+++ b/math/p5-Statistics-Basic/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: math/p5-Statistics-Basic
-# Date created: 28 July 2009
-# Whom: Anton Berezin <tobez@FreeBSD.org>
-#
+# Created by: Anton Berezin <tobez@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Statistics-Basic
PORTVERSION= 1.6607
@@ -18,7 +14,8 @@ COMMENT= A collection of very basic statistics modules
BUILD_DEPENDS= p5-Number-Format>=1.61:${PORTSDIR}/textproc/p5-Number-Format
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Statistics::Basic.3 \
Statistics::Basic::ComputedVector.3 \
diff --git a/math/p5-Statistics-ChiSquare/Makefile b/math/p5-Statistics-ChiSquare/Makefile
index b89641a92c71..01fcfbc271a2 100644
--- a/math/p5-Statistics-ChiSquare/Makefile
+++ b/math/p5-Statistics-ChiSquare/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: math/p5-Statistics-ChiSquare
-# Date created: 01 January 2001
-# Whom: Anton Berezin <tobez@tobez.org>
-#
+# Created by: Anton Berezin <tobez@tobez.org>
# $FreeBSD$
-#
PORTNAME= Statistics-ChiSquare
PORTVERSION= 0.5
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
COMMENT= How random is your data?
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Statistics::ChiSquare.3
diff --git a/math/p5-Statistics-Descriptive/Makefile b/math/p5-Statistics-Descriptive/Makefile
index 64b0ae46ca22..7cdd25fe8fb6 100644
--- a/math/p5-Statistics-Descriptive/Makefile
+++ b/math/p5-Statistics-Descriptive/Makefile
@@ -10,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
COMMENT= Perl module that supplies statistical methods for perl5
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Statistics::Descriptive.3 \
Statistics::Descriptive::Smoother.3 \
diff --git a/math/p5-Statistics-Distributions/Makefile b/math/p5-Statistics-Distributions/Makefile
index 113337573d5d..1e68c0443e4f 100644
--- a/math/p5-Statistics-Distributions/Makefile
+++ b/math/p5-Statistics-Distributions/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: math/p5-Statistics-Distributions
-# Date created: 01 January 2001
-# Whom: Anton Berezin <tobez@tobez.org>
-#
+# Created by: Anton Berezin <tobez@tobez.org>
# $FreeBSD$
-#
PORTNAME= Statistics-Distributions
PORTVERSION= 1.02
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
COMMENT= Perl module that calculates critical values of common statistical distributions
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Statistics::Distributions.3
diff --git a/math/p5-Statistics-LTU/Makefile b/math/p5-Statistics-LTU/Makefile
index 39429a70555a..c14cec12e9c0 100644
--- a/math/p5-Statistics-LTU/Makefile
+++ b/math/p5-Statistics-LTU/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: math/p5-Statistics-LTU
-# Date created: 01 January 2001
-# Whom: Anton Berezin <tobez@tobez.org>
-#
+# Created by: Anton Berezin <tobez@tobez.org>
# $FreeBSD$
-#
PORTNAME= Statistics-LTU
PORTVERSION= 2.8
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
COMMENT= Perl implementation of Linear Threshold Units
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Statistics::LTU.3
diff --git a/math/p5-Statistics-OLS/Makefile b/math/p5-Statistics-OLS/Makefile
index 288c6ad4145c..498eeada6248 100644
--- a/math/p5-Statistics-OLS/Makefile
+++ b/math/p5-Statistics-OLS/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: math/p5-Statistics-OLS
-# Date created: 02 January 2001
-# Whom: Anton Berezin <tobez@tobez.org>
-#
+# Created by: Anton Berezin <tobez@tobez.org>
# $FreeBSD$
-#
PORTNAME= Statistics-OLS
PORTVERSION= 0.07
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
COMMENT= Perl module to perform ordinary least squares and other bivariate statistics
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Statistics::OLS.3