aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-04-24 05:04:55 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-04-24 05:04:55 +0000
commit5215e7ecff164a6deaaba42a594eed7500da7981 (patch)
treed8de7896e840a151ff62fdfe8f739cef4f9dc9f5 /math
parent8a30e1b2d026e212a94a4cddbdb77e4b01612b69 (diff)
downloadports-5215e7ecff164a6deaaba42a594eed7500da7981.tar.gz
ports-5215e7ecff164a6deaaba42a594eed7500da7981.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/piranha/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/math/piranha/Makefile b/math/piranha/Makefile
index 2590edde17f8..168a0a359756 100644
--- a/math/piranha/Makefile
+++ b/math/piranha/Makefile
@@ -15,10 +15,8 @@ LICENSE_FILE_GPLv3= ${WRKSRC}/COPYING.gpl3
LICENSE_FILE_LGPL3= ${WRKSRC}/COPYING.lgpl3
# build only checks that boost, gmp, mpfr headers are installed, and in the runtime they are included, shared libs are never used directly
-BUILD_DEPENDS= ${LOCALBASE}/include/boost/numeric/conversion/cast.hpp:devel/boost-libs \
- ${LOCALBASE}/include/gmp.h:math/gmp \
- ${LOCALBASE}/include/mpfr.h:math/mpfr
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+BUILD_DEPENDS= ${HEADER_DEPENDS}
+RUN_DEPENDS= ${HEADER_DEPENDS}
USES= cmake:outsource
USE_GITHUB= yes
@@ -26,6 +24,10 @@ GH_ACCOUNT= bluescarni
NO_BUILD= yes
NO_ARCH= yes
+HEADER_DEPENDS= ${LOCALBASE}/include/boost/numeric/conversion/cast.hpp:devel/boost-libs \
+ ${LOCALBASE}/include/gmp.h:math/gmp \
+ ${LOCALBASE}/include/mpfr.h:math/mpfr
+
TEST_USES= compiler:c++14-lang
do-test: