aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2006-05-06 01:28:22 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2006-05-06 01:28:22 +0000
commit57c00223d04bb0f55e26ec4a558265cc703db1e4 (patch)
tree3249671a74c0166d3d7391fb6ae8fd63f48f4ed6 /math
parentff5d44386a0f35ef76ea2aadca5946fa10b8e982 (diff)
downloadports-57c00223d04bb0f55e26ec4a558265cc703db1e4.tar.gz
ports-57c00223d04bb0f55e26ec4a558265cc703db1e4.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/PDL/Makefile3
-rw-r--r--math/freefem++/Makefile3
-rw-r--r--math/freemat/Makefile9
-rw-r--r--math/labplot/Makefile4
-rw-r--r--math/orpie/Makefile3
-rw-r--r--math/p5-Math-GSL/Makefile4
-rw-r--r--math/pspp/Makefile3
-rw-r--r--math/py-gsl/Makefile3
-rw-r--r--math/qtiplot/Makefile4
-rw-r--r--math/yacas/Makefile3
10 files changed, 22 insertions, 17 deletions
diff --git a/math/PDL/Makefile b/math/PDL/Makefile
index 8c9912ec0023..47f1de9c8c43 100644
--- a/math/PDL/Makefile
+++ b/math/PDL/Makefile
@@ -8,6 +8,7 @@
PORTNAME= PDL
PORTVERSION= 2.4.2
+PORTREVISION= 1
CATEGORIES= math perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN:S/$/:cpan/} \
${MASTER_SITE_SOURCEFORGE:S/$/:sf/}
@@ -27,7 +28,7 @@ BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/PGPLOT.pm:${PORTSDIR}/graphics/pgperl \
${SITE_PERL}/Term/ReadLine/readline.pm:${PORTSDIR}/devel/p5-ReadLine-Perl
LIB_DEPENDS= plplotd.10:${PORTSDIR}/math/plplot \
fftw.2:${PORTSDIR}/math/fftw \
- gsl.7:${PORTSDIR}/math/gsl
+ gsl.9:${PORTSDIR}/math/gsl
RUN_DEPENDS= ${BUILD_DEPENDS}
USE_GL= yes
diff --git a/math/freefem++/Makefile b/math/freefem++/Makefile
index 1c87c537e4e9..95b0f1e6f0b6 100644
--- a/math/freefem++/Makefile
+++ b/math/freefem++/Makefile
@@ -7,6 +7,7 @@
PORTNAME= freefem++
PORTVERSION= 2.7
+PORTREVISION= 1
CATEGORIES= math science
MASTER_SITES= http://www.freefem.org/ff++/ftp/
@@ -15,7 +16,7 @@ COMMENT= An implementation of a language dedicated to the finite element method
LIB_DEPENDS= atlas.1:${PORTSDIR}/math/atlas \
f2c.2:${PORTSDIR}/lang/f2c \
- gsl.7:${PORTSDIR}/math/gsl \
+ gsl.9:${PORTSDIR}/math/gsl \
lapack.3:${PORTSDIR}/math/lapack \
fltk.1:${PORTSDIR}/x11-toolkits/fltk-threads \
fftw3.3:${PORTSDIR}/math/fftw3
diff --git a/math/freemat/Makefile b/math/freemat/Makefile
index 4b56e0a10faf..b76d390252f0 100644
--- a/math/freemat/Makefile
+++ b/math/freemat/Makefile
@@ -7,7 +7,7 @@
PORTNAME= freemat
PORTVERSION= 1.10
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math science
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -20,7 +20,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= An environment for rapid engineering and scientific processing
LIB_DEPENDS= f2c.2:${PORTSDIR}/lang/f2c \
- gsl.7:${PORTSDIR}/math/gsl \
+ gsl.9:${PORTSDIR}/math/gsl \
jpeg.9:${PORTSDIR}/graphics/jpeg \
lapack.3:${PORTSDIR}/math/lapack \
png.5:${PORTSDIR}/graphics/png \
@@ -29,7 +29,6 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libarpack.a:${PORTSDIR}/math/arpack \
${LOCALBASE}/lib/libumfpack.a:${PORTSDIR}/math/umfpack
USE_GL= yes
-USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-blas="${lib_blas}"
@@ -70,7 +69,7 @@ DATADIR= ${PREFIX}/share/FreeMat
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
-BROKEN= "Does not compile with gcc-2.95"
+BROKEN= Does not compile with gcc-2.95
.endif
.if exists(${LOCALBASE}/bin/balky)
@@ -78,7 +77,7 @@ WITH_MPI= yes
.endif
.if defined(WITH_MPI)
. if exists(${LOCALBASE}/bin/laminfo)
-BROKEN= "does not work with net/lam7, please install net/lam"
+BROKEN= does not work with net/lam7, please install net/lam
. endif
BUILD_DEPENDS+= mpiCC:${PORTSDIR}/net/lam
RUN_DEPENDS+= lamboot:${PORTSDIR}/net/lam
diff --git a/math/labplot/Makefile b/math/labplot/Makefile
index cf44ebf8a2fa..a86ba6cc76dc 100644
--- a/math/labplot/Makefile
+++ b/math/labplot/Makefile
@@ -7,7 +7,7 @@
PORTNAME= LabPlot
PORTVERSION= 1.5.0.5
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= math kde
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=labplot
@@ -18,7 +18,7 @@ COMMENT= LabPlot : Data analysis and visualisation
LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
Magick.9:${PORTSDIR}/graphics/ImageMagick \
audiofile.0:${PORTSDIR}/audio/libaudiofile \
- gsl.7:${PORTSDIR}/math/gsl \
+ gsl.9:${PORTSDIR}/math/gsl \
jasper.4:${PORTSDIR}/graphics/jasper \
fftw3.3:${PORTSDIR}/math/fftw3 \
netcdf:${PORTSDIR}/science/netcdf \
diff --git a/math/orpie/Makefile b/math/orpie/Makefile
index f3700189d636..b22b0dc4eac5 100644
--- a/math/orpie/Makefile
+++ b/math/orpie/Makefile
@@ -7,6 +7,7 @@
PORTNAME= orpie
PORTVERSION= 1.4.1
+PORTREVISION= 1
CATEGORIES+= math
MASTER_SITES= http://www.eecs.umich.edu/~pelzlpj/orpie/
@@ -14,7 +15,7 @@ MAINTAINER= dylan@dylex.net
COMMENT= A fullscreen RPN calculator for the console
BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml
-LIB_DEPENDS= gsl.7:${PORTSDIR}/math/gsl
+LIB_DEPENDS= gsl.9:${PORTSDIR}/math/gsl
GNU_CONFIGURE= yes
USE_GMAKE= yes
diff --git a/math/p5-Math-GSL/Makefile b/math/p5-Math-GSL/Makefile
index fe4d274f586a..790be98d1417 100644
--- a/math/p5-Math-GSL/Makefile
+++ b/math/p5-Math-GSL/Makefile
@@ -7,7 +7,7 @@
PORTNAME= Math-GSL
PORTVERSION= 0.01
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Math
@@ -16,7 +16,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= A perl interface to GNU Scientific Library
-LIB_DEPENDS= gsl.7:${PORTSDIR}/math/gsl
+LIB_DEPENDS= gsl.9:${PORTSDIR}/math/gsl
PERL_CONFIGURE= yes
MAKE_ENV= INC="-I${LOCALBASE}/include"
diff --git a/math/pspp/Makefile b/math/pspp/Makefile
index 858407888917..cd19b73d0273 100644
--- a/math/pspp/Makefile
+++ b/math/pspp/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pspp
PORTVERSION= 0.4.0
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -29,7 +30,7 @@ INFO= pspp
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500600
-BROKEN= "Needs at least Perl 5.6"
+BROKEN= needs at least Perl 5.6
.endif
.include <bsd.port.post.mk>
diff --git a/math/py-gsl/Makefile b/math/py-gsl/Makefile
index adf720852e34..d5252672651e 100644
--- a/math/py-gsl/Makefile
+++ b/math/py-gsl/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gsl
PORTVERSION= 0.3.2
+PORTREVISION= 1
CATEGORIES= math python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= pygsl
@@ -19,7 +20,7 @@ COMMENT= Python interface to GNU Scientific Library
BUILD_DEPENDS= ${PYNUMERIC}
RUN_DEPENDS= ${PYNUMERIC}
-LIB_DEPENDS= gsl.7:${PORTSDIR}/math/gsl
+LIB_DEPENDS= gsl.9:${PORTSDIR}/math/gsl
PLIST_SUB= PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR:S,^${LOCALBASE}/,,g}
USE_PYTHON= yes
diff --git a/math/qtiplot/Makefile b/math/qtiplot/Makefile
index c9cdaff2d7fe..b7b2df16be5e 100644
--- a/math/qtiplot/Makefile
+++ b/math/qtiplot/Makefile
@@ -7,6 +7,7 @@
PORTNAME= qtiplot
PORTVERSION= 0.6.4
+PORTREVISION= 1
CATEGORIES= math science
MASTER_SITES= http://soft.proindependent.com/src/
@@ -14,12 +15,11 @@ MAINTAINER= gaoj@cpsc.ucalgary.ca
COMMENT= An Origin clone for data analysis and scientific plotting
BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
-LIB_DEPENDS= gsl:${PORTSDIR}/math/gsl \
+LIB_DEPENDS= gsl.9:${PORTSDIR}/math/gsl \
qwt:${PORTSDIR}/x11-toolkits/qwt \
qwtplot3d:${PORTSDIR}/math/qwtplot3d
USE_BZIP2= yes
-USE_REINPLACE= yes
USE_GMAKE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/${PORTNAME}-${PORTVERSION}
diff --git a/math/yacas/Makefile b/math/yacas/Makefile
index 2056acbdd7d8..391bbce3cc6d 100644
--- a/math/yacas/Makefile
+++ b/math/yacas/Makefile
@@ -8,13 +8,14 @@
PORTNAME= yacas
PORTVERSION= 1.0.59
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= http://yacas.sourceforge.net/backups/
MAINTAINER= ports@FreeBSD.org
COMMENT= Yet Another Computer Algebra System
-LIB_DEPENDS= gsl.7:${PORTSDIR}/math/gsl
+LIB_DEPENDS= gsl.9:${PORTSDIR}/math/gsl
USE_PERL5_BUILD= yes
USE_GMAKE= yes