aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-03-09 07:23:45 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-03-09 07:23:45 +0000
commit59b28943a26d393fd239705187cf37d1dfae1702 (patch)
treed626fdc277c5c2fda6cd30694306f878bd90f657 /math
parent83faeecedb04e98a6cc1a2d997e763627901b55f (diff)
Notes
Diffstat (limited to 'math')
-rw-r--r--math/py-matplotlib/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/math/py-matplotlib/Makefile b/math/py-matplotlib/Makefile
index e3f542982fb2..123e164dc746 100644
--- a/math/py-matplotlib/Makefile
+++ b/math/py-matplotlib/Makefile
@@ -19,7 +19,6 @@ LIB_DEPENDS= libfreetype.so:print/freetype2 \
libfontconfig.so:x11-fonts/fontconfig \
libtcl86.so:lang/tcl86
RUN_DEPENDS= ${PYNUMPY} \
- ${PYTHON_PKGNAMEPREFIX}backports.functools_lru_cache>0:devel/py-backports.functools_lru_cache@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}cycler>0:devel/py-cycler@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}dateutil>=1.4:devel/py-dateutil@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytz>=0:devel/py-pytz@${FLAVOR} \
@@ -81,6 +80,12 @@ TKAGGBACKEND_BUILD_DEPENDS+= Xvfb:x11-servers/xorg-vfbserver
WXAGGBACKEND_BUILD_DEPENDS= Xvfb:x11-servers/xorg-vfbserver
.endif
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 3000
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}backports.functools_lru_cache>0:devel/py-backports.functools_lru_cache@${FLAVOR}
+.endif
+
post-extract:
${FIND} ${WRKSRC} -name \*.py | ${XARGS} ${CHMOD} -x
@@ -109,4 +114,4 @@ post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${CP} -R ${WRKSRC}/examples/ ${STAGEDIR}${EXAMPLESDIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>