aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-12-29 12:46:11 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-12-29 12:46:11 +0000
commit6272f4bbab50b18a00221b768393df1426c594c3 (patch)
treecdb319834544ce556a266038c0ec1416d60a9385 /math
parenta479fa662bb25e8a11e9226cd5b043210c3f91ce (diff)
Notes
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/py-hdbscan/Makefile26
-rw-r--r--math/py-hdbscan/distinfo3
-rw-r--r--math/py-hdbscan/pkg-descr14
4 files changed, 44 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index bf966a56c13f..aa244eb54807 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -719,6 +719,7 @@
SUBDIR += py-grandalf
SUBDIR += py-graphillion
SUBDIR += py-gym
+ SUBDIR += py-hdbscan
SUBDIR += py-igakit
SUBDIR += py-igraph
SUBDIR += py-intspan
diff --git a/math/py-hdbscan/Makefile b/math/py-hdbscan/Makefile
new file mode 100644
index 000000000000..1851947f308f
--- /dev/null
+++ b/math/py-hdbscan/Makefile
@@ -0,0 +1,26 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= hdbscan
+PORTVERSION= 0.8.24
+CATEGORIES= math python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Clustering based on density with variable density clusters
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYNUMPY}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}joblib>=0:devel/py-joblib@${PY_FLAVOR} \
+ ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}scikit-learn>=0:science/py-scikit-learn@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>=0:science/py-scipy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>=0:devel/py-six@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent cython distutils
+
+.include <bsd.port.mk>
diff --git a/math/py-hdbscan/distinfo b/math/py-hdbscan/distinfo
new file mode 100644
index 000000000000..d92165e0e1a1
--- /dev/null
+++ b/math/py-hdbscan/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1577523844
+SHA256 (hdbscan-0.8.24.tar.gz) = fe31a7ea0ce2c9babd190a195e491834ff9f64c74daa4ca94fa65a88f701269a
+SIZE (hdbscan-0.8.24.tar.gz) = 4356868
diff --git a/math/py-hdbscan/pkg-descr b/math/py-hdbscan/pkg-descr
new file mode 100644
index 000000000000..753f6a83dfd3
--- /dev/null
+++ b/math/py-hdbscan/pkg-descr
@@ -0,0 +1,14 @@
+HDBSCAN - Hierarchical Density-Based Spatial Clustering of Applications with
+Noise. Performs DBSCAN over varying epsilon values and integrates the result to
+find a clustering that gives the best stability over epsilon. This allows
+HDBSCAN to find clusters of varying densities (unlike DBSCAN), and be more
+robust to parameter selection.
+
+In practice this means that HDBSCAN returns a good clustering straight away with
+little or no parameter tuning -- and the primary parameter, minimum cluster
+size, is intuitive and easy to select.
+
+HDBSCAN is ideal for exploratory data analysis; it's a fast and robust algorithm
+that you can trust to return meaningful clusters (if there are any).
+
+WWW: https://github.com/scikit-learn-contrib/hdbscan