aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-07-24 02:03:41 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-07-24 02:03:41 +0000
commit6281532dad65ce42ad6341ed46ca481278d70a50 (patch)
treece00d9959a869d9733ed556a136ae00b8a63cb92 /math
parentf443dee6318e2ff3b869a3add0a6c5155b5a7e7c (diff)
downloadports-6281532dad65ce42ad6341ed46ca481278d70a50.tar.gz
ports-6281532dad65ce42ad6341ed46ca481278d70a50.zip
math/colpack: fix build on powerpc
CMake Error at /usr/local/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:230 (message): Could NOT find OpenMP_C (missing: OpenMP_C_FLAGS OpenMP_C_LIB_NAMES)
Diffstat (limited to 'math')
-rw-r--r--math/colpack/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/math/colpack/Makefile b/math/colpack/Makefile
index 6be895e4c536..6f14e10cf6bc 100644
--- a/math/colpack/Makefile
+++ b/math/colpack/Makefile
@@ -10,7 +10,7 @@ COMMENT= Graph Coloring Algorithm Package
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= cmake compiler:c++11-lang
+USES= cmake
USE_LDCONFIG= yes
USE_GITHUB= yes
@@ -19,4 +19,12 @@ GH_PROJECT= ColPack
CMAKE_SOURCE_PATH= ${WRKSRC}/build/cmake
+.include <bsd.port.options.mk>
+
+.if ${ARCH} == powerpc
+USES+= compiler:gcc-c++11-lib
+.else
+USES+= compiler:c++11-lang
+.endif
+
.include <bsd.port.mk>