aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-06-23 10:51:44 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-06-23 10:51:44 +0000
commit67cfe5db5a8492338356e3b16f3296daee71983e (patch)
tree03d12ab271deb2593e82857f0c0b81b4718cbf08 /math
parent4269f33bb7268d12c7371989142590527d7dab45 (diff)
downloadports-67cfe5db5a8492338356e3b16f3296daee71983e.tar.gz
ports-67cfe5db5a8492338356e3b16f3296daee71983e.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/grace/Makefile85
-rw-r--r--math/grace/distinfo6
-rw-r--r--math/grace/files/patch-ab11
-rw-r--r--math/grace/files/patch-ac11
-rw-r--r--math/grace/files/patch-ad11
-rw-r--r--math/grace/files/patch-ae13
-rw-r--r--math/grace/files/patch-af19
-rw-r--r--math/grace/files/patch-configure (renamed from math/grace/files/patch-aa)0
-rw-r--r--math/grace/files/patch-src__dlmodule.c (renamed from math/grace/files/patch-ag)6
-rw-r--r--math/grace/files/patch-src__pdfdrv.c11
-rw-r--r--math/grace/pkg-plist185
11 files changed, 165 insertions, 193 deletions
diff --git a/math/grace/Makefile b/math/grace/Makefile
index e484c889f530..578f472f5b54 100644
--- a/math/grace/Makefile
+++ b/math/grace/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= grace
-PORTVERSION= 5.1.21
-PORTREVISION= 1
+PORTVERSION= 5.1.22
CATEGORIES= math print
#
MASTER_SITES= ftp://plasma-gate.weizmann.ac.il/pub/grace/src/stable/ \
@@ -20,37 +19,71 @@ MASTER_SITES= ftp://plasma-gate.weizmann.ac.il/pub/grace/src/stable/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= A powerful plotting tool (successor of xmgr)
-LIB_DEPENDS= Xbae:${PORTSDIR}/x11-toolkits/xbae \
- netcdf.4:${PORTSDIR}/science/netcdf \
- fftw.2:${PORTSDIR}/math/fftw \
- tiff.4:${PORTSDIR}/graphics/tiff \
+LIB_DEPENDS= t1:${PORTSDIR}/devel/t1lib \
jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png \
- t1:${PORTSDIR}/devel/t1lib \
- XmHTML.1:${PORTSDIR}/x11-toolkits/xmhtml\
- pdf.8:${PORTSDIR}/print/pdflib
-
-MAN1= convcal.1 grace.1 xmgrace.1 gracebat.1 grconvert.1
+ tiff.4:${PORTSDIR}/graphics/tiff \
+ fftw.2:${PORTSDIR}/math/fftw \
+ pdf.8:${PORTSDIR}/print/pdflib \
+ netcdf.4:${PORTSDIR}/science/netcdf \
+ Xbae.4:${PORTSDIR}/x11-toolkits/xbae \
+ XmHTML.1:${PORTSDIR}/x11-toolkits/xmhtml
-USE_GMAKE= YES
-USE_MOTIF= YES
-GNU_CONFIGURE= YES
-CONFIGURE_ARGS= \
- --with-extra-incpath=${LOCALBASE}/include/X11:${LOCALBASE}/include \
- --with-extra-ldpath=${LOCALBASE}/lib --without-bundled_xbae \
- --enable-grace-home=${DATADIR}
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_GNOME= gnometarget
+USE_MOTIF= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-grace-home=${DATADIR} \
+ --with-extra-incpath=${LOCALBASE}/include \
+ --with-extra-ldpath=${LOCALBASE}/lib \
+ --without-bundled-xbae
ALL_TARGET= # empty
-INSTALL_TARGET= install links
-pre-configure:
- @${REINPLACE_CMD} -e "s%-lXm %${MOTIFLIB} %" ${WRKSRC}/configure
+MAN1= convcal.1 grace.1 grconvert.1
+MLINKS= grace.1 gracebat.1 \
+ grace.1 xmgrace.1
-post-install:
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/xmgrace ${PREFIX}/bin
+ @${LN} -sf xmgrace ${PREFIX}/bin/grace
+ @${LN} -sf xmgrace ${PREFIX}/bin/gracebat
+ ${INSTALL_PROGRAM} ${WRKSRC}/auxiliary/convcal ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/grconvert/grconvert ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/auxiliary/fdf2fit ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/doc/*.1 ${MANPREFIX}/man/man1
+ ${INSTALL_DATA} ${WRKSRC}/grace_np/grace_np.h ${PREFIX}/include
+ ${INSTALL_DATA} ${WRKSRC}/grace_np/libgrace_np.a ${PREFIX}/lib
+ @${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/gracerc ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/gracerc.user ${DATADIR}
+ @${MKDIR} ${DATADIR}/auxiliary
+ ${INSTALL_DATA} ${WRKSRC}/auxiliary/README ${DATADIR}/auxiliary
+ ${INSTALL_DATA} ${WRKSRC}/auxiliary/convcal.c ${DATADIR}/auxiliary
+ ${INSTALL_DATA} ${WRKSRC}/auxiliary/magic.grace ${DATADIR}/auxiliary
+ @${MKDIR} ${DATADIR}/fonts
+ ${INSTALL_DATA} ${WRKSRC}/fonts/FontDataBase ${DATADIR}/fonts
+ @${MKDIR} ${DATADIR}/fonts/enc
+ ${INSTALL_DATA} ${WRKSRC}/fonts/enc/*.enc ${DATADIR}/fonts/enc
+ @${MKDIR} ${DATADIR}/fonts/type1
+ ${INSTALL_DATA} ${WRKSRC}/fonts/type1/*.afm ${DATADIR}/fonts/type1
+ ${INSTALL_DATA} ${WRKSRC}/fonts/type1/*.pfb ${DATADIR}/fonts/type1
+ @${MKDIR} ${DATADIR}/templates
+ ${INSTALL_DATA} ${WRKSRC}/templates/*.agr ${DATADIR}/templates
.if !defined(NOPORTDOCS)
- if [ ! -e ${DOCSDIR} ]; then \
- ${LN} -s ${DATADIR}/doc ${DOCSDIR}; \
- fi
+ @${MKDIR} ${DOCSDIR}
+ @${TAR} -C ${WRKSRC}/doc --exclude "*Makefile*" --exclude "*.1" \
+ -cf - . | ${TAR} -C ${DOCSDIR} --unlink -xf -
+ @${FIND} ${DOCSDIR} -exec ${CHOWN} ${SHAREOWN}:${SHAREGRP} {} \;
+ @${FIND} ${DOCSDIR} -type f -exec ${CHMOD} ${SHAREMODE} {} \;
+ @${LN} -sf ${DOCSDIR} ${DATADIR}/doc
+.endif
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+ @${TAR} -C ${WRKSRC}/examples --exclude "*Makefile*" \
+ -cf - . | ${TAR} -C ${EXAMPLESDIR} --unlink -xf -
+ @${FIND} ${EXAMPLESDIR} -exec ${CHOWN} ${SHAREOWN}:${SHAREGRP} {} \;
+ @${FIND} ${EXAMPLESDIR} -type f -exec ${CHMOD} ${SHAREMODE} {} \;
+ @${LN} -sf ${EXAMPLESDIR} ${DATADIR}/examples
.endif
.include <bsd.port.mk>
diff --git a/math/grace/distinfo b/math/grace/distinfo
index 0ad209f00377..a13a64506bf5 100644
--- a/math/grace/distinfo
+++ b/math/grace/distinfo
@@ -1,3 +1,3 @@
-MD5 (grace-5.1.21.tar.gz) = db02dee3c68179c41452e652bd469bb9
-SHA256 (grace-5.1.21.tar.gz) = 30e4b5d86f4b966428aac5d8c5d0468bcf28226eea9e00d9eb4886f4ab094b00
-SIZE (grace-5.1.21.tar.gz) = 2474115
+MD5 (grace-5.1.22.tar.gz) = 672356466f18fe59ed21a8fb44f9851d
+SHA256 (grace-5.1.22.tar.gz) = 4ce8f058b6c1267a842419a3edbf471421dea9cf5744783745b6cb375cdf5f25
+SIZE (grace-5.1.22.tar.gz) = 2516576
diff --git a/math/grace/files/patch-ab b/math/grace/files/patch-ab
deleted file mode 100644
index 5d298e90d053..000000000000
--- a/math/grace/files/patch-ab
+++ /dev/null
@@ -1,11 +0,0 @@
-*** ac-tools/Make.conf.in.orig Mon May 22 19:57:32 2000
---- ac-tools/Make.conf.in Mon May 22 19:57:36 2000
-***************
-*** 90,95 ****
---- 90,96 ----
- # BSD install
- INSTALL=@INSTALL@
- INSTALL_PROGRAM=@INSTALL_PROGRAM@
-+ INSTALL_SCRIPT=@INSTALL_SCRIPT@
- INSTALL_DATA=@INSTALL_DATA@
- MKINSTALLDIRS=@MKINSTALLDIRS@
diff --git a/math/grace/files/patch-ac b/math/grace/files/patch-ac
deleted file mode 100644
index 59eb403ab4e2..000000000000
--- a/math/grace/files/patch-ac
+++ /dev/null
@@ -1,11 +0,0 @@
---- examples/Makefile.orig Sat Jun 22 12:40:21 2002
-+++ examples/Makefile Mon Aug 12 01:59:44 2002
-@@ -33,7 +33,7 @@
- install : $(EXAMPLES) $(DOTEST)
- $(MKINSTALLDIRS) $(DESTDIR)$(GRACE_HOME)/examples
- for i in $(EXAMPLES); do $(INSTALL_DATA) $$i $(DESTDIR)$(GRACE_HOME)/examples; done
-- $(INSTALL_PROGRAM) $(DOTEST) $(DESTDIR)$(GRACE_HOME)/examples/$(DOTEST)
-+ $(INSTALL_SCRIPT) $(DOTEST) $(DESTDIR)$(GRACE_HOME)/examples/$(DOTEST)
-
- links : dummy
-
diff --git a/math/grace/files/patch-ad b/math/grace/files/patch-ad
deleted file mode 100644
index ee8ee32af204..000000000000
--- a/math/grace/files/patch-ad
+++ /dev/null
@@ -1,11 +0,0 @@
---- doc/Makefile.orig Sat Jun 22 12:40:21 2002
-+++ doc/Makefile Mon Aug 12 02:05:28 2002
-@@ -97,7 +97,7 @@
- $(MKINSTALLDIRS) $(DESTDIR)$(PREFIX)/man
- $(MKINSTALLDIRS) $(DESTDIR)$(PREFIX)/man/man1
- cd $(DESTDIR)$(PREFIX)/man/man1; \
-- for i in $(MANPAGES) $(MANLINKS); do $(RM) $$i; $(LN_S) $(GRACE_HOME)/doc/$$i $$i; done
-+ for i in $(MANPAGES) $(MANLINKS); do $(RM) $$i; $(INSTALL_DATA) $(GRACE_HOME)/doc/$$i $$i; done
-
- tests : dummy
-
diff --git a/math/grace/files/patch-ae b/math/grace/files/patch-ae
deleted file mode 100644
index 5f5cd7f0d063..000000000000
--- a/math/grace/files/patch-ae
+++ /dev/null
@@ -1,13 +0,0 @@
-*** src/pdfdrv.c.org Thu Apr 20 22:34:34 2000
---- src/pdfdrv.c Thu Aug 3 21:23:05 2000
-***************
-*** 57,62 ****
---- 57,64 ----
- # include "motifinc.h"
- #endif
-
-+ #define PDF_set_fillrule(handle, rule) PDF_set_parameter(handle, "fillrule", rule)
-+
- static void pdf_error_handler(PDF *p, int type, const char* msg);
-
- static unsigned long page_scale;
diff --git a/math/grace/files/patch-af b/math/grace/files/patch-af
deleted file mode 100644
index 611d4b0e15a2..000000000000
--- a/math/grace/files/patch-af
+++ /dev/null
@@ -1,19 +0,0 @@
-*** auxiliary/Makefile.orig Sat Jun 22 13:40:21 2002
---- auxiliary/Makefile Mon Aug 26 10:07:23 2002
-***************
-*** 28,34 ****
- $(MKINSTALLDIRS) $(DESTDIR)$(GRACE_HOME)/auxiliary
- for i in $(AUXILIARIES); do $(INSTALL_DATA) $$i $(DESTDIR)$(GRACE_HOME)/auxiliary; done
- for i in $(PROGRAMS); do $(INSTALL_PROGRAM) -s $$i $(DESTDIR)$(GRACE_HOME)/bin; done
-! for i in $(SCRIPTS); do $(INSTALL_PROGRAM) $$i $(DESTDIR)$(GRACE_HOME)/bin; done
-
- tests : dummy
-
---- 28,34 ----
- $(MKINSTALLDIRS) $(DESTDIR)$(GRACE_HOME)/auxiliary
- for i in $(AUXILIARIES); do $(INSTALL_DATA) $$i $(DESTDIR)$(GRACE_HOME)/auxiliary; done
- for i in $(PROGRAMS); do $(INSTALL_PROGRAM) -s $$i $(DESTDIR)$(GRACE_HOME)/bin; done
-! for i in $(SCRIPTS); do $(INSTALL_SCRIPT) $$i $(DESTDIR)$(GRACE_HOME)/bin; done
-
- tests : dummy
-
diff --git a/math/grace/files/patch-aa b/math/grace/files/patch-configure
index 71e9b196a5d8..71e9b196a5d8 100644
--- a/math/grace/files/patch-aa
+++ b/math/grace/files/patch-configure
diff --git a/math/grace/files/patch-ag b/math/grace/files/patch-src__dlmodule.c
index f8312f0b9bf7..9e36b34e06f4 100644
--- a/math/grace/files/patch-ag
+++ b/math/grace/files/patch-src__dlmodule.c
@@ -1,5 +1,5 @@
---- src/dlmodule.c.orig 3 Jul 2004 20:47:45 -0000
-+++ src/dlmodule.c 27 Oct 2005 11:08:30 -0000
+--- src/dlmodule.c.orig 2005-11-13 07:45:16.000000000 +0900
++++ src/dlmodule.c 2008-06-16 15:28:33.000000000 +0900
@@ -89,6 +89,9 @@
return RETURN_FAILURE;
}
@@ -8,5 +8,5 @@
+ dlerror();
+
newkey.data = dlsym(handle, dl_function);
- if ((error = (char *) dlerror()) != NULL) {
+ if (!newkey.data && (error = dlerror()) != NULL) {
errmsg(error);
diff --git a/math/grace/files/patch-src__pdfdrv.c b/math/grace/files/patch-src__pdfdrv.c
new file mode 100644
index 000000000000..6d6200713bfe
--- /dev/null
+++ b/math/grace/files/patch-src__pdfdrv.c
@@ -0,0 +1,11 @@
+--- src/pdfdrv.c.orig 2004-08-05 04:37:47.000000000 +0900
++++ src/pdfdrv.c 2008-06-16 15:29:00.000000000 +0900
+@@ -57,6 +57,8 @@
+ # include "motifinc.h"
+ #endif
+
++#define PDF_set_fillrule(handle, rule) PDF_set_parameter(handle, "fillrule", rule)
++
+ static void pdf_error_handler(PDF *p, int type, const char* msg);
+
+ static unsigned long page_scale;
diff --git a/math/grace/pkg-plist b/math/grace/pkg-plist
index 30192a48e6b3..b7d9eeb7bfef 100644
--- a/math/grace/pkg-plist
+++ b/math/grace/pkg-plist
@@ -1,98 +1,96 @@
+bin/convcal
+bin/fdf2fit
bin/grace
bin/gracebat
+bin/grconvert
bin/xmgrace
include/grace_np.h
+lib/libgrace_np.a
+%%PORTDOCS%%%%DOCSDIR%%/10.1.dat
+%%PORTDOCS%%%%DOCSDIR%%/10a.dat
+%%PORTDOCS%%%%DOCSDIR%%/10b.dat
+%%PORTDOCS%%%%DOCSDIR%%/10c.dat
+%%PORTDOCS%%%%DOCSDIR%%/2.1.dat
+%%PORTDOCS%%%%DOCSDIR%%/3.dat
+%%PORTDOCS%%%%DOCSDIR%%/7.1.2.agr
+%%PORTDOCS%%%%DOCSDIR%%/7.1.3.agr
+%%PORTDOCS%%%%DOCSDIR%%/8.2.dat
+%%PORTDOCS%%%%DOCSDIR%%/CHANGES.html
+%%PORTDOCS%%%%DOCSDIR%%/FAQ.dvi
+%%PORTDOCS%%%%DOCSDIR%%/FAQ.html
+%%PORTDOCS%%%%DOCSDIR%%/FAQ.sgml
+%%PORTDOCS%%%%DOCSDIR%%/GPL.html
+%%PORTDOCS%%%%DOCSDIR%%/Tutorial.dvi
+%%PORTDOCS%%%%DOCSDIR%%/Tutorial.html
+%%PORTDOCS%%%%DOCSDIR%%/Tutorial.sgml
+%%PORTDOCS%%%%DOCSDIR%%/UsersGuide.dvi
+%%PORTDOCS%%%%DOCSDIR%%/UsersGuide.html
+%%PORTDOCS%%%%DOCSDIR%%/UsersGuide.sgml
+%%PORTDOCS%%%%DOCSDIR%%/mygraph.png
+%%PORTDOCS%%%%DOCSDIR%%/nohelp.html
+%%PORTDOCS%%%%DOCSDIR%%/philosophical-gnu-sm.jpg
+%%PORTDOCS%%%%DOCSDIR%%/shiftdata.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/altaxis.par
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/arrows.agr
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/au.agr
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/axes.agr
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bar.agr
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/boxplot.agr
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/brw.dat
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/chartebar.agr
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/charts.agr
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/co2.agr
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/co2.par
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/dotest
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/explain.agr
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fills.agr
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphs.par
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hilo.agr
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/log.dat
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/log2.agr
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/log2log.agr
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/logistic.agr
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/logistic.fit
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/logit.agr
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/logtest.par
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/manygraphs.agr
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mlo.dat
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/motif.agr
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pie.agr
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/polar.agr
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/props.agr
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/reciprocal.agr
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/regions.par
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/spectrum.agr
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/stackedb.agr
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/symslines.agr
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/terr.agr
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test.com
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test.dat
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test1.par
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test2.agr
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tfonts.agr
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tforms.par
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/times.agr
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tinset.agr
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tlog.agr
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tmc.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tstack.agr
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/txttrans.agr
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/txyr.agr
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/typeset.agr
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/vmap.agr
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/xycolor.agr
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/xysize.agr
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/xyz.agr
%%DATADIR%%/auxiliary/README
%%DATADIR%%/auxiliary/convcal.c
%%DATADIR%%/auxiliary/magic.grace
-%%DATADIR%%/bin/convcal
-%%DATADIR%%/bin/fdf2fit
-%%DATADIR%%/bin/gracebat
-%%DATADIR%%/bin/grconvert
-%%DATADIR%%/bin/xmgrace
-%%DATADIR%%/doc/10.1.dat
-%%DATADIR%%/doc/10a.dat
-%%DATADIR%%/doc/10b.dat
-%%DATADIR%%/doc/10c.dat
-%%DATADIR%%/doc/2.1.dat
-%%DATADIR%%/doc/3.dat
-%%DATADIR%%/doc/7.1.2.agr
-%%DATADIR%%/doc/7.1.3.agr
-%%DATADIR%%/doc/8.2.dat
-%%DATADIR%%/doc/CHANGES.html
-%%DATADIR%%/doc/FAQ.dvi
-%%DATADIR%%/doc/FAQ.html
-%%DATADIR%%/doc/GPL.html
-%%DATADIR%%/doc/Tutorial.dvi
-%%DATADIR%%/doc/Tutorial.html
-%%DATADIR%%/doc/UsersGuide.dvi
-%%DATADIR%%/doc/UsersGuide.html
-%%DATADIR%%/doc/convcal.1
-%%DATADIR%%/doc/grace.1
-%%DATADIR%%/doc/gracebat.1
-%%DATADIR%%/doc/grconvert.1
-%%DATADIR%%/doc/mygraph.png
-%%DATADIR%%/doc/nohelp.html
-%%DATADIR%%/doc/philosophical-gnu-sm.jpg
-%%DATADIR%%/doc/shiftdata.sh
-%%DATADIR%%/doc/xmgrace.1
-%%DATADIR%%/examples/altaxis.par
-%%DATADIR%%/examples/arrows.agr
-%%DATADIR%%/examples/au.agr
-%%DATADIR%%/examples/axes.agr
-%%DATADIR%%/examples/bar.agr
-%%DATADIR%%/examples/boxplot.agr
-%%DATADIR%%/examples/brw.dat
-%%DATADIR%%/examples/chartebar.agr
-%%DATADIR%%/examples/charts.agr
-%%DATADIR%%/examples/co2.agr
-%%DATADIR%%/examples/co2.par
-%%DATADIR%%/examples/dotest
-%%DATADIR%%/examples/explain.agr
-%%DATADIR%%/examples/fills.agr
-%%DATADIR%%/examples/graphs.par
-%%DATADIR%%/examples/hilo.agr
-%%DATADIR%%/examples/log.dat
-%%DATADIR%%/examples/log2.agr
-%%DATADIR%%/examples/log2log.agr
-%%DATADIR%%/examples/logistic.agr
-%%DATADIR%%/examples/logistic.fit
-%%DATADIR%%/examples/logit.agr
-%%DATADIR%%/examples/logtest.par
-%%DATADIR%%/examples/manygraphs.agr
-%%DATADIR%%/examples/mlo.dat
-%%DATADIR%%/examples/motif.agr
-%%DATADIR%%/examples/pie.agr
-%%DATADIR%%/examples/polar.agr
-%%DATADIR%%/examples/props.agr
-%%DATADIR%%/examples/reciprocal.agr
-%%DATADIR%%/examples/regions.par
-%%DATADIR%%/examples/spectrum.agr
-%%DATADIR%%/examples/stackedb.agr
-%%DATADIR%%/examples/symslines.agr
-%%DATADIR%%/examples/terr.agr
-%%DATADIR%%/examples/test.com
-%%DATADIR%%/examples/test.dat
-%%DATADIR%%/examples/test1.par
-%%DATADIR%%/examples/test2.agr
-%%DATADIR%%/examples/tfonts.agr
-%%DATADIR%%/examples/tforms.par
-%%DATADIR%%/examples/times.agr
-%%DATADIR%%/examples/tinset.agr
-%%DATADIR%%/examples/tlog.agr
-%%DATADIR%%/examples/tmc.c
-%%DATADIR%%/examples/tstack.agr
-%%DATADIR%%/examples/txttrans.agr
-%%DATADIR%%/examples/txyr.agr
-%%DATADIR%%/examples/typeset.agr
-%%DATADIR%%/examples/vmap.agr
-%%DATADIR%%/examples/xycolor.agr
-%%DATADIR%%/examples/xysize.agr
-%%DATADIR%%/examples/xyz.agr
%%DATADIR%%/fonts/FontDataBase
%%DATADIR%%/fonts/enc/CP1251.enc
%%DATADIR%%/fonts/enc/IsoLatin1.enc
%%DATADIR%%/fonts/enc/IsoLatin2.enc
+%%DATADIR%%/fonts/enc/IsoLatin5.enc
%%DATADIR%%/fonts/enc/IsoLatin7.enc
%%DATADIR%%/fonts/enc/IsoLatin9.enc
%%DATADIR%%/fonts/enc/KOI8-R.enc
@@ -131,19 +129,14 @@ include/grace_np.h
%%DATADIR%%/fonts/type1/s050000l.pfb
%%DATADIR%%/gracerc
%%DATADIR%%/gracerc.user
-%%DATADIR%%/include/grace_np.h
-%%DATADIR%%/lib/libgrace_np.a
%%DATADIR%%/templates/Default.agr
-lib/libgrace_np.a
-@dirrm %%DATADIR%%/auxiliary
-@dirrm %%DATADIR%%/bin
-@dirrm %%DATADIR%%/doc
-@dirrm %%DATADIR%%/examples
-@dirrm %%DATADIR%%/fonts/enc
+@dirrm %%DATADIR%%/templates
@dirrm %%DATADIR%%/fonts/type1
+@dirrm %%DATADIR%%/fonts/enc
@dirrm %%DATADIR%%/fonts
-@dirrm %%DATADIR%%/include
-@dirrm %%DATADIR%%/lib
-@dirrm %%DATADIR%%/templates
+%%PORTEXAMPLES%%@dirrm %%DATADIR%%/examples
+%%PORTDOCS%%@dirrm %%DATADIR%%/doc
+@dirrm %%DATADIR%%/auxiliary
@dirrm %%DATADIR%%
-%%PORTDOCS%%%%DOCSDIR%%
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%