aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2008-06-14 04:47:35 +0000
committerMaho Nakata <maho@FreeBSD.org>2008-06-14 04:47:35 +0000
commit72cdf3f1b207c7d6a935b899616a5e98794efe32 (patch)
treecefb1f9cb28ebad601775728a9d15e02187b2ccc /math
parented91e1908d5758ebc355b114aae7170430ede81a (diff)
downloadports-72cdf3f1b207c7d6a935b899616a5e98794efe32.tar.gz
ports-72cdf3f1b207c7d6a935b899616a5e98794efe32.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/gotoblas/Makefile6
-rw-r--r--math/gotoblas/distinfo6
-rw-r--r--math/gotoblas/files/patch-Makefile.rule102
-rw-r--r--math/gotoblas/files/patch-getarch16
-rw-r--r--math/gotoblas/files/patch-level1-asum-Makefile14
-rw-r--r--math/gotoblas/files/patch-level1-others-Makefile16
-rw-r--r--math/gotoblas/files/patch-level3-Makefile19
7 files changed, 108 insertions, 71 deletions
diff --git a/math/gotoblas/Makefile b/math/gotoblas/Makefile
index e16b9410598a..cf5005ff4ad4 100644
--- a/math/gotoblas/Makefile
+++ b/math/gotoblas/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gotoblas
-PORTVERSION= 1.23
+PORTVERSION= 1.26
CATEGORIES= math
MASTER_SITES= #empty
DISTNAME= GotoBLAS-${PORTVERSION}
@@ -85,9 +85,9 @@ do-fetch:
@${ECHO_CMD} "and put it to ${DISTDIR}."
.endif
-#Honor F77 and CC, but this makes Makefile.rule bit dirtier
+#Honor FC and CC, but this makes Makefile.rule bit dirtier
pre-build:
- @${REINPLACE_CMD} -e "s+%%F77%%+${F77}+" -e "s+%%CC%%+${CC}+" ${WRKSRC}/Makefile.rule
+ @${REINPLACE_CMD} -e "s+%%FC%%+${FC}+" -e "s+%%CC%%+${CC}+" ${WRKSRC}/Makefile.rule
do-build:
${MKDIR} ${WRKDIR}/lib
diff --git a/math/gotoblas/distinfo b/math/gotoblas/distinfo
index a87d2e2a3375..8e8a81cb91c9 100644
--- a/math/gotoblas/distinfo
+++ b/math/gotoblas/distinfo
@@ -1,3 +1,3 @@
-MD5 (GotoBLAS-1.23.tar.gz) = e0cf0763bea1f9e5dd1fdb70d165b7f8
-SHA256 (GotoBLAS-1.23.tar.gz) = 0d200b86f015260c7fb808dd274063e0b5cebf7184cea0204ec128f11ed67a55
-SIZE (GotoBLAS-1.23.tar.gz) = 2068412
+MD5 (GotoBLAS-1.26.tar.gz) = 35c6985deb9f69579dc09a1b71e3dbfc
+SHA256 (GotoBLAS-1.26.tar.gz) = 02fba0eef1c01da323edd609820dfac5d6485f99faca2045d2f93617ef6f86e9
+SIZE (GotoBLAS-1.26.tar.gz) = 2212072
diff --git a/math/gotoblas/files/patch-Makefile.rule b/math/gotoblas/files/patch-Makefile.rule
index 83797387653d..1ead9adf1199 100644
--- a/math/gotoblas/files/patch-Makefile.rule
+++ b/math/gotoblas/files/patch-Makefile.rule
@@ -1,6 +1,15 @@
---- Makefile.rule.orig 2008-01-31 01:03:08.000000000 +0900
-+++ Makefile.rule 2008-02-20 17:02:26.000000000 +0900
-@@ -169,12 +169,12 @@
+--- Makefile.rule.orig 2008-05-13 02:50:54.000000000 +0900
++++ Makefile.rule 2008-06-14 13:27:28.000000000 +0900
+@@ -114,7 +114,7 @@
+ MACHINE =
+ OSNAME =
+ PGCPATH =
+-ARCH =
++GARCH =
+ SUBARCH =
+ ARCHSUBDIR =
+ CONFIG =
+@@ -201,7 +201,7 @@
endif
ifndef F_COMPILER
@@ -9,96 +18,107 @@
I_DONT_HAVE_FC = 1
endif
+@@ -245,7 +245,7 @@
+ endif
+
ifeq ($(C_COMPILER), GNU)
-COMPILER = gcc
+COMPILER = %%CC%%
CCOMMON_OPT += -Wall
- ifneq ($(OSNAME), CYGWIN_NT)
+ ifeq ($(SUPPORTED_DYNLIB), YES)
CCOMMON_OPT += -fPIC
-@@ -190,12 +190,12 @@
+@@ -262,7 +262,7 @@
endif
ifeq ($(C_COMPILER), INTEL)
-COMPILER = icc
-+COMPILER = %%CC%%
++COMPILER = %%CC%%
+ ifeq ($(SUPPORTED_DYNLIB), YES)
CCOMMON_OPT += -fPIC
endif
+@@ -294,7 +294,7 @@
+ endif
ifeq ($(F_COMPILER), G77)
-COMPILER_F77 = g77
-+COMPILER_F77 = %%F77%%
++COMPILER_F77 = %%FC%%
BU = _
CCOMMON_OPT += -DF_INTERFACE_F2C -DNEED_F2CCONV
FCOMMON_OPT += -Wall
-@@ -212,7 +212,7 @@
+@@ -311,7 +311,7 @@
endif
ifeq ($(F_COMPILER), G95)
-COMPILER_F77 = g95
-+COMPILER_F77 = %%F77%%
++COMPILER_F77 = %%FC%%
BU = _
CCOMMON_OPT += -DF_INTERFACE_F2C
FCOMMON_OPT += -Wall # -fno-underscoring
-@@ -230,11 +230,12 @@
+@@ -328,10 +328,12 @@
endif
ifeq ($(F_COMPILER), GFORTRAN)
-COMPILER_F77 = gfortran
-+COMPILER_F77 = %%F77%%
++COMPILER_F77 = %%FC%%
BU = _
CCOMMON_OPT += -DF_INTERFACE_GFORT
FCOMMON_OPT += -Wall
--# EXTRALIB += -lgfortran
-+GCCPATH = $(shell dirname `%%F77%% -print-libgcc-file-name`)
++GCCPATH = $(shell dirname `%%FC%% -print-libgcc-file-name`)
+EXTRALIB += -L$(GCCPATH)/../../../ -lgfortran
- ifneq ($(OSNAME), CYGWIN_NT)
+ ifeq ($(SUPPORTED_DYNLIB), YES)
FCOMMON_OPT += -fPIC
endif
-@@ -252,7 +253,7 @@
+@@ -349,7 +351,7 @@
endif
ifeq ($(F_COMPILER), INTEL)
-COMPILER_F77 = ifort
-+COMPILER_F77 = %%F77%%
++COMPILER_F77 = %%FC%%
BU = _
CCOMMON_OPT += -DF_INTERFACE_F2C
- FCOMMON_OPT += -fPIC
-@@ -304,11 +305,9 @@
- endif
- endif
+ ifeq ($(SUPPORTED_DYNLIB), YES)
+@@ -404,7 +406,7 @@
--ifneq ($(OSNAME), CYGWIN_NT)
+ ifneq ($(OSNAME), CYGWIN_NT)
ifdef SMP
--PTHREADLIB += -lpthread
--FEXTRALIB += -lpthread
--endif
-+PTHREADLIB += ${PTHREAD_LIBS}
-+FEXTRALIB += ${PTHREAD_CFLAGS}
+-EXTRALIB += -lpthread
++EXTRALIB += ${PTHREAD_LIBS}
+ endif
endif
- ifeq ($(F_COMPILER), PATHSCALE)
-@@ -370,7 +369,7 @@
- GETARCH_CC = gcc
+@@ -477,8 +479,8 @@
+ GETARCH_SCRIPT = ./getarch
endif
--ARCH := $(shell (cd $(TOPDIR); ./getarch 0 $(GETARCH_CC) $(GETARCH_FLAGS)))
-+GARCH := $(shell (cd $(TOPDIR); ./getarch 0 $(GETARCH_CC) $(GETARCH_FLAGS)))
- SUBARCH := $(shell (cd $(TOPDIR); ./getarch 1 $(GETARCH_CC) $(GETARCH_FLAGS)))
- ARCHSUBDIR := $(shell (cd $(TOPDIR); ./getarch 2 $(GETARCH_CC) $(GETARCH_FLAGS)))
- CONFIG := $(shell (cd $(TOPDIR); ./getarch 3 $(GETARCH_CC) $(GETARCH_FLAGS)))
-@@ -459,11 +458,11 @@
- FPFLAGS = $(COMMON_OPT) $(FCOMMON_OPT) $(COMMON_PROF)
+-ifndef ARCH
+-ARCH := $(shell (cd $(TOPDIR); $(GETARCH_SCRIPT) 0 $(GETARCH_CC) $(GETARCH_FLAGS)))
++ifndef GARCH
++GARCH := $(shell (cd $(TOPDIR); $(GETARCH_SCRIPT) 0 $(GETARCH_CC) $(GETARCH_FLAGS)))
+ endif
+ ifndef SUBARCH
+ SUBARCH := $(shell (cd $(TOPDIR); $(GETARCH_SCRIPT) 1 $(GETARCH_CC) $(GETARCH_FLAGS)))
+@@ -613,11 +615,11 @@
+ endif
ifndef SMP
--LIBNAME = $(LIBPREFIX)_$(LIBSUBARCH)$(REVISION).a
--LIBNAME_P = $(LIBPREFIX)_$(LIBSUBARCH)$(REVISION)_p.a
+-LIBNAME = $(LIBPREFIX)_$(LIBSUBARCH)$(REVISION).$(LIBSUFFIX)
+-LIBNAME_P = $(LIBPREFIX)_$(LIBSUBARCH)$(REVISION)_p.$(LIBSUFFIX)
+LIBNAME = $(LIBPREFIX)$(REVISION).a
+LIBNAME_P = $(LIBPREFIX)$(REVISION)_p.a
else
--LIBNAME = $(LIBPREFIX)_$(LIBSUBARCH)p$(REVISION).a
--LIBNAME_P = $(LIBPREFIX)_$(LIBSUBARCH)p$(REVISION)_p.a
+-LIBNAME = $(LIBPREFIX)_$(LIBSUBARCH)p$(REVISION).$(LIBSUFFIX)
+-LIBNAME_P = $(LIBPREFIX)_$(LIBSUBARCH)p$(REVISION)_p.$(LIBSUFFIX)
+LIBNAME = $(LIBPREFIX)p$(REVISION).a
+LIBNAME_P = $(LIBPREFIX)p$(REVISION)_p.a
endif
- LIBSONAME = $(LIBNAME:.a=.so)
+ LIBSONAME = $(LIBNAME:.$(LIBSUFFIX)=.so)
+@@ -637,7 +639,7 @@
+ export MACHINE
+ export OSNAME
+ export PGCPATH
+-export ARCH
++export GARCH
+ export SUBARCH
+ export ARCHSUBDIR
+ export CONFIG
diff --git a/math/gotoblas/files/patch-getarch b/math/gotoblas/files/patch-getarch
index ad48c6cd8ec1..7b5cb9e0630f 100644
--- a/math/gotoblas/files/patch-getarch
+++ b/math/gotoblas/files/patch-getarch
@@ -1,8 +1,10 @@
---- getarch~ 2008-01-19 02:14:59.000000000 +0900
-+++ getarch 2008-02-20 17:14:45.000000000 +0900
-@@ -1,4 +1,4 @@
--#!/bin/bash
-+#!/bin/sh
+--- getarch.c~ 2008-05-12 23:44:31.000000000 +0900
++++ getarch.c 2008-06-14 13:20:54.000000000 +0900
+@@ -25,6 +25,7 @@
+ #include <windows.h>
+ #endif
+ #if defined(__FreeBSD__) || defined(__APPLE__)
++#include <sys/types.h>
+ #include <sys/sysctl.h>
+ #endif
- # if test getarch_cmd -ot getarch.c; then
- # rm -f getarch_cmd
diff --git a/math/gotoblas/files/patch-level1-asum-Makefile b/math/gotoblas/files/patch-level1-asum-Makefile
index 0d49760e85a6..90ad52656408 100644
--- a/math/gotoblas/files/patch-level1-asum-Makefile
+++ b/math/gotoblas/files/patch-level1-asum-Makefile
@@ -1,11 +1,11 @@
---- level1/asum/Makefile.orig Sun Jan 21 11:17:30 2007
-+++ level1/asum/Makefile Sun Jan 21 11:17:35 2007
+--- level1/asum/Makefile.orig 2008-03-22 03:55:49.000000000 +0900
++++ level1/asum/Makefile 2008-06-14 13:13:02.000000000 +0900
@@ -8,7 +8,7 @@
- ZOBJS = dzasumf.o
- XOBJS = qxasumf.o
+ ZOBJS = dzasumf.$(SUFFIX)
+ XOBJS = qxasumf.$(SUFFIX)
-ifeq ($(ARCH), X86)
+ifeq ($(GARCH), X86)
- SBLASOBJS = sasum.o
- DBLASOBJS = dasum.o
- QBLASOBJS = qasum.o
+ SBLASOBJS = sasum.$(SUFFIX)
+ DBLASOBJS = dasum.$(SUFFIX)
+ QBLASOBJS = qasum.$(SUFFIX)
diff --git a/math/gotoblas/files/patch-level1-others-Makefile b/math/gotoblas/files/patch-level1-others-Makefile
index a62dab2add4e..3af3d56a441f 100644
--- a/math/gotoblas/files/patch-level1-others-Makefile
+++ b/math/gotoblas/files/patch-level1-others-Makefile
@@ -1,20 +1,20 @@
---- level1/others/Makefile.orig Sun Jan 21 11:18:16 2007
-+++ level1/others/Makefile Sun Jan 21 11:18:30 2007
-@@ -16,7 +16,7 @@
+--- level1/others/Makefile.orig 2008-04-03 10:18:18.000000000 +0900
++++ level1/others/Makefile 2008-06-14 13:14:16.000000000 +0900
+@@ -23,7 +23,7 @@
- LIBOTHERS = libothers.a
+ LIBOTHERS = libothers.$(LIBSUFFIX)
-ifeq ($(ARCH), X86)
+ifeq ($(GARCH), X86)
- COMMONOBJS += cpuid.o
+ COMMONOBJS += cpuid.$(SUFFIX)
endif
-@@ -111,7 +111,7 @@
- staticbuffer.o staticbuffer.po : dummy
+@@ -133,7 +133,7 @@
cd $(ARCHSUBDIR) && $(MAKE) ../$(@F)
+ endif
-ifeq ($(ARCH), X86)
+ifeq ($(GARCH), X86)
- cpuid.o cpuid.po : dummy
+ cpuid.$(SUFFIX) cpuid.$(PSUFFIX) : dummy
cd $(ARCHSUBDIR) && $(MAKE) ../$(@F)
endif
diff --git a/math/gotoblas/files/patch-level3-Makefile b/math/gotoblas/files/patch-level3-Makefile
index 43fb5a8fb17b..843a40c1fff1 100644
--- a/math/gotoblas/files/patch-level3-Makefile
+++ b/math/gotoblas/files/patch-level3-Makefile
@@ -1,5 +1,5 @@
---- level3/Makefile.orig Sun Jan 21 11:19:32 2007
-+++ level3/Makefile Sun Jan 21 11:19:37 2007
+--- level3/Makefile.orig 2008-03-22 03:56:03.000000000 +0900
++++ level3/Makefile 2008-06-14 13:16:00.000000000 +0900
@@ -1,7 +1,7 @@
TOPDIR = ..
include ../Makefile.rule
@@ -9,3 +9,18 @@
TRSMDIR = oldtrsm
TRMMDIR = oldtrmm
endif
+@@ -20,12 +20,12 @@
+
+ ALLSUBDIRS = gemm trsm trmm symm syrk syr2k hemm herk her2k oldtrsm oldtrmm
+
+-ifeq ($(ARCH), X86_64)
++ifeq ($(GARCH), X86_64)
+ SUBDIRS += gemm3m symm3m hemm3m
+ ALLSUBDIRS += gemm3m symm3m hemm3m
+ endif
+
+-ifeq ($(ARCH), IA64)
++ifeq ($(GARCH), IA64)
+ SUBDIRS += gemm3m symm3m hemm3m
+ ALLSUBDIRS += gemm3m symm3m hemm3m
+ endif