aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2013-08-15 02:37:30 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2013-08-15 02:37:30 +0000
commit7af1895cd0e6b2c226f535ad46b7fd1006fcf93b (patch)
treef7165373d0e633d9743f4b1cafda8ddb60f03a9b /math
parent3fcbfb7f40b8d0043e71b34f6aa6d9c30ff430d3 (diff)
downloadports-7af1895cd0e6b2c226f535ad46b7fd1006fcf93b.tar.gz
ports-7af1895cd0e6b2c226f535ad46b7fd1006fcf93b.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/sage/Makefile3
-rw-r--r--math/sage/distinfo4
-rw-r--r--math/sage/files/spkg-patch-ppl_-_src_demos_ppl_lpsol_ppl_lpsol.c11
-rw-r--r--math/sage/files/spkg-patch-python_-_src_Doc_library_fcntl.rst2
-rw-r--r--math/sage/files/spkg-patch-python_-_src_Modules__ctypes_libffi_configure2
-rw-r--r--math/sage/files/spkg-patch-python_-_src_Modules_fcntlmodule.c2
-rw-r--r--math/sage/files/spkg-patch-python_-_src_Python_thread_pthread.h2
-rw-r--r--math/sage/files/spkg-patch-python_-_src_setup.py13
-rw-r--r--math/sage/files/spkg-patch-sage_-_doc_common_builder.py2
9 files changed, 21 insertions, 20 deletions
diff --git a/math/sage/Makefile b/math/sage/Makefile
index 23ce1b4ac4c9..ae72774afca2 100644
--- a/math/sage/Makefile
+++ b/math/sage/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= sage
-PORTVERSION= 5.10
-PORTREVISION= 1
+PORTVERSION= 5.11
CATEGORIES= math
MASTER_SITES= http://boxen.math.washington.edu/home/sagemath/sage-mirror/src/ \
http://mirrors.xmission.com/sage/src/ \
diff --git a/math/sage/distinfo b/math/sage/distinfo
index b48f24daf5eb..a7843f5d93ca 100644
--- a/math/sage/distinfo
+++ b/math/sage/distinfo
@@ -1,2 +1,2 @@
-SHA256 (sage-5.10.tar) = 6675f3a0bd04d54cf7699354814e3d9fc184397d4c18b331487c1ffbd16901ed
-SIZE (sage-5.10.tar) = 335462400
+SHA256 (sage-5.11.tar) = 2d03eb98075709b647ac9cc72bf5c7b52e4585e381b4015a3d21216c36814a12
+SIZE (sage-5.11.tar) = 339742720
diff --git a/math/sage/files/spkg-patch-ppl_-_src_demos_ppl_lpsol_ppl_lpsol.c b/math/sage/files/spkg-patch-ppl_-_src_demos_ppl_lpsol_ppl_lpsol.c
new file mode 100644
index 000000000000..6252b9924129
--- /dev/null
+++ b/math/sage/files/spkg-patch-ppl_-_src_demos_ppl_lpsol_ppl_lpsol.c
@@ -0,0 +1,11 @@
+--- ppl-1.0.p0/src/demos/ppl_lpsol/ppl_lpsol.c.orig 2013-06-20 17:21:39.000000000 +0000
++++ ppl-1.1pre9.p0/src/demos/ppl_lpsol/ppl_lpsol.c 2013-06-20 17:39:44.000000000 +0000
+@@ -534,7 +534,7 @@
+ if (getrlimit(RLIMIT_AS, &t) != 0)
+ fatal("getrlimit failed: %s", strerror(errno));
+
+- if (bytes < t.rlim_cur) {
++ if (bytes < (unsigned long)(t.rlim_cur)) {
+ t.rlim_cur = bytes;
+ if (setrlimit(RLIMIT_AS, &t) != 0)
+ fatal("setrlimit failed: %s", strerror(errno));
diff --git a/math/sage/files/spkg-patch-python_-_src_Doc_library_fcntl.rst b/math/sage/files/spkg-patch-python_-_src_Doc_library_fcntl.rst
index c009e2f5ed9d..e1b137fd7791 100644
--- a/math/sage/files/spkg-patch-python_-_src_Doc_library_fcntl.rst
+++ b/math/sage/files/spkg-patch-python_-_src_Doc_library_fcntl.rst
@@ -1,5 +1,5 @@
--- python-2.7.3.p0/src/Doc/library/fcntl.rst.orig 2011-06-11 15:46:23.000000000 +0000
-+++ python-2.7.4.p0/src/Doc/library/fcntl.rst 2012-04-22 00:31:48.000000000 +0000
++++ python-2.7.5.p1/src/Doc/library/fcntl.rst 2012-04-22 00:31:48.000000000 +0000
@@ -50,8 +50,6 @@
operations are typically defined in the library module :mod:`termios` and the
argument handling is even more complicated.
diff --git a/math/sage/files/spkg-patch-python_-_src_Modules__ctypes_libffi_configure b/math/sage/files/spkg-patch-python_-_src_Modules__ctypes_libffi_configure
index b833bd05ab79..aa6297bcb94d 100644
--- a/math/sage/files/spkg-patch-python_-_src_Modules__ctypes_libffi_configure
+++ b/math/sage/files/spkg-patch-python_-_src_Modules__ctypes_libffi_configure
@@ -1,5 +1,5 @@
--- python-2.7.3.p0/src/Modules/_ctypes/libffi/configure.orig 2011-06-11 15:46:26.000000000 +0000
-+++ python-2.7.4.p0/src/Modules/_ctypes/libffi/configure 2012-04-22 00:23:14.000000000 +0000
++++ python-2.7.5.p1/src/Modules/_ctypes/libffi/configure 2012-04-22 00:23:14.000000000 +0000
@@ -6289,7 +6289,7 @@
rm -rf conftest*
;;
diff --git a/math/sage/files/spkg-patch-python_-_src_Modules_fcntlmodule.c b/math/sage/files/spkg-patch-python_-_src_Modules_fcntlmodule.c
index 243028f0ad28..0899c8c93ac4 100644
--- a/math/sage/files/spkg-patch-python_-_src_Modules_fcntlmodule.c
+++ b/math/sage/files/spkg-patch-python_-_src_Modules_fcntlmodule.c
@@ -1,5 +1,5 @@
--- python-2.7.3.p0/src/Modules/fcntlmodule.c.orig 2011-06-11 15:46:27.000000000 +0000
-+++ python-2.7.4.p0/src/Modules/fcntlmodule.c 2012-04-22 00:23:34.000000000 +0000
++++ python-2.7.5.p1/src/Modules/fcntlmodule.c 2012-04-22 00:23:34.000000000 +0000
@@ -97,20 +97,15 @@
{
#define IOCTL_BUFSZ 1024
diff --git a/math/sage/files/spkg-patch-python_-_src_Python_thread_pthread.h b/math/sage/files/spkg-patch-python_-_src_Python_thread_pthread.h
index 368b69ad494c..944232c92871 100644
--- a/math/sage/files/spkg-patch-python_-_src_Python_thread_pthread.h
+++ b/math/sage/files/spkg-patch-python_-_src_Python_thread_pthread.h
@@ -1,5 +1,5 @@
--- python-2.7.3.p0/src/Python/thread_pthread.h.orig 2011-06-11 15:46:28.000000000 +0000
-+++ python-2.7.4.p0/src/Python/thread_pthread.h 2012-04-22 00:23:46.000000000 +0000
++++ python-2.7.5.p1/src/Python/thread_pthread.h 2012-04-22 00:23:46.000000000 +0000
@@ -38,13 +38,18 @@
#endif
#endif
diff --git a/math/sage/files/spkg-patch-python_-_src_setup.py b/math/sage/files/spkg-patch-python_-_src_setup.py
index 5c547c8b52f9..f776ec7f5c2c 100644
--- a/math/sage/files/spkg-patch-python_-_src_setup.py
+++ b/math/sage/files/spkg-patch-python_-_src_setup.py
@@ -1,5 +1,5 @@
---- python-2.7.4.p0/src/setup.py-orig 2013-03-17 03:13:46.000000000 +0000
-+++ python-2.7.4.p0/src/setup.py 2013-03-17 03:15:11.000000000 +0000
+--- python-2.7.5.p1/src/setup.py-orig 2013-03-17 03:13:46.000000000 +0000
++++ python-2.7.5.p1/src/setup.py 2013-03-17 03:15:11.000000000 +0000
@@ -642,7 +642,7 @@
# use the same library for the readline and curses modules.
if 'curses' in readline_termcap_library:
@@ -18,15 +18,6 @@
extra_link_args=readline_extra_link_args,
libraries=readline_libs) )
else:
-@@ -783,6 +783,8 @@
- # OpenSSL doesn't do these until 0.9.8 so we'll bring our own hash
- exts.append( Extension('_sha256', ['sha256module.c']) )
- exts.append( Extension('_sha512', ['sha512module.c']) )
-+ else:
-+ open('.without_own_sha', 'w')
-
- # Modules that provide persistent dictionary-like semantics. You will
- # probably want to arrange for at least one of them to be available on
@@ -1120,7 +1122,7 @@
sysroot = macosx_sdk_root()
f = os.path.join(sysroot, f[1:])
diff --git a/math/sage/files/spkg-patch-sage_-_doc_common_builder.py b/math/sage/files/spkg-patch-sage_-_doc_common_builder.py
index 8c2b64b0b0e7..a470e3ac94d4 100644
--- a/math/sage/files/spkg-patch-sage_-_doc_common_builder.py
+++ b/math/sage/files/spkg-patch-sage_-_doc_common_builder.py
@@ -1,5 +1,5 @@
--- sage-5.8.rc0/doc/common/builder.py-orig 2013-03-17 20:50:38.000000000 +0000
-+++ sage-5.10/doc/common/builder.py 2013-03-17 20:56:42.000000000 +0000
++++ sage-5.11/doc/common/builder.py 2013-03-17 20:56:42.000000000 +0000
@@ -272,13 +272,16 @@
# build the other documents in parallel