aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2011-12-26 21:32:20 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2011-12-26 21:32:20 +0000
commit805910ebe3b4660b2264681ee4529530da0bcc71 (patch)
tree3aeb89c9442699fd0cb457c71d3fd37e4ab015b5 /math
parent6c2d6146d6dd9e3d3e667a89ab95c8defcc480c4 (diff)
downloadports-805910ebe3b4660b2264681ee4529530da0bcc71.tar.gz
ports-805910ebe3b4660b2264681ee4529530da0bcc71.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/octave-forge-dicom/Makefile32
-rw-r--r--math/octave-forge-dicom/distinfo2
-rw-r--r--math/octave-forge-dicom/pkg-descr12
-rw-r--r--math/octave-forge-dicom/pkg-plist1
5 files changed, 48 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 4be191586eef..3027b77b7683 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -249,6 +249,7 @@
SUBDIR += octave-forge-control
SUBDIR += octave-forge-data-smoothing
SUBDIR += octave-forge-dataframe
+ SUBDIR += octave-forge-dicom
SUBDIR += octave-forge-econometrics
SUBDIR += octave-forge-engine
SUBDIR += octave-forge-es
diff --git a/math/octave-forge-dicom/Makefile b/math/octave-forge-dicom/Makefile
new file mode 100644
index 000000000000..4f338f55543e
--- /dev/null
+++ b/math/octave-forge-dicom/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: octave-forge-dicom
+# Date created: 20 December 2011
+# Whom: Stephen Montgomery-Smith <stephen@math.missouri.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= octave-forge-dicom
+PORTVERSION= 0.1.1
+CATEGORIES= math
+
+MAINTAINER= stephen@FreeBSD.org
+COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
+
+#LIB_DEPENDS+= gdcmCommon:${PORTSDIR}/devel/gdcm
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libgdcmCommon.so:${PORTSDIR}/devel/gdcm
+RUN_DEPENDS+= ${LOCALBASE}/lib/libgdcmCommon.so:${PORTSDIR}/devel/gdcm
+
+# OCTSRC is the name of the directory of the package.
+# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
+OCTSRC= ${OCTAVE_PKGNAME}
+
+WRKSRC= ${WRKDIR}/${OCTSRC}/src
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/Mk/bsd.octave.mk"
+
+post-build:
+ ${RM} -f ${WRKSRC}/Makefile ${WRKSRC}/configure
+ cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
+
+.include <bsd.port.post.mk>
diff --git a/math/octave-forge-dicom/distinfo b/math/octave-forge-dicom/distinfo
new file mode 100644
index 000000000000..8f262fc495a5
--- /dev/null
+++ b/math/octave-forge-dicom/distinfo
@@ -0,0 +1,2 @@
+SHA256 (octave-forge/dicom-0.1.1.tar.gz) = 692cc509c70e85d94598866190366d0dbc2968bee56fbb998eac940bea62e8fa
+SIZE (octave-forge/dicom-0.1.1.tar.gz) = 91427
diff --git a/math/octave-forge-dicom/pkg-descr b/math/octave-forge-dicom/pkg-descr
new file mode 100644
index 000000000000..88cdc53964a9
--- /dev/null
+++ b/math/octave-forge-dicom/pkg-descr
@@ -0,0 +1,12 @@
+The octave-forge package is the result of The GNU Octave Repositry project,
+which is intended to be a central location for custom scripts, functions and
+extensions for GNU Octave. contains the source for all the functions plus
+build and install scripts.
+
+This is dicom.
+
+ Digital communications in medicine (DICOM) file io. Depends on Grassroots
+ DICOM (GDCM). This package is not available in repos for all distros.
+ Contributors: Judd Storrs, Kris Thielemans.
+
+WWW: http://octave.sourceforge.net/
diff --git a/math/octave-forge-dicom/pkg-plist b/math/octave-forge-dicom/pkg-plist
new file mode 100644
index 000000000000..a999ec86c07e
--- /dev/null
+++ b/math/octave-forge-dicom/pkg-plist
@@ -0,0 +1 @@
+@comment This file intentionally left empty