aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2018-05-11 11:05:10 +0000
committerKurt Jaeger <pi@FreeBSD.org>2018-05-11 11:05:10 +0000
commit828377ea61aab7a236b9fe6c2787d69d4c374179 (patch)
treec2ea9e0edabbfdd6b0f4cddeb426e1b9356a8dff /math
parent46d248413984827f6112e94e28e30fd2c8db7d20 (diff)
downloadports-828377ea61aab7a236b9fe6c2787d69d4c374179.tar.gz
ports-828377ea61aab7a236b9fe6c2787d69d4c374179.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/p5-Math-ProvablePrime/Makefile25
-rw-r--r--math/p5-Math-ProvablePrime/distinfo3
-rw-r--r--math/p5-Math-ProvablePrime/pkg-descr4
4 files changed, 33 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 47bb2cc565ce..cbaf63589883 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -535,6 +535,7 @@
SUBDIR += p5-Math-Polygon-Tree
SUBDIR += p5-Math-Polynomial-Solve
SUBDIR += p5-Math-Prime-XS
+ SUBDIR += p5-Math-ProvablePrime
SUBDIR += p5-Math-RPN
SUBDIR += p5-Math-Random
SUBDIR += p5-Math-Random-ISAAC
diff --git a/math/p5-Math-ProvablePrime/Makefile b/math/p5-Math-ProvablePrime/Makefile
new file mode 100644
index 000000000000..67b4523bc888
--- /dev/null
+++ b/math/p5-Math-ProvablePrime/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= Math-ProvablePrime
+PORTVERSION= 0.043
+CATEGORIES= math perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= pi@FreeBSD.org
+COMMENT= Generate a provable prime number, in pure Perl
+
+LICENSE= ART10 GPLv1+
+LICENSE_COMB= dual
+
+USES= perl5
+USE_PERL5= configure
+
+PLIST_FILES= ${SITE_PERL_REL}/Math/ProvablePrime.pm \
+ ${SITE_PERL_REL}/Math/ProvablePrime/Rand.pm \
+ ${SITE_MAN3_REL}/Math::ProvablePrime.3.gz
+
+pre-install:
+ ${RM} ${WRKSRC}/blib/lib/Math/README.pod
+
+.include <bsd.port.mk>
diff --git a/math/p5-Math-ProvablePrime/distinfo b/math/p5-Math-ProvablePrime/distinfo
new file mode 100644
index 000000000000..f7351993263c
--- /dev/null
+++ b/math/p5-Math-ProvablePrime/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1526036417
+SHA256 (Math-ProvablePrime-0.043.tar.gz) = 7c170e0278b3ed08846e37ac34d6d560c41f8eaa0e10865e630322e25cb91884
+SIZE (Math-ProvablePrime-0.043.tar.gz) = 25121
diff --git a/math/p5-Math-ProvablePrime/pkg-descr b/math/p5-Math-ProvablePrime/pkg-descr
new file mode 100644
index 000000000000..3dd9d313ad54
--- /dev/null
+++ b/math/p5-Math-ProvablePrime/pkg-descr
@@ -0,0 +1,4 @@
+This module returns a prime number of a specified bit length, using
+Maurers algorithm.
+
+WWW: http://search.cpan.org/dist/Math-ProvablePrime/