aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorAlex Kozlov <ak@FreeBSD.org>2013-04-26 10:44:28 +0000
committerAlex Kozlov <ak@FreeBSD.org>2013-04-26 10:44:28 +0000
commit83f02b963c2b22c85235bf19b4f10a20bea921b5 (patch)
treee5e83d3ba0442c1c2f0b99c843428b36a8eb003d /math
parent152f30ef73f9cf1c87d1eb78186693682bed0c43 (diff)
downloadports-83f02b963c2b22c85235bf19b4f10a20bea921b5.tar.gz
ports-83f02b963c2b22c85235bf19b4f10a20bea921b5.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/gnumeric/Makefile3
-rw-r--r--math/gretl/Makefile2
-rw-r--r--math/libqalculate/Makefile2
-rw-r--r--math/oleo/Makefile2
-rw-r--r--math/rkward-kde4/Makefile3
5 files changed, 5 insertions, 7 deletions
diff --git a/math/gnumeric/Makefile b/math/gnumeric/Makefile
index c207b06c8543..16309f855a66 100644
--- a/math/gnumeric/Makefile
+++ b/math/gnumeric/Makefile
@@ -22,9 +22,8 @@ LIB_DEPENDS= goffice-0.8:${PORTSDIR}/devel/goffice \
RUN_DEPENDS= rarian-sk-config:${PORTSDIR}/textproc/rarian
USE_XZ= yes
-USE_GETTEXT= yes
USE_GMAKE= yes
-USES= pathfix
+USES= pathfix gettext
USE_GNOME= gnomeprefix intlhack gnomehier pygtk2 \
desktopfileutils libgsf
USE_PYTHON= yes
diff --git a/math/gretl/Makefile b/math/gretl/Makefile
index db9c0a23a441..6dcf86cbbb34 100644
--- a/math/gretl/Makefile
+++ b/math/gretl/Makefile
@@ -67,7 +67,7 @@ PLIST_SUB+= GUI="@comment "
.if ${PORT_OPTIONS:MNLS}
CONFIGURE_ARGS+= --enable-nls=yes
-USE_GETTEXT= yes
+USES+= gettext
PLIST_SUB+= NLS=""
.else
CONFIGURE_ARGS+= --enable-nls=no
diff --git a/math/libqalculate/Makefile b/math/libqalculate/Makefile
index 16b58cd0033a..c33ddd39f78d 100644
--- a/math/libqalculate/Makefile
+++ b/math/libqalculate/Makefile
@@ -21,7 +21,7 @@ USE_LDCONFIG= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
+USES+= gettext
PLIST_SUB+= NLS=""
.else
CONFIGURE_ARGS+= --disable-nls
diff --git a/math/oleo/Makefile b/math/oleo/Makefile
index e8320576e310..b404e286f9a8 100644
--- a/math/oleo/Makefile
+++ b/math/oleo/Makefile
@@ -37,7 +37,7 @@ CONFIGURE_ARGS+= --without-motif
.endif
.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
+USES+= gettext
PLIST_SUB= NLS=""
.else
CONFIGURE_ARGS+= --disable-nls
diff --git a/math/rkward-kde4/Makefile b/math/rkward-kde4/Makefile
index ec35bf158e9d..2d9a2db763f9 100644
--- a/math/rkward-kde4/Makefile
+++ b/math/rkward-kde4/Makefile
@@ -23,8 +23,7 @@ USE_QT4= qmake_build moc_build rcc_build uic_build phonon
USE_KDE4= kdehier kdeprefix automoc4 kdelibs
USE_PHP= yes
WANT_PHP_CLI= yes
-USE_GETTEXT= yes
-USES= cmake
+USES= cmake gettext
INSTALLS_ICONS= yes
CFLAGS+= -I${LOCALBASE}/include