aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2021-03-22 16:36:31 +0000
committerThierry Thomas <thierry@FreeBSD.org>2021-03-22 16:36:31 +0000
commit87ccdfac2cdba62c4e50b68fa0fa66c8dfa589a1 (patch)
tree554cfdd42281e38ee6423b1410a02bc6d6b7128c /math
parent1c6cd4e14c1cffd07c2a2cb82e98c8a0a3d08ed1 (diff)
downloadports-87ccdfac2cdba62c4e50b68fa0fa66c8dfa589a1.tar.gz
ports-87ccdfac2cdba62c4e50b68fa0fa66c8dfa589a1.zip
Upgrade to 2.1.2b1.
Notes
Notes: svn path=/head/; revision=568972
Diffstat (limited to 'math')
-rw-r--r--math/py-cypari2/Makefile5
-rw-r--r--math/py-cypari2/distinfo6
-rw-r--r--math/py-cypari2/files/patch-cypari2_gen.pyx11
-rw-r--r--math/py-cypari2/files/patch-cypari2_paridecl.pxd11
-rw-r--r--math/py-cypari2/pkg-plist5
5 files changed, 11 insertions, 27 deletions
diff --git a/math/py-cypari2/Makefile b/math/py-cypari2/Makefile
index fe733e421065..74094b81cc6e 100644
--- a/math/py-cypari2/Makefile
+++ b/math/py-cypari2/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= cypari2
-DISTVERSION= 2.1.1
-PORTREVISION= 2
+DISTVERSION= 2.1.2b1
CATEGORIES= math python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -29,6 +28,8 @@ DOCS_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>=0,1:textproc/py-sphinx@${PY_F
DOCS_USES= gmake
PORTDOCS= *
+PLIST_SUB+= VER=${DISTVERSION}
+
pre-configure-DOCS-on:
${REINPLACE_CMD} -e 's|python -m|${PYTHON_CMD} -m|' \
${WRKSRC}/docs/Makefile
diff --git a/math/py-cypari2/distinfo b/math/py-cypari2/distinfo
index b25a6b77a933..01f97a75b205 100644
--- a/math/py-cypari2/distinfo
+++ b/math/py-cypari2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1589574266
-SHA256 (sagemath-cypari2-2.1.1_GH0.tar.gz) = 8b707cba6f5ed249105348d3e29ce55c12c7ed5556ff6e0ae03f7aa792321e10
-SIZE (sagemath-cypari2-2.1.1_GH0.tar.gz) = 123990
+TIMESTAMP = 1616425865
+SHA256 (sagemath-cypari2-2.1.2b1_GH0.tar.gz) = 8c58cb3c6a8e51e8f1319619761df747ae56823b159c3d326d2b11b0ca5598cd
+SIZE (sagemath-cypari2-2.1.2b1_GH0.tar.gz) = 125863
diff --git a/math/py-cypari2/files/patch-cypari2_gen.pyx b/math/py-cypari2/files/patch-cypari2_gen.pyx
deleted file mode 100644
index 484e5a5f0d26..000000000000
--- a/math/py-cypari2/files/patch-cypari2_gen.pyx
+++ /dev/null
@@ -1,11 +0,0 @@
---- cypari2/gen.pyx.orig 2019-04-23 10:57:51 UTC
-+++ cypari2/gen.pyx
-@@ -4109,7 +4109,7 @@ cdef class Gen(Gen_base):
- non-constant polynomial, or False if f is reducible or constant.
- """
- sig_on()
-- t = isirreducible(self.g)
-+ t = polisirreducible(self.g)
- clear_stack()
- return t != 0
-
diff --git a/math/py-cypari2/files/patch-cypari2_paridecl.pxd b/math/py-cypari2/files/patch-cypari2_paridecl.pxd
deleted file mode 100644
index c01ae1f8a0ac..000000000000
--- a/math/py-cypari2/files/patch-cypari2_paridecl.pxd
+++ /dev/null
@@ -1,11 +0,0 @@
---- cypari2/paridecl.pxd.orig 2019-04-23 10:57:51 UTC
-+++ cypari2/paridecl.pxd
-@@ -3850,7 +3850,7 @@ cdef extern from *: # PARI headers already include
- GEN glcm0(GEN x, GEN y)
- GEN gp_factor0(GEN x, GEN flag)
- GEN idealfactorback(GEN nf, GEN L, GEN e, int red)
-- long isirreducible(GEN x)
-+ long polisirreducible "isirreducible"(GEN x)
- GEN newtonpoly(GEN x, GEN p)
- GEN nffactorback(GEN nf, GEN L, GEN e)
- GEN nfrootsQ(GEN x)
diff --git a/math/py-cypari2/pkg-plist b/math/py-cypari2/pkg-plist
index 5105b3786ad1..47e4f3e7de64 100644
--- a/math/py-cypari2/pkg-plist
+++ b/math/py-cypari2/pkg-plist
@@ -1,3 +1,8 @@
+%%PYTHON_SITELIBDIR%%/cypari2-%%VER%%-py%%PYTHON_VER%%.egg-info/PKG-INFO
+%%PYTHON_SITELIBDIR%%/cypari2-%%VER%%-py%%PYTHON_VER%%.egg-info/SOURCES.txt
+%%PYTHON_SITELIBDIR%%/cypari2-%%VER%%-py%%PYTHON_VER%%.egg-info/dependency_links.txt
+%%PYTHON_SITELIBDIR%%/cypari2-%%VER%%-py%%PYTHON_VER%%.egg-info/requires.txt
+%%PYTHON_SITELIBDIR%%/cypari2-%%VER%%-py%%PYTHON_VER%%.egg-info/top_level.txt
%%PYTHON_SITELIBDIR%%/cypari2/__init__.py
%%PYTHON_SITELIBDIR%%/cypari2/__pycache__/__init__.cpython-%%PYTHON_SUFFIX%%.opt-1.pyc
%%PYTHON_SITELIBDIR%%/cypari2/__pycache__/__init__.cpython-%%PYTHON_SUFFIX%%.pyc