aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2018-11-02 13:32:34 +0000
committerRene Ladan <rene@FreeBSD.org>2018-11-02 13:32:34 +0000
commit8a502cb2d43b4059a5678ee4539ca03603104107 (patch)
tree2c2c3d0def8d9d1ad349013f7b532f0065f57789 /math
parentf60d4bacdc58ec061406d72cace1ac1266952e39 (diff)
downloadports-8a502cb2d43b4059a5678ee4539ca03603104107.tar.gz
ports-8a502cb2d43b4059a5678ee4539ca03603104107.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/R/Makefile1
-rw-r--r--math/adept/Makefile2
-rw-r--r--math/ambit/Makefile12
-rw-r--r--math/eprover/Makefile12
-rw-r--r--math/libRmath/Makefile1
-rw-r--r--math/libpgmath/Makefile1
-rw-r--r--math/maxima/Makefile6
-rw-r--r--math/mkl-dnn/Makefile1
-rw-r--r--math/opensolaris-libm/Makefile5
-rw-r--r--math/sleef/Makefile2
10 files changed, 2 insertions, 41 deletions
diff --git a/math/R/Makefile b/math/R/Makefile
index e207a0fc1c76..1b481adf2e8a 100644
--- a/math/R/Makefile
+++ b/math/R/Makefile
@@ -12,7 +12,6 @@ COMMENT= Language for statistical computing and graphics
LICENSE= GPLv2
-BROKEN_FreeBSD_10_armv6= Fails to build
ONLY_FOR_ARCHS= aarch64 amd64 armv6 armv7 i386
LIB_DEPENDS= libcurl.so:ftp/curl \
diff --git a/math/adept/Makefile b/math/adept/Makefile
index 9397a8d3d248..977b25945929 100644
--- a/math/adept/Makefile
+++ b/math/adept/Makefile
@@ -12,8 +12,6 @@ COMMENT= Combined array and automatic differentiation library in C++
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN_FreeBSD_10_amd64= error: use of undeclared identifier '_mm_undefined_ps'
-
USES= autoreconf gmake fortran blaslapack:openblas libtool
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-static
diff --git a/math/ambit/Makefile b/math/ambit/Makefile
index 4b59a848d2eb..38e2556f00ed 100644
--- a/math/ambit/Makefile
+++ b/math/ambit/Makefile
@@ -27,14 +27,4 @@ CMAKE_ARGS+= -DSHARED_ONLY:BOOL=ON
CMAKE_ARGS+= -DENABLE_OPENMP:BOOL=ON # bug#223678: find_package(OpenMP) doesn't find the openmp package
CMAKE_ARGS+= -DENABLE_TESTS:BOOL=OFF # https://github.com/jturney/ambit/issues/24
-.include <bsd.port.pre.mk>
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1100000
-# It requires clang version >3.6
-BUILD_DEPENDS+= clang60:devel/llvm60
-RUN_DEPENDS+= clang60:devel/llvm60
-CC= clang60
-CXX= clang++60
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/eprover/Makefile b/math/eprover/Makefile
index dc063ab9a05e..f76f5d8131b8 100644
--- a/math/eprover/Makefile
+++ b/math/eprover/Makefile
@@ -36,14 +36,4 @@ post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${f}
.endfor
-.include <bsd.port.pre.mk>
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1100000
-# the default compiler hangs on 10
-BUILD_DEPENDS+= clang60:devel/llvm60
-RUN_DEPENDS+= clang60:devel/llvm60
-CC= clang60
-CXX= clang++60
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/libRmath/Makefile b/math/libRmath/Makefile
index e83c2caf8838..d13ef1738544 100644
--- a/math/libRmath/Makefile
+++ b/math/libRmath/Makefile
@@ -13,7 +13,6 @@ COMMENT= Standalone math library from R
LICENSE= GPLv2
-BROKEN_FreeBSD_10_armv6= Fails to build
ONLY_FOR_ARCHS= aarch64 amd64 armv6 armv7 i386
LIB_DEPENDS= libcurl.so:ftp/curl \
diff --git a/math/libpgmath/Makefile b/math/libpgmath/Makefile
index 173f06fbd6fe..977395637522 100644
--- a/math/libpgmath/Makefile
+++ b/math/libpgmath/Makefile
@@ -12,7 +12,6 @@ LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
ONLY_FOR_ARCHS= amd64
-IGNORE_FreeBSD_10= not supported on older than 12.0, no cpuid bit support
IGNORE_FreeBSD_11= not supported on older than 12.0, no cpuid bit support
BUILD_DEPENDS= llvm60>=0:devel/llvm60
diff --git a/math/maxima/Makefile b/math/maxima/Makefile
index 0c6d8151c077..13e2c7158553 100644
--- a/math/maxima/Makefile
+++ b/math/maxima/Makefile
@@ -76,12 +76,6 @@ PLIST_SUB+= LISPBINARY="@comment "
MAXIMABINARY= maxima_core
.endif
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1100000
-# The older makeinfo from the base fails in 10.3
-BUILD_DEPENDS+= ${LOCALBASE}/bin/makeinfo:print/texinfo
-CONFIGURE_ENV+= MAKEINFO="${LOCALBASE}/bin/makeinfo"
-.endif
-
post-patch:
@${GREP} -Fe '.core' -l -r ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} \
-e 's;\.core;_core;g'
diff --git a/math/mkl-dnn/Makefile b/math/mkl-dnn/Makefile
index c8cb3e6d1987..ec9de701e61f 100644
--- a/math/mkl-dnn/Makefile
+++ b/math/mkl-dnn/Makefile
@@ -11,7 +11,6 @@ COMMENT= Intel(R) Math Kernel Library for Deep Neural Networks
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN_FreeBSD_10= invalid value 'internal' in '-fvisibility internal'
BROKEN_i386= error: shift count >= width of type (and other errors), see https://github.com/intel/mkl-dnn/issues/315
TEST_DEPENDS= bash:shells/bash
diff --git a/math/opensolaris-libm/Makefile b/math/opensolaris-libm/Makefile
index ea0ec2126985..7749ced82dfc 100644
--- a/math/opensolaris-libm/Makefile
+++ b/math/opensolaris-libm/Makefile
@@ -34,7 +34,6 @@ MAKE_ENV= ARCH=${ARCH} USE_ASSEMBLY_VERSIONS=yes
# proper functioning.
OPTIONS_DEFINE= GCC
-OPTIONS_EXCLUDE_FreeBSD_10= GCC
OPTIONS_EXCLUDE_DragonFly= GCC
GCC_USE= GCC=yes
@@ -42,10 +41,6 @@ GCC_USE= GCC=yes
.include <bsd.port.options.mk>
.if ${OPSYS} == FreeBSD
-. if ${OSREL:R} < 11
-USE_GCC= yes
-. endif
-
RUN_DEPENDS= ${LOCALBASE}/bin/addr2line:devel/binutils
post-patch:
diff --git a/math/sleef/Makefile b/math/sleef/Makefile
index a29a55b0a43f..c51c8d49e5d7 100644
--- a/math/sleef/Makefile
+++ b/math/sleef/Makefile
@@ -12,8 +12,6 @@ COMMENT= SIMD Library for Evaluating Elementary Functions, vectorized libm
LICENSE= BSL
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-IGNORE_FreeBSD_10= base compiler too old
-
USES= cmake:outsource compiler:c11
USE_LDCONFIG= yes