aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2021-07-18 15:37:07 +0000
committerThierry Thomas <thierry@FreeBSD.org>2021-07-18 15:40:50 +0000
commit8af3d45c8b1fbc2ace55eccd74b93defffce5b1a (patch)
tree1674b42739b9636d56e726ae45657a95e7aabbfe /math
parent905dfe641b7045ca5b92dab3f11acda51d380134 (diff)
downloadports-8af3d45c8b1fbc2ace55eccd74b93defffce5b1a.tar.gz
ports-8af3d45c8b1fbc2ace55eccd74b93defffce5b1a.zip
math/lapack: fix broken lib symlink
In lapack-3.10.0, there is a broken sym link for libtmglib.so.3.10.0 (should be a file): /usr/local/lib/libtmglib.so.3@ -> libtmglib.so.3.10.0 /usr/local/lib/libtmglib.so.3.10.0@ -> libtmglib.so.3 Just remove the unnecessary code in post-install for libtmglib shared lib files. 'do-install' does everything correctly. PR: 257139 Reported by: John Hein <jcfyecrayz (at) liamekaens.com>
Diffstat (limited to 'math')
-rw-r--r--math/lapack/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/math/lapack/Makefile b/math/lapack/Makefile
index 66774d40d1fe..73253ef2c45a 100644
--- a/math/lapack/Makefile
+++ b/math/lapack/Makefile
@@ -2,7 +2,11 @@
PORTNAME?= lapack
PORTVERSION= 3.10.0
+.if !(defined(BLAS_SLAVEPORT) || defined(CBLAS_SLAVEPORT) || defined(XLAPACK_SLAVEPORT) || defined(LAPACKE_SLAVEPORT))
+PORTREVISION= 1
+.else
PORTREVISION?= 0 # Never remove this line, keep PORTREVISION?=0 in case.
+.endif
CATEGORIES= math
MASTER_SITES= https://github.com/Reference-LAPACK/lapack/archive/refs/tags/:src \
http://www.netlib.org/lapack/:man \
@@ -164,10 +168,6 @@ post-install:
.else # Lapack
${INSTALL_DATA} ${BUILD_WRKSRC}/SRC/liblapack.a ${STAGEDIR}${PREFIX}/lib
${INSTALL_DATA} ${BUILD_WRKSRC}/TESTING/MATGEN/libtmglib.a ${STAGEDIR}${PREFIX}/lib
- ${MV} ${STAGEDIR}${PREFIX}/lib/libtmglib.so \
- ${STAGEDIR}${PREFIX}/lib/libtmglib.so.${PORTVERSION}
- ${LN} -sf libtmglib.so.${PORTVERSION} ${STAGEDIR}${PREFIX}/lib/libtmglib.so
- ${LN} -sf libtmglib.so.${PORTVERSION} ${STAGEDIR}${PREFIX}/lib/libtmglib.so.${SVERSION}
.endif
.include <bsd.port.post.mk>