aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2004-07-11 21:53:10 +0000
committerLars Thegler <lth@FreeBSD.org>2004-07-11 21:53:10 +0000
commit939f964014a752594876d327fe604f8ff75a3201 (patch)
treee747572f7fd452a568ea88d83a0cc448ace5e6e2 /math
parent99a34eb395d0bedb08bb84647b590b3f6ad59bf3 (diff)
downloadports-939f964014a752594876d327fe604f8ff75a3201.tar.gz
ports-939f964014a752594876d327fe604f8ff75a3201.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/p5-Geo-Distance/Makefile22
-rw-r--r--math/p5-Geo-Distance/distinfo2
-rw-r--r--math/p5-Geo-Distance/files/patch-Distance.pm51
-rw-r--r--math/p5-Geo-Distance/pkg-descr7
-rw-r--r--math/p5-Geo-Distance/pkg-plist5
6 files changed, 88 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index c66529610f4d..a60e7380de77 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -121,6 +121,7 @@
SUBDIR += p5-Bit-Vector
SUBDIR += p5-Chart-Math-Axis
SUBDIR += p5-Date-Handler
+ SUBDIR += p5-Geo-Distance
SUBDIR += p5-Graph
SUBDIR += p5-Math-Base85
SUBDIR += p5-Math-BaseCalc
diff --git a/math/p5-Geo-Distance/Makefile b/math/p5-Geo-Distance/Makefile
new file mode 100644
index 000000000000..6d0e7b397db2
--- /dev/null
+++ b/math/p5-Geo-Distance/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-Geo-Distance
+# Date created: 10 July 2004
+# Whom: Rod Taylor <ports@rbt.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Geo-Distance
+PORTVERSION= 0.06
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Geo
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@rbt.ca
+COMMENT= Calculate Distances and Closest Locations
+
+PERL_CONFIGURE= yes
+
+MAN3= Geo::Distance.3
+
+.include <bsd.port.mk>
diff --git a/math/p5-Geo-Distance/distinfo b/math/p5-Geo-Distance/distinfo
new file mode 100644
index 000000000000..0d76e4b34a38
--- /dev/null
+++ b/math/p5-Geo-Distance/distinfo
@@ -0,0 +1,2 @@
+MD5 (Geo-Distance-0.06.tar.gz) = 6313eb1cdabca80d494d213db1aa94c0
+SIZE (Geo-Distance-0.06.tar.gz) = 9234
diff --git a/math/p5-Geo-Distance/files/patch-Distance.pm b/math/p5-Geo-Distance/files/patch-Distance.pm
new file mode 100644
index 000000000000..e11afe5042f1
--- /dev/null
+++ b/math/p5-Geo-Distance/files/patch-Distance.pm
@@ -0,0 +1,51 @@
+--- ../../../Geo-Distance-0.06/Distance.pm Wed Jun 30 02:12:10 2004
++++ Distance.pm Sun Jul 11 21:46:44 2004
+@@ -1,21 +1,20 @@
+ package Geo::Distance;
+
+-use 5.006;
+ use strict;
+-use warnings;
+ use Carp;
+ use Math::Trig qw( great_circle_distance deg2rad );
+
+ require Exporter;
+-our @ISA = qw(Exporter);
+-our %EXPORT_TAGS = ( 'all' => [ qw(
++use vars qw(@ISA %EXPORT_TAGS @EXPORT_OK $VERSION);
++@ISA = qw(Exporter);
++%EXPORT_TAGS = ( 'all' => [ qw(
+ &distance
+ &distance_calc
+ &find_closest
+ &reg_unit
+ &formula
+ ) ] );
+-our @EXPORT_OK = (
++@EXPORT_OK = (
+ @{ $EXPORT_TAGS{'all'} },
+ '&distance',
+ '&distance_calc',
+@@ -23,11 +22,11 @@
+ '&reg_unit',
+ '&formula'
+ );
+-our $VERSION = '0.06';
++$VERSION = '0.06';
+
+
+ # See Math::Trig for what $rho is.
+-our(%rho,$formula);
++use vars qw(%rho $formula);
+ $rho{kilometer} = 6378; # Derived from the Math::Trig POD on the 'great_circle_distance'.
+ $rho{meter} = $rho{kilometer}*1000; # 1000 meters in one kilometer.
+ $rho{centimeter} = $rho{meter}*100; # 100 centimeters in one meter.
+@@ -41,7 +40,7 @@
+ # Number of units in a single degree (lat or lon) at the equator.
+ # Derived from doing dirty_distance('kilometer',10,0,11,0) = 111.317099692185
+ # Then dividing that by $unit{kilometer} = 6378
+-our $deg_ratio = 0.01745329252;
++use vars qw($deg_ratio); $deg_ratio = 0.01745329252;
+
+
+ # New Object Constructor
diff --git a/math/p5-Geo-Distance/pkg-descr b/math/p5-Geo-Distance/pkg-descr
new file mode 100644
index 000000000000..0a63065cd3ab
--- /dev/null
+++ b/math/p5-Geo-Distance/pkg-descr
@@ -0,0 +1,7 @@
+This perl library aims to provide as many tools to make it as simple as possible
+to calculate distances between geographic points, and anything that can be
+derived from that. Currently there is support for finding the closest locations
+within a specified distance, to find the closest number of points to a specified
+point, and to do basic point-to-point distance calculations.
+
+WWW: http://search.cpan.org/~bluefeet/Geo-Distance/
diff --git a/math/p5-Geo-Distance/pkg-plist b/math/p5-Geo-Distance/pkg-plist
new file mode 100644
index 000000000000..0863d93fb9c7
--- /dev/null
+++ b/math/p5-Geo-Distance/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/mach/auto/Geo/Distance/.packlist
+%%SITE_PERL%%/Geo/Distance.pm
+@dirrm %%SITE_PERL%%/mach/auto/Geo/Distance
+@unexec rmdir %D/%%%SITE_PERL%%/mach/auto/Geo 2>/dev/null || true
+@unexec rmdir %D/%%%SITE_PERL%%/Geo 2>/dev/null || true