aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-26 00:44:22 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-26 00:48:20 +0000
commit95274bf4f99c71fc056013d966aec239161dfd74 (patch)
treebc1e95977678cb5b6b00b33e333b28161885e706 /math
parentdbe06d2da8c38d9d058f7939a7c6af36a2c0f1c7 (diff)
downloadports-95274bf4f99c71fc056013d966aec239161dfd74.tar.gz
ports-95274bf4f99c71fc056013d966aec239161dfd74.zip
Diffstat (limited to 'math')
-rw-r--r--math/alps/Makefile9
-rw-r--r--math/eval/Makefile2
-rw-r--r--math/form/Makefile2
-rw-r--r--math/lemon/Makefile7
4 files changed, 4 insertions, 16 deletions
diff --git a/math/alps/Makefile b/math/alps/Makefile
index 9180c3dffb4d..24c6e415b514 100644
--- a/math/alps/Makefile
+++ b/math/alps/Makefile
@@ -15,6 +15,7 @@ LIB_DEPENDS= libCoinUtils.so:math/coinutils \
libopenblas.so:math/openblas
USES= blaslapack gmake libtool pkgconfig
+USE_CXXSTD= c++14
USE_LDCONFIG= yes
USE_GITHUB= yes
@@ -25,14 +26,6 @@ GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-.include <bsd.port.options.mk>
-
-post-patch:
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
- @${REINPLACE_CMD} -e 's|std::unary_function|std::__unary_function|' \
- ${WRKSRC}/Alps/src/AlpsHelperFunctions.h
-.endif
-
post-install:
${RM} -r ${STAGEDIR}${PREFIX}/share
diff --git a/math/eval/Makefile b/math/eval/Makefile
index 1093e38904ea..dc0c0b536928 100644
--- a/math/eval/Makefile
+++ b/math/eval/Makefile
@@ -19,7 +19,7 @@ PLIST_FILES= bin/Eval
.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
CFLAGS+= -Wno-error=incompatible-function-pointer-types
.endif
diff --git a/math/form/Makefile b/math/form/Makefile
index 4957163b59a3..bb946fdc542a 100644
--- a/math/form/Makefile
+++ b/math/form/Makefile
@@ -37,7 +37,7 @@ OPENMPI_CONFIGURE_ENV+= MPICC="${MPICC}" \
.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
CFLAGS+= -Wno-error=incompatible-function-pointer-types
.endif
diff --git a/math/lemon/Makefile b/math/lemon/Makefile
index a695e8fc07c1..79b26d1b75ea 100644
--- a/math/lemon/Makefile
+++ b/math/lemon/Makefile
@@ -19,6 +19,7 @@ LIB_DEPENDS= libCbc.so:math/cbc \
libOsi.so:math/osi
USES= cmake
+USE_CXXSTD= c++14
USE_LDCONFIG= yes
CMAKE_ON= BUILD_SHARED_LIBS
@@ -32,12 +33,6 @@ GLPK_DESC= Build with GLPK solver
GLPK_CMAKE_BOOL= LEMON_ENABLE_GLPK
GLPK_LIB_DEPENDS= libglpk.so:math/glpk
-.include <bsd.port.options.mk>
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
-CXXFLAGS+= -Dregister=
-.endif
-
post-install:
@${RM} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}-0.x-to-1.x.sh