aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-06-10 12:39:17 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-06-10 12:39:17 +0000
commitb08a7396eb210bcd6e23a83e003743e88018958f (patch)
tree04682de066edae5441b90db16e48acc2bb49c431 /math
parent0a618235c76d379d40ae3087e19a8de0068c2221 (diff)
downloadports-b08a7396eb210bcd6e23a83e003743e88018958f.tar.gz
ports-b08a7396eb210bcd6e23a83e003743e88018958f.zip
math/py-z3-solver: fix build on powerpc
ld: error: can't create dynamic relocation R_PPC_ADDR16_LO against local symbol in readonly segment; recompile object files with -fPIC or pass '-Wl,-z,notext' to allow text relocations in the output
Diffstat (limited to 'math')
-rw-r--r--math/py-z3-solver/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/math/py-z3-solver/Makefile b/math/py-z3-solver/Makefile
index 2a08d843dd44..ee5cb7b8fd78 100644
--- a/math/py-z3-solver/Makefile
+++ b/math/py-z3-solver/Makefile
@@ -10,6 +10,8 @@ COMMENT= Python binding for Z3 Theorem Prover
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/../../../LICENSE.txt
+CFLAGS_powerpc= -fPIC
+
BROKEN_i386= can't create dynamic relocation R_386_32 against symbol: .L.str in readonly segment; see https://github.com/Z3Prover/z3/issues/2442
# CAVEAT: There should have LIB_DEPENDS=libz3.so:math/z3, but currently it rebuilds all code, see https://github.com/Z3Prover/z3/issues/1767