aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2011-03-12 00:10:39 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2011-03-12 00:10:39 +0000
commitb7019609cf7c524d7c3f1e267a0edec18e4721ed (patch)
treefeeb58314c9ffbc49ab9988e56a2ddbb350dc122 /math
parentd8e1644f1043c38e6be26edde43a87d85447f46a (diff)
downloadports-b7019609cf7c524d7c3f1e267a0edec18e4721ed.tar.gz
ports-b7019609cf7c524d7c3f1e267a0edec18e4721ed.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/p5-Math-Polygon-Tree/Makefile27
-rw-r--r--math/p5-Math-Polygon-Tree/distinfo2
-rw-r--r--math/p5-Math-Polygon-Tree/pkg-descr5
-rw-r--r--math/p5-Math-Polygon-Tree/pkg-plist7
5 files changed, 42 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 0c296c746af0..754d51eabe5c 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -363,6 +363,7 @@
SUBDIR += p5-Math-NumberCruncher
SUBDIR += p5-Math-Pari
SUBDIR += p5-Math-Polygon
+ SUBDIR += p5-Math-Polygon-Tree
SUBDIR += p5-Math-Polynomial-Solve
SUBDIR += p5-Math-RPN
SUBDIR += p5-Math-Random
diff --git a/math/p5-Math-Polygon-Tree/Makefile b/math/p5-Math-Polygon-Tree/Makefile
new file mode 100644
index 000000000000..b6695c99bdff
--- /dev/null
+++ b/math/p5-Math-Polygon-Tree/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-Math-Polygon-Tree
+# Date created: 03 Mar 2011
+# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-Polygon-Tree
+PORTVERSION= 0.041
+CATEGORIES= math perl5
+MASTER_SITES= CPAN/../../authors/id/L/LI/LIOSHA
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Class for fast check if point is inside polygon
+
+BUILD_DEPENDS= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
+ ${SITE_PERL}/${PERL_ARCH}/List/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils \
+ ${SITE_PERL}/${PERL_ARCH}/List/MoreUtils.pm:${PORTSDIR}/lang/p5-List-MoreUtils \
+ ${SITE_PERL}/${PERL_ARCH}/Math/Geometry/Planar/GPC/Polygon.pm:${PORTSDIR}/math/p5-Math-Geometry-Planar-GPC-Polygon
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Math::Polygon::Tree.3
+
+.include <bsd.port.mk>
diff --git a/math/p5-Math-Polygon-Tree/distinfo b/math/p5-Math-Polygon-Tree/distinfo
new file mode 100644
index 000000000000..659cd0eaf7f9
--- /dev/null
+++ b/math/p5-Math-Polygon-Tree/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Math-Polygon-Tree-0.041.tar.gz) = 31a02fa1e8b7bdf01d850a22942bb96526b0657e3e13dc52a09a97032475c55e
+SIZE (Math-Polygon-Tree-0.041.tar.gz) = 5299
diff --git a/math/p5-Math-Polygon-Tree/pkg-descr b/math/p5-Math-Polygon-Tree/pkg-descr
new file mode 100644
index 000000000000..78fb916fb2b6
--- /dev/null
+++ b/math/p5-Math-Polygon-Tree/pkg-descr
@@ -0,0 +1,5 @@
+Math::Polygon::Tree creates a B-tree of polygon parts for fast check
+if object is inside this polygon. This method is effective if polygon
+has hundreds or more segments.
+
+WWW: http://search.cpan.org/dist/Math-Polygon-Tree/
diff --git a/math/p5-Math-Polygon-Tree/pkg-plist b/math/p5-Math-Polygon-Tree/pkg-plist
new file mode 100644
index 000000000000..9f2cbe0f7225
--- /dev/null
+++ b/math/p5-Math-Polygon-Tree/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Math/Polygon/Tree.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Polygon/Tree/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Polygon/Tree
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Polygon
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math
+@dirrm %%SITE_PERL%%/Math/Polygon
+@dirrmtry %%SITE_PERL%%/Math