aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-04-29 19:07:06 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-04-29 19:07:06 +0000
commitc082697976e1f5ea50759df234908db6f9092977 (patch)
tree4e4f3e5120173eeb07cf454b17e567b7bae2e203 /math
parent2f6ce00077558887deff37dbed2154d393de9698 (diff)
downloadports-c082697976e1f5ea50759df234908db6f9092977.tar.gz
ports-c082697976e1f5ea50759df234908db6f9092977.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/hmat-oss/Makefile27
-rw-r--r--math/hmat-oss/distinfo3
-rw-r--r--math/hmat-oss/files/patch-src_disable__threading.cpp13
-rw-r--r--math/hmat-oss/pkg-descr10
-rw-r--r--math/hmat-oss/pkg-plist22
6 files changed, 76 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 65c569ef5bfc..9afe6ba7b18f 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -271,6 +271,7 @@
SUBDIR += gsl
SUBDIR += hexcalc
SUBDIR += hipmcl
+ SUBDIR += hmat-oss
SUBDIR += hs-Agda
SUBDIR += hs-Agda-stdlib
SUBDIR += hs-NumInstances
diff --git a/math/hmat-oss/Makefile b/math/hmat-oss/Makefile
new file mode 100644
index 000000000000..dd48c27f59c2
--- /dev/null
+++ b/math/hmat-oss/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= hmat-oss
+DISTVERSION= 1.5.0-340
+DISTVERSIONSUFFIX= -g700d1fa
+CATEGORIES= math
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Hierarchical matrix C/C++ library
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+LIB_DEPENDS= libcblas.so:math/cblas \
+ libomp.so:devel/openmp \
+ libopenblas.so:math/openblas
+
+USES= cmake localbase:ldflags
+USE_GITHUB= yes
+GH_ACCOUNT= jeromerobert
+USE_LDCONFIG= yes
+
+CMAKE_ARGS= -DBLAS_LIBRARIES:STRING=${LOCALBASE}/lib/libopenblas.so \
+ -DLAPACK_LIBRARIES:STRING=${LOCALBASE}/lib/libopenblas.so \
+ -DCBLAS_LIBRARIES:STRING=${LOCALBASE}/lib/libcblas.so
+
+.include <bsd.port.mk>
diff --git a/math/hmat-oss/distinfo b/math/hmat-oss/distinfo
new file mode 100644
index 000000000000..7de3651b310e
--- /dev/null
+++ b/math/hmat-oss/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1556520890
+SHA256 (jeromerobert-hmat-oss-1.5.0-340-g700d1fa_GH0.tar.gz) = 60a13f3626ddcef46a0d4c8ff750a3ae982b8de2fac0f09a673e029c45c636fc
+SIZE (jeromerobert-hmat-oss-1.5.0-340-g700d1fa_GH0.tar.gz) = 184636
diff --git a/math/hmat-oss/files/patch-src_disable__threading.cpp b/math/hmat-oss/files/patch-src_disable__threading.cpp
new file mode 100644
index 000000000000..771fce5a47f5
--- /dev/null
+++ b/math/hmat-oss/files/patch-src_disable__threading.cpp
@@ -0,0 +1,13 @@
+see https://github.com/jeromerobert/hmat-oss/issues/59
+
+--- src/disable_threading.cpp.orig 2019-04-29 18:50:39 UTC
++++ src/disable_threading.cpp
+@@ -37,6 +37,8 @@ extern "C" {
+ // This function is private in openblas
+ int goto_get_num_procs(void);
+ }
++
++void openblas_set_num_threads(int n);
+ #endif
+
+ namespace hmat {
diff --git a/math/hmat-oss/pkg-descr b/math/hmat-oss/pkg-descr
new file mode 100644
index 000000000000..63972048a483
--- /dev/null
+++ b/math/hmat-oss/pkg-descr
@@ -0,0 +1,10 @@
+A hierarchical matrix C/C++ library including a LU solver.
+
+Hierarchical matrices are semi-sparse matrices that have a hierarchical block
+structure with dense blocks hierarchically embedded into other blocks, and the
+elements not covered by blocks are zero.
+
+For a more detailed definition please see the wikipedia article
+"Hierarchical matrix".
+
+WWW: https://github.com/jeromerobert/hmat-oss
diff --git a/math/hmat-oss/pkg-plist b/math/hmat-oss/pkg-plist
new file mode 100644
index 000000000000..3639325f7b31
--- /dev/null
+++ b/math/hmat-oss/pkg-plist
@@ -0,0 +1,22 @@
+include/admissibility.hpp
+include/assembly.hpp
+include/cluster_tree.hpp
+include/clustering.hpp
+include/compression.hpp
+include/coordinates.hpp
+include/data_types.hpp
+include/default_engine.hpp
+include/full_matrix.hpp
+include/h_matrix.hpp
+include/hmat/config-oss.h
+include/hmat/config.h
+include/hmat/hmat.h
+include/hmat_cpp_interface.hpp
+include/tree.hpp
+lib/cmake/hmat/HMATConfig.cmake
+lib/cmake/hmat/HMATConfigVersion.cmake
+lib/cmake/hmat/HMATLibraryDepends-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/hmat/HMATLibraryDepends.cmake
+lib/libhmat-oss.so
+lib/libhmat-oss.so.1
+lib/libhmat-oss.so.1.5.0