aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-03-13 21:29:57 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-03-13 21:29:57 +0000
commitc6868aff9dd3f280f6cd043d8fbf0e00b9327be4 (patch)
tree396e33025c09ff352744a1ec359abf87f31a9206 /math
parentd8f0502f64e16223c1fe91f3b7204eb50221116b (diff)
downloadports-c6868aff9dd3f280f6cd043d8fbf0e00b9327be4.tar.gz
ports-c6868aff9dd3f280f6cd043d8fbf0e00b9327be4.zip
New port: math/py-baycomp: Library for Bayesian comparison of classifiers
Notes
Notes: svn path=/head/; revision=568286
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/py-baycomp/Makefile24
-rw-r--r--math/py-baycomp/distinfo3
-rw-r--r--math/py-baycomp/pkg-descr11
4 files changed, 39 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 0f712287cf3c..f2f29d2f5b68 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -756,6 +756,7 @@
SUBDIR += py-apgl
SUBDIR += py-arviz
SUBDIR += py-autograd
+ SUBDIR += py-baycomp
SUBDIR += py-bayesian-optimization
SUBDIR += py-benford_py
SUBDIR += py-bitmath
diff --git a/math/py-baycomp/Makefile b/math/py-baycomp/Makefile
new file mode 100644
index 000000000000..7e1292c0a554
--- /dev/null
+++ b/math/py-baycomp/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= baycomp
+DISTVERSION= 1.0.2
+CATEGORIES= math python # statistics
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Library for Bayesian comparison of classifiers
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}matplotlib>=2.1.2:math/py-matplotlib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>=0.19.1:science/py-scipy@${PY_FLAVOR}
+
+USES= localbase:ldflags python:3.6+
+USE_PYTHON= distutils autoplist
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/math/py-baycomp/distinfo b/math/py-baycomp/distinfo
new file mode 100644
index 000000000000..e47c092c972b
--- /dev/null
+++ b/math/py-baycomp/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1615670344
+SHA256 (baycomp-1.0.2.tar.gz) = c43472c16bd7cdf4884dd4c73dd307e4a3da7097fe49c83cd5e88d75142923b0
+SIZE (baycomp-1.0.2.tar.gz) = 154316
diff --git a/math/py-baycomp/pkg-descr b/math/py-baycomp/pkg-descr
new file mode 100644
index 000000000000..0bcf1633154e
--- /dev/null
+++ b/math/py-baycomp/pkg-descr
@@ -0,0 +1,11 @@
+Baycomp is a library for Bayesian comparison of classifiers.
+
+Functions compare two classifiers on one or on multiple data sets. They compute
+three probabilities: the probability that the first classifier has higher scores
+than the second, the probability that differences are within the region of
+practical equivalence (rope), or that the second classifier has higher scores.
+We will refer to this probabilities as p_left, p_rope and p_right. If the
+argument rope is omitted (or set to zero), functions return only p_left and
+p_right.
+
+WWW: https://github.com/janezd/baycomp