aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-03-25 01:00:29 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-03-25 01:00:29 +0000
commitcdbdb979090217b37e35652495f552f1ccd6911e (patch)
tree5b5c17821c8ae8615233bb6af49e9f983dd0a3ea /math
parent26f7e77421bbf7132cd00d1896f74ec4dee43805 (diff)
downloadports-cdbdb979090217b37e35652495f552f1ccd6911e.tar.gz
ports-cdbdb979090217b37e35652495f552f1ccd6911e.zip
Re-add port: math/openmesh: Update 8.0 -> 8.1
Notes
Notes: svn path=/head/; revision=569173
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/openmesh/Makefile26
-rw-r--r--math/openmesh/distinfo3
-rw-r--r--math/openmesh/files/patch-src_OpenMesh_Apps_Decimating_decimater.cc12
-rw-r--r--math/openmesh/files/patch-src_OpenMesh_Apps_Decimating_decimaterviewer.cc12
-rw-r--r--math/openmesh/files/patch-src_OpenMesh_Apps_QtViewer_meshviewer.cc12
-rw-r--r--math/openmesh/files/patch-src_OpenMesh_Apps_Smoothing_smooth.cc12
-rw-r--r--math/openmesh/files/patch-src_OpenMesh_Apps_Subdivider_adaptive__subdivider.cc12
-rw-r--r--math/openmesh/files/patch-src_OpenMesh_Apps_Subdivider_subdivider.cc12
-rw-r--r--math/openmesh/files/patch-src_OpenMesh_Apps_VDProgMesh_Analyzer_vdpmanalyzer.cc12
-rw-r--r--math/openmesh/files/patch-src_OpenMesh_Apps_VDProgMesh_mkbalancedpm_mkbalancedpm.cc12
-rw-r--r--math/openmesh/files/patch-src_OpenMesh_Apps_mconvert_mconvert.cc12
-rw-r--r--math/openmesh/files/patch-src_OpenMesh_Core_CMakeLists.txt11
-rw-r--r--math/openmesh/files/patch-src_OpenMesh_Tools_CMakeLists.txt29
-rw-r--r--math/openmesh/files/patch-src_OpenMesh_Tools_Utils_Timer.cc29
-rw-r--r--math/openmesh/pkg-descr11
-rw-r--r--math/openmesh/pkg-plist206
17 files changed, 424 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 8178d4320728..aa23bedc40fa 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -546,6 +546,7 @@
SUBDIR += onednn
SUBDIR += openblas
SUBDIR += openlibm
+ SUBDIR += openmesh
SUBDIR += opensolaris-libm
SUBDIR += openturns
SUBDIR += optpp
diff --git a/math/openmesh/Makefile b/math/openmesh/Makefile
new file mode 100644
index 000000000000..c54fecf1b7ac
--- /dev/null
+++ b/math/openmesh/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= openmesh
+DISTVERSION= 8.1
+CATEGORIES= math
+MASTER_SITES= http://www.openmesh.org/media/Releases/${DISTVERSION}/
+DISTNAME= OpenMesh-${DISTVERSION}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Generic data structure for manipulating polygonal meshes
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= cmake compiler:c++11-lang dos2unix gl qt:5 xorg
+DOS2UNIX_FILES= src/OpenMesh/Tools/CMakeLists.txt
+USE_QT= core concurrent gui help network opengl printsupport script scripttools sql svg x11extras xml xmlpatterns webkit widgets \
+ buildtools_build qmake_build uitools_build
+USE_GL= gl glu glut
+USE_XORG= xi xmu
+USE_LDCONFIG= yes
+
+post-install:
+ @${RMDIR} ${STAGEDIR}${PREFIX}/include/OpenMesh/Tools/VDPM/xpm
+
+.include <bsd.port.mk>
diff --git a/math/openmesh/distinfo b/math/openmesh/distinfo
new file mode 100644
index 000000000000..f55cf9101506
--- /dev/null
+++ b/math/openmesh/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1616633090
+SHA256 (OpenMesh-8.1.tar.gz) = 0953777f483d47ea9fa00c329838443a7a09dde8be77bf7de188001cb9e768a7
+SIZE (OpenMesh-8.1.tar.gz) = 26934610
diff --git a/math/openmesh/files/patch-src_OpenMesh_Apps_Decimating_decimater.cc b/math/openmesh/files/patch-src_OpenMesh_Apps_Decimating_decimater.cc
new file mode 100644
index 000000000000..4a874729818c
--- /dev/null
+++ b/math/openmesh/files/patch-src_OpenMesh_Apps_Decimating_decimater.cc
@@ -0,0 +1,12 @@
+--- src/OpenMesh/Apps/Decimating/decimater.cc.orig 2020-03-12 13:55:53 UTC
++++ src/OpenMesh/Apps/Decimating/decimater.cc
+@@ -53,6 +53,9 @@
+ #include <string>
+ #include <memory>
+ #include <map>
++#if defined(__FreeBSD__)
++#include <unistd.h>
++#endif
+ //--------------------
+ #include <OpenMesh/Core/IO/MeshIO.hh>
+ //--------------------
diff --git a/math/openmesh/files/patch-src_OpenMesh_Apps_Decimating_decimaterviewer.cc b/math/openmesh/files/patch-src_OpenMesh_Apps_Decimating_decimaterviewer.cc
new file mode 100644
index 000000000000..7870d8bf725a
--- /dev/null
+++ b/math/openmesh/files/patch-src_OpenMesh_Apps_Decimating_decimaterviewer.cc
@@ -0,0 +1,12 @@
+--- src/OpenMesh/Apps/Decimating/decimaterviewer.cc.orig 2020-03-12 13:55:53 UTC
++++ src/OpenMesh/Apps/Decimating/decimaterviewer.cc
+@@ -44,6 +44,9 @@
+ #ifdef _MSC_VER
+ # pragma warning(disable: 4267 4311)
+ #endif
++#if defined(__FreeBSD__)
++#include <unistd.h>
++#endif
+
+ #include <iostream>
+ #include <fstream>
diff --git a/math/openmesh/files/patch-src_OpenMesh_Apps_QtViewer_meshviewer.cc b/math/openmesh/files/patch-src_OpenMesh_Apps_QtViewer_meshviewer.cc
new file mode 100644
index 000000000000..63c08e4bd104
--- /dev/null
+++ b/math/openmesh/files/patch-src_OpenMesh_Apps_QtViewer_meshviewer.cc
@@ -0,0 +1,12 @@
+--- src/OpenMesh/Apps/QtViewer/meshviewer.cc.orig 2020-03-12 13:55:53 UTC
++++ src/OpenMesh/Apps/QtViewer/meshviewer.cc
+@@ -42,6 +42,9 @@
+ #ifdef _MSC_VER
+ # pragma warning(disable: 4267 4311)
+ #endif
++#if defined(__FreeBSD__)
++#include <unistd.h>
++#endif
+
+ #include <iostream>
+ #include <fstream>
diff --git a/math/openmesh/files/patch-src_OpenMesh_Apps_Smoothing_smooth.cc b/math/openmesh/files/patch-src_OpenMesh_Apps_Smoothing_smooth.cc
new file mode 100644
index 000000000000..cd8a76ebfddf
--- /dev/null
+++ b/math/openmesh/files/patch-src_OpenMesh_Apps_Smoothing_smooth.cc
@@ -0,0 +1,12 @@
+--- src/OpenMesh/Apps/Smoothing/smooth.cc.orig 2020-03-12 13:55:53 UTC
++++ src/OpenMesh/Apps/Smoothing/smooth.cc
+@@ -48,6 +48,9 @@
+ #include <OpenMesh/Tools/Utils/Timer.hh>
+ #include <OpenMesh/Tools/Smoother/JacobiLaplaceSmootherT.hh>
+ #include <OpenMesh/Tools/Utils/getopt.h>
++#if defined(__FreeBSD__)
++#include <unistd.h>
++#endif
+
+
+ using namespace OpenMesh;
diff --git a/math/openmesh/files/patch-src_OpenMesh_Apps_Subdivider_adaptive__subdivider.cc b/math/openmesh/files/patch-src_OpenMesh_Apps_Subdivider_adaptive__subdivider.cc
new file mode 100644
index 000000000000..c9306817d55b
--- /dev/null
+++ b/math/openmesh/files/patch-src_OpenMesh_Apps_Subdivider_adaptive__subdivider.cc
@@ -0,0 +1,12 @@
+--- src/OpenMesh/Apps/Subdivider/adaptive_subdivider.cc.orig 2020-03-12 13:55:53 UTC
++++ src/OpenMesh/Apps/Subdivider/adaptive_subdivider.cc
+@@ -62,6 +62,9 @@
+ # include <cmath>
+ using std::pow;
+ #endif
++#if defined(__FreeBSD__)
++#include <unistd.h>
++#endif
+
+
+ using OpenMesh::Subdivider::Adaptive::CompositeTraits;
diff --git a/math/openmesh/files/patch-src_OpenMesh_Apps_Subdivider_subdivider.cc b/math/openmesh/files/patch-src_OpenMesh_Apps_Subdivider_subdivider.cc
new file mode 100644
index 000000000000..3255dd05ece1
--- /dev/null
+++ b/math/openmesh/files/patch-src_OpenMesh_Apps_Subdivider_subdivider.cc
@@ -0,0 +1,12 @@
+--- src/OpenMesh/Apps/Subdivider/subdivider.cc.orig 2020-03-12 13:55:53 UTC
++++ src/OpenMesh/Apps/Subdivider/subdivider.cc
+@@ -43,6 +43,9 @@
+
+ #include <iostream>
+ #include <sstream>
++#if defined(__FreeBSD__)
++#include <unistd.h>
++#endif
+ // ---------------------------------------- OpenMesh Stuff
+ #include <OpenMesh/Core/IO/MeshIO.hh>
+ #include <OpenMesh/Core/Mesh/TriMesh_ArrayKernelT.hh>
diff --git a/math/openmesh/files/patch-src_OpenMesh_Apps_VDProgMesh_Analyzer_vdpmanalyzer.cc b/math/openmesh/files/patch-src_OpenMesh_Apps_VDProgMesh_Analyzer_vdpmanalyzer.cc
new file mode 100644
index 000000000000..f18104d80f1a
--- /dev/null
+++ b/math/openmesh/files/patch-src_OpenMesh_Apps_VDProgMesh_Analyzer_vdpmanalyzer.cc
@@ -0,0 +1,12 @@
+--- src/OpenMesh/Apps/VDProgMesh/Analyzer/vdpmanalyzer.cc.orig 2020-03-12 13:55:54 UTC
++++ src/OpenMesh/Apps/VDProgMesh/Analyzer/vdpmanalyzer.cc
+@@ -51,6 +51,9 @@
+ #include <limits>
+ #include <exception>
+ #include <cmath>
++#if defined(__FreeBSD__)
++#include <unistd.h>
++#endif
+ // -------------------- OpenMesh
+ #include <OpenMesh/Core/IO/MeshIO.hh>
+ #include <OpenMesh/Core/Mesh/TriMesh_ArrayKernelT.hh>
diff --git a/math/openmesh/files/patch-src_OpenMesh_Apps_VDProgMesh_mkbalancedpm_mkbalancedpm.cc b/math/openmesh/files/patch-src_OpenMesh_Apps_VDProgMesh_mkbalancedpm_mkbalancedpm.cc
new file mode 100644
index 000000000000..b6e24595e29b
--- /dev/null
+++ b/math/openmesh/files/patch-src_OpenMesh_Apps_VDProgMesh_mkbalancedpm_mkbalancedpm.cc
@@ -0,0 +1,12 @@
+--- src/OpenMesh/Apps/VDProgMesh/mkbalancedpm/mkbalancedpm.cc.orig 2020-03-12 13:55:54 UTC
++++ src/OpenMesh/Apps/VDProgMesh/mkbalancedpm/mkbalancedpm.cc
+@@ -45,6 +45,9 @@
+ #include <iostream>
+ #include <sstream>
+ #include <cmath>
++#if defined(__FreeBSD__)
++#include <unistd.h>
++#endif
+ // -------------------- OpenMesh
+ #include <OpenMesh/Core/IO/MeshIO.hh>
+ #include <OpenMesh/Core/Mesh/TriMesh_ArrayKernelT.hh>
diff --git a/math/openmesh/files/patch-src_OpenMesh_Apps_mconvert_mconvert.cc b/math/openmesh/files/patch-src_OpenMesh_Apps_mconvert_mconvert.cc
new file mode 100644
index 000000000000..22ea215e9c96
--- /dev/null
+++ b/math/openmesh/files/patch-src_OpenMesh_Apps_mconvert_mconvert.cc
@@ -0,0 +1,12 @@
+--- src/OpenMesh/Apps/mconvert/mconvert.cc.orig 2020-03-12 13:55:54 UTC
++++ src/OpenMesh/Apps/mconvert/mconvert.cc
+@@ -45,6 +45,9 @@
+ #include <iterator>
+ #include <fstream>
+ #include <string>
++#if defined(__FreeBSD__)
++#include <unistd.h>
++#endif
+ //
+ #include <OpenMesh/Core/IO/MeshIO.hh>
+ #include <OpenMesh/Core/Mesh/TriMesh_ArrayKernelT.hh>
diff --git a/math/openmesh/files/patch-src_OpenMesh_Core_CMakeLists.txt b/math/openmesh/files/patch-src_OpenMesh_Core_CMakeLists.txt
new file mode 100644
index 000000000000..4039b7c53a3c
--- /dev/null
+++ b/math/openmesh/files/patch-src_OpenMesh_Core_CMakeLists.txt
@@ -0,0 +1,11 @@
+--- src/OpenMesh/Core/CMakeLists.txt.orig 2020-03-12 13:55:54 UTC
++++ src/OpenMesh/Core/CMakeLists.txt
+@@ -41,7 +41,7 @@ if (WIN32)
+ endif()
+
+ else ()
+- acg_add_library (OpenMeshCore SHAREDANDSTATIC ${sources} ${headers})
++ acg_add_library (OpenMeshCore SHARED ${sources} ${headers})
+ set_target_properties (OpenMeshCore PROPERTIES VERSION ${OPENMESH_VERSION_MAJOR}.${OPENMESH_VERSION_MINOR}
+ SOVERSION ${OPENMESH_VERSION_MAJOR}.${OPENMESH_VERSION_MINOR} )
+
diff --git a/math/openmesh/files/patch-src_OpenMesh_Tools_CMakeLists.txt b/math/openmesh/files/patch-src_OpenMesh_Tools_CMakeLists.txt
new file mode 100644
index 000000000000..c4584a5a0a98
--- /dev/null
+++ b/math/openmesh/files/patch-src_OpenMesh_Tools_CMakeLists.txt
@@ -0,0 +1,29 @@
+--- src/OpenMesh/Tools/CMakeLists.txt.orig 2021-03-25 00:45:18 UTC
++++ src/OpenMesh/Tools/CMakeLists.txt
+@@ -43,7 +43,7 @@ if (WIN32)
+ endif()
+
+ else ()
+- acg_add_library (OpenMeshTools SHAREDANDSTATIC ${sources} ${headers})
++ acg_add_library (OpenMeshTools SHARED ${sources} ${headers})
+ set_target_properties (OpenMeshTools PROPERTIES VERSION ${OPENMESH_VERSION_MAJOR}.${OPENMESH_VERSION_MINOR}
+ SOVERSION ${OPENMESH_VERSION_MAJOR}.${OPENMESH_VERSION_MINOR} )
+ endif ()
+@@ -51,7 +51,7 @@ endif ()
+ target_link_libraries (OpenMeshTools OpenMeshCore)
+
+ IF( NOT WIN32 )
+- target_link_libraries (OpenMeshToolsStatic OpenMeshCoreStatic)
++ #target_link_libraries (OpenMeshToolsStatic OpenMeshCoreStatic)
+ ENDIF(NOT WIN32)
+
+ if ( (${PROJECT_NAME} MATCHES "OpenMesh") AND BUILD_APPS )
+@@ -67,7 +67,7 @@ if ( (${PROJECT_NAME} MATCHES "OpenMesh") AND BUILD_AP
+ if (APPLE)
+ # let bundle generation depend on target
+ add_dependencies (fixbundle OpenMeshTools)
+- add_dependencies (fixbundle OpenMeshToolsStatic)
++ #add_dependencies (fixbundle OpenMeshToolsStatic)
+ endif()
+
+ endif()
diff --git a/math/openmesh/files/patch-src_OpenMesh_Tools_Utils_Timer.cc b/math/openmesh/files/patch-src_OpenMesh_Tools_Utils_Timer.cc
new file mode 100644
index 000000000000..07453764c7ed
--- /dev/null
+++ b/math/openmesh/files/patch-src_OpenMesh_Tools_Utils_Timer.cc
@@ -0,0 +1,29 @@
+--- src/OpenMesh/Tools/Utils/Timer.cc.orig 2020-03-12 13:55:54 UTC
++++ src/OpenMesh/Tools/Utils/Timer.cc
+@@ -41,6 +41,8 @@
+
+
+
++#include <sys/time.h>
++
+ #ifndef DOXY_IGNORE_THIS
+ // ----------------------------------------------------------------------------
+ #include <OpenMesh/Core/System/config.h>
+@@ -145,7 +147,7 @@ double TimerImplWin32::seconds(void) const
+ }
+
+ // ------------------------------------------------------------- posix time ----
+-#elif defined(__GNUC__) && defined(__POSIX__)
++#elif 0 && defined(__GNUC__) && defined(__POSIX__)
+
+ #ifndef DOXY_IGNORE_THIS
+ # include <time.h>
+@@ -183,7 +185,7 @@ class TimerImplPosix : public TimerImpl (protected)
+ };
+
+ // ----------------------------------------------------------- gettimeofday ----
+-#elif (defined(__GNUC__) && !defined(__FreeBSD__) || (defined(__INTEL_COMPILER) && !defined(WIN32))) && !defined(__MINGW32__)
++#elif 0 && (defined(__GNUC__) && !defined(__FreeBSD__) || (defined(__INTEL_COMPILER) && !defined(WIN32))) && !defined(__MINGW32__)
+
+ # include <sys/time.h>
+ # include <sys/resource.h>
diff --git a/math/openmesh/pkg-descr b/math/openmesh/pkg-descr
new file mode 100644
index 000000000000..4d63aa02b64b
--- /dev/null
+++ b/math/openmesh/pkg-descr
@@ -0,0 +1,11 @@
+OpenMesh is a generic and efficient data structure for representing and
+manipulating polygonal meshes.
+
+The main features of the underlying data structure are:
+* No restriction to triangles meshes, handle general polygonal meshes.
+* Explicit representation of vertices, halfedges, edges, and faces.
+* Efficient access to the one-ring neighborhood of a vertex.
+* Ability to handle non-manifold vertices (like two faces meeting in only one
+ vertex).
+
+WWW: https://www.openmesh.org/
diff --git a/math/openmesh/pkg-plist b/math/openmesh/pkg-plist
new file mode 100644
index 000000000000..04da367e7cd6
--- /dev/null
+++ b/math/openmesh/pkg-plist
@@ -0,0 +1,206 @@
+bin/Analyzer
+bin/DecimaterGui
+bin/Dualizer
+bin/ProgViewer
+bin/QtViewer
+bin/Smoothing
+bin/SubdividerGui
+bin/Synthesizer
+bin/commandlineAdaptiveSubdivider
+bin/commandlineDecimater
+bin/commandlineSubdivider
+bin/mconvert
+bin/mkbalancedpm
+include/OpenMesh/Core/Geometry/Config.hh
+include/OpenMesh/Core/Geometry/EigenVectorT.hh
+include/OpenMesh/Core/Geometry/LoopSchemeMaskT.hh
+include/OpenMesh/Core/Geometry/MathDefs.hh
+include/OpenMesh/Core/Geometry/NormalConeT.hh
+include/OpenMesh/Core/Geometry/NormalConeT_impl.hh
+include/OpenMesh/Core/Geometry/Plane3d.hh
+include/OpenMesh/Core/Geometry/QuadricT.hh
+include/OpenMesh/Core/Geometry/Vector11T.hh
+include/OpenMesh/Core/Geometry/VectorT.hh
+include/OpenMesh/Core/Geometry/VectorT_inc.hh
+include/OpenMesh/Core/IO/BinaryHelper.hh
+include/OpenMesh/Core/IO/IOInstances.hh
+include/OpenMesh/Core/IO/IOManager.hh
+include/OpenMesh/Core/IO/MeshIO.hh
+include/OpenMesh/Core/IO/OFFFormat.hh
+include/OpenMesh/Core/IO/OMFormat.hh
+include/OpenMesh/Core/IO/OMFormatT_impl.hh
+include/OpenMesh/Core/IO/Options.hh
+include/OpenMesh/Core/IO/SR_binary.hh
+include/OpenMesh/Core/IO/SR_binary_spec.hh
+include/OpenMesh/Core/IO/SR_binary_vector_of_bool.inl
+include/OpenMesh/Core/IO/SR_binary_vector_of_fundamentals.inl
+include/OpenMesh/Core/IO/SR_binary_vector_of_string.inl
+include/OpenMesh/Core/IO/SR_rbo.hh
+include/OpenMesh/Core/IO/SR_store.hh
+include/OpenMesh/Core/IO/SR_types.hh
+include/OpenMesh/Core/IO/StoreRestore.hh
+include/OpenMesh/Core/IO/exporter/BaseExporter.hh
+include/OpenMesh/Core/IO/exporter/ExporterT.hh
+include/OpenMesh/Core/IO/importer/BaseImporter.hh
+include/OpenMesh/Core/IO/importer/ImporterT.hh
+include/OpenMesh/Core/IO/reader/BaseReader.hh
+include/OpenMesh/Core/IO/reader/OBJReader.hh
+include/OpenMesh/Core/IO/reader/OFFReader.hh
+include/OpenMesh/Core/IO/reader/OMReader.hh
+include/OpenMesh/Core/IO/reader/PLYReader.hh
+include/OpenMesh/Core/IO/reader/STLReader.hh
+include/OpenMesh/Core/IO/writer/BaseWriter.hh
+include/OpenMesh/Core/IO/writer/OBJWriter.hh
+include/OpenMesh/Core/IO/writer/OFFWriter.hh
+include/OpenMesh/Core/IO/writer/OMWriter.hh
+include/OpenMesh/Core/IO/writer/PLYWriter.hh
+include/OpenMesh/Core/IO/writer/STLWriter.hh
+include/OpenMesh/Core/IO/writer/VTKWriter.hh
+include/OpenMesh/Core/Mesh/ArrayItems.hh
+include/OpenMesh/Core/Mesh/ArrayKernel.hh
+include/OpenMesh/Core/Mesh/ArrayKernelT_impl.hh
+include/OpenMesh/Core/Mesh/AttribKernelT.hh
+include/OpenMesh/Core/Mesh/Attributes.hh
+include/OpenMesh/Core/Mesh/BaseKernel.hh
+include/OpenMesh/Core/Mesh/BaseMesh.hh
+include/OpenMesh/Core/Mesh/Casts.hh
+include/OpenMesh/Core/Mesh/CirculatorsT.hh
+include/OpenMesh/Core/Mesh/DefaultPolyMesh.hh
+include/OpenMesh/Core/Mesh/DefaultTriMesh.hh
+include/OpenMesh/Core/Mesh/FinalMeshItemsT.hh
+include/OpenMesh/Core/Mesh/Handles.hh
+include/OpenMesh/Core/Mesh/IteratorsT.hh
+include/OpenMesh/Core/Mesh/PolyConnectivity.hh
+include/OpenMesh/Core/Mesh/PolyConnectivity_inline_impl.hh
+include/OpenMesh/Core/Mesh/PolyMeshT.hh
+include/OpenMesh/Core/Mesh/PolyMeshT_impl.hh
+include/OpenMesh/Core/Mesh/PolyMesh_ArrayKernelT.hh
+include/OpenMesh/Core/Mesh/SmartHandles.hh
+include/OpenMesh/Core/Mesh/SmartRange.hh
+include/OpenMesh/Core/Mesh/Status.hh
+include/OpenMesh/Core/Mesh/Tags.hh
+include/OpenMesh/Core/Mesh/Traits.hh
+include/OpenMesh/Core/Mesh/TriConnectivity.hh
+include/OpenMesh/Core/Mesh/TriMeshT.hh
+include/OpenMesh/Core/Mesh/TriMeshT_impl.hh
+include/OpenMesh/Core/Mesh/TriMesh_ArrayKernelT.hh
+include/OpenMesh/Core/Mesh/gen/circulators_header.hh
+include/OpenMesh/Core/Mesh/gen/circulators_template.hh
+include/OpenMesh/Core/Mesh/gen/footer.hh
+include/OpenMesh/Core/Mesh/gen/iterators_header.hh
+include/OpenMesh/Core/Mesh/gen/iterators_template.hh
+include/OpenMesh/Core/System/OpenMeshDLLMacros.hh
+include/OpenMesh/Core/System/compiler.hh
+include/OpenMesh/Core/System/config.h
+include/OpenMesh/Core/System/config.hh
+include/OpenMesh/Core/System/mostream.hh
+include/OpenMesh/Core/System/omstream.hh
+include/OpenMesh/Core/Utils/AutoPropertyHandleT.hh
+include/OpenMesh/Core/Utils/BaseProperty.hh
+include/OpenMesh/Core/Utils/Endian.hh
+include/OpenMesh/Core/Utils/GenProg.hh
+include/OpenMesh/Core/Utils/HandleToPropHandle.hh
+include/OpenMesh/Core/Utils/Noncopyable.hh
+include/OpenMesh/Core/Utils/Property.hh
+include/OpenMesh/Core/Utils/PropertyContainer.hh
+include/OpenMesh/Core/Utils/PropertyManager.hh
+include/OpenMesh/Core/Utils/RandomNumberGenerator.hh
+include/OpenMesh/Core/Utils/SingletonT.hh
+include/OpenMesh/Core/Utils/SingletonT_impl.hh
+include/OpenMesh/Core/Utils/color_cast.hh
+include/OpenMesh/Core/Utils/typename.hh
+include/OpenMesh/Core/Utils/vector_cast.hh
+include/OpenMesh/Core/Utils/vector_traits.hh
+include/OpenMesh/Tools/Decimater/BaseDecimaterT.hh
+include/OpenMesh/Tools/Decimater/BaseDecimaterT_impl.hh
+include/OpenMesh/Tools/Decimater/CollapseInfoT.hh
+include/OpenMesh/Tools/Decimater/DecimaterT.hh
+include/OpenMesh/Tools/Decimater/DecimaterT_impl.hh
+include/OpenMesh/Tools/Decimater/McDecimaterT.hh
+include/OpenMesh/Tools/Decimater/McDecimaterT_impl.hh
+include/OpenMesh/Tools/Decimater/MixedDecimaterT.hh
+include/OpenMesh/Tools/Decimater/MixedDecimaterT_impl.hh
+include/OpenMesh/Tools/Decimater/ModAspectRatioT.hh
+include/OpenMesh/Tools/Decimater/ModAspectRatioT_impl.hh
+include/OpenMesh/Tools/Decimater/ModBaseT.hh
+include/OpenMesh/Tools/Decimater/ModEdgeLengthT.hh
+include/OpenMesh/Tools/Decimater/ModEdgeLengthT_impl.hh
+include/OpenMesh/Tools/Decimater/ModHausdorffT.hh
+include/OpenMesh/Tools/Decimater/ModHausdorffT_impl.hh
+include/OpenMesh/Tools/Decimater/ModIndependentSetsT.hh
+include/OpenMesh/Tools/Decimater/ModNormalDeviationT.hh
+include/OpenMesh/Tools/Decimater/ModNormalFlippingT.hh
+include/OpenMesh/Tools/Decimater/ModProgMeshT.hh
+include/OpenMesh/Tools/Decimater/ModProgMeshT_impl.hh
+include/OpenMesh/Tools/Decimater/ModQuadricT.hh
+include/OpenMesh/Tools/Decimater/ModQuadricT_impl.hh
+include/OpenMesh/Tools/Decimater/ModRoundnessT.hh
+include/OpenMesh/Tools/Decimater/Observer.hh
+include/OpenMesh/Tools/Dualizer/meshDualT.hh
+include/OpenMesh/Tools/Kernel_OSG/ArrayKernelT.hh
+include/OpenMesh/Tools/Kernel_OSG/AttribKernelT.hh
+include/OpenMesh/Tools/Kernel_OSG/PropertyKernel.hh
+include/OpenMesh/Tools/Kernel_OSG/PropertyT.hh
+include/OpenMesh/Tools/Kernel_OSG/Traits.hh
+include/OpenMesh/Tools/Kernel_OSG/TriMesh_OSGArrayKernelT.hh
+include/OpenMesh/Tools/Kernel_OSG/VectorAdapter.hh
+include/OpenMesh/Tools/Kernel_OSG/bindT.hh
+include/OpenMesh/Tools/Kernel_OSG/color_cast.hh
+include/OpenMesh/Tools/SmartTagger/SmartTaggerT.hh
+include/OpenMesh/Tools/SmartTagger/SmartTaggerT_impl.hh
+include/OpenMesh/Tools/Smoother/JacobiLaplaceSmootherT.hh
+include/OpenMesh/Tools/Smoother/JacobiLaplaceSmootherT_impl.hh
+include/OpenMesh/Tools/Smoother/LaplaceSmootherT.hh
+include/OpenMesh/Tools/Smoother/LaplaceSmootherT_impl.hh
+include/OpenMesh/Tools/Smoother/SmootherT.hh
+include/OpenMesh/Tools/Smoother/SmootherT_impl.hh
+include/OpenMesh/Tools/Smoother/smooth_mesh.hh
+include/OpenMesh/Tools/Subdivider/Adaptive/Composite/CompositeT.hh
+include/OpenMesh/Tools/Subdivider/Adaptive/Composite/CompositeT_impl.hh
+include/OpenMesh/Tools/Subdivider/Adaptive/Composite/CompositeTraits.hh
+include/OpenMesh/Tools/Subdivider/Adaptive/Composite/RuleInterfaceT.hh
+include/OpenMesh/Tools/Subdivider/Adaptive/Composite/RulesT.hh
+include/OpenMesh/Tools/Subdivider/Adaptive/Composite/RulesT_impl.hh
+include/OpenMesh/Tools/Subdivider/Adaptive/Composite/Traits.hh
+include/OpenMesh/Tools/Subdivider/Uniform/CatmullClarkT.hh
+include/OpenMesh/Tools/Subdivider/Uniform/CatmullClarkT_impl.hh
+include/OpenMesh/Tools/Subdivider/Uniform/Composite/CompositeT.hh
+include/OpenMesh/Tools/Subdivider/Uniform/Composite/CompositeT_impl.hh
+include/OpenMesh/Tools/Subdivider/Uniform/Composite/CompositeTraits.hh
+include/OpenMesh/Tools/Subdivider/Uniform/CompositeLoopT.hh
+include/OpenMesh/Tools/Subdivider/Uniform/CompositeSqrt3T.hh
+include/OpenMesh/Tools/Subdivider/Uniform/LongestEdgeT.hh
+include/OpenMesh/Tools/Subdivider/Uniform/LoopT.hh
+include/OpenMesh/Tools/Subdivider/Uniform/MidpointT.hh
+include/OpenMesh/Tools/Subdivider/Uniform/ModifiedButterFlyT.hh
+include/OpenMesh/Tools/Subdivider/Uniform/Sqrt3InterpolatingSubdividerLabsikGreinerT.hh
+include/OpenMesh/Tools/Subdivider/Uniform/Sqrt3T.hh
+include/OpenMesh/Tools/Subdivider/Uniform/SubdividerT.hh
+include/OpenMesh/Tools/Utils/Config.hh
+include/OpenMesh/Tools/Utils/GLConstAsString.hh
+include/OpenMesh/Tools/Utils/Gnuplot.hh
+include/OpenMesh/Tools/Utils/HeapT.hh
+include/OpenMesh/Tools/Utils/MeshCheckerT.hh
+include/OpenMesh/Tools/Utils/MeshCheckerT_impl.hh
+include/OpenMesh/Tools/Utils/NumLimitsT.hh
+include/OpenMesh/Tools/Utils/StripifierT.hh
+include/OpenMesh/Tools/Utils/StripifierT_impl.hh
+include/OpenMesh/Tools/Utils/TestingFramework.hh
+include/OpenMesh/Tools/Utils/Timer.hh
+include/OpenMesh/Tools/Utils/conio.hh
+include/OpenMesh/Tools/Utils/getopt.h
+include/OpenMesh/Tools/VDPM/MeshTraits.hh
+include/OpenMesh/Tools/VDPM/StreamingDef.hh
+include/OpenMesh/Tools/VDPM/VFront.hh
+include/OpenMesh/Tools/VDPM/VHierarchy.hh
+include/OpenMesh/Tools/VDPM/VHierarchyNode.hh
+include/OpenMesh/Tools/VDPM/VHierarchyNodeIndex.hh
+include/OpenMesh/Tools/VDPM/VHierarchyWindow.hh
+include/OpenMesh/Tools/VDPM/ViewingParameters.hh
+lib/libOpenMeshCore.so
+lib/libOpenMeshCore.so.8.1
+lib/libOpenMeshTools.so
+lib/libOpenMeshTools.so.8.1
+libdata/pkgconfig/openmesh.pc
+share/OpenMesh/cmake/OpenMeshConfig-%%CMAKE_BUILD_TYPE%%.cmake
+share/OpenMesh/cmake/OpenMeshConfig.cmake