aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-07-15 10:37:31 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-07-15 10:37:31 +0000
commitdbb0b7482f87c180be139b72925149eb7c4419cb (patch)
tree3525ab9b278ac3e818e54dc07e5c80ffad39f2b6 /math
parent834b9cb4da3b5f38f4e619912679c88f278211ec (diff)
downloadports-dbb0b7482f87c180be139b72925149eb7c4419cb.tar.gz
ports-dbb0b7482f87c180be139b72925149eb7c4419cb.zip
math/wxmaxima: fix build on powerpc
/usr/bin/c++ -DWXUSINGDLL -D_FILE_OFFSET_BITS=64 -D_THREAD_SAFE -D__WXGTK__ -Isrc -isystem /usr/local/lib/wx/include/gtk3-unicode-3.0 -isystem /usr/local/include/wx-3.0 -O2 -pipe -fstack-protector-strong -fno-strict-aliasing -pthread -O2 -pipe -fstack-protector-strong -fno-strict-aliasing -std=gnu++11 -MD -MT src/CMakeFiles/wxmaxima.dir/SlideShowCell.cpp.o -MF src/CMakeFiles/wxmaxima.dir/SlideShowCell.cpp.o.d -o src/CMakeFiles/wxmaxima.dir/SlideShowCell.cpp.o -c /wrkdirs/usr/ports/math/wxmaxima/work/wxmaxima-Version-20.04.0/src/SlideShowCell.cpp In file included from /wrkdirs/usr/ports/math/wxmaxima/work/wxmaxima-Version-20.04.0/src/SlideShowCell.cpp:32: In file included from /wrkdirs/usr/ports/math/wxmaxima/work/wxmaxima-Version-20.04.0/src/SlideShowCell.h:33: In file included from /wrkdirs/usr/ports/math/wxmaxima/work/wxmaxima-Version-20.04.0/src/Image.h:33: src/Version.h:5:6: error: invalid token at start of a preprocessor expression
Diffstat (limited to 'math')
-rw-r--r--math/wxmaxima/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/math/wxmaxima/Makefile b/math/wxmaxima/Makefile
index 3db33979c6b7..426bfa123a40 100644
--- a/math/wxmaxima/Makefile
+++ b/math/wxmaxima/Makefile
@@ -31,4 +31,10 @@ OPTIONS_SUB= yes
NLS_USES= gettext
NLS_EXTRA_PATCHES_OFF= ${PATCHDIR}/extra-patch-CMakeLists.txt
+.include <bsd.port.options.mk>
+
+.if ${ARCH} != powerpc
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-src_Version.h.cin
+.endif
+
.include <bsd.port.mk>