aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2017-03-29 05:18:30 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2017-03-29 05:18:30 +0000
commitddebd2795922b2682efeffea1de2f9c8b7391046 (patch)
treeb0a372218eb95f330ad0f290f2a50832c88ecc7a /math
parent50cb74b54bbee23f0cb66b9416da3031b68c0e07 (diff)
downloadports-ddebd2795922b2682efeffea1de2f9c8b7391046.tar.gz
ports-ddebd2795922b2682efeffea1de2f9c8b7391046.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/mprime/Makefile31
-rw-r--r--math/mprime/distinfo3
-rw-r--r--math/mprime/files/pkg-message.in10
-rw-r--r--math/mprime/files/wrapper.sh.in23
-rw-r--r--math/mprime/pkg-descr12
-rw-r--r--math/mprime/pkg-plist7
7 files changed, 87 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index e0d8c4c52ef9..a5bd1c0306f3 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -286,6 +286,7 @@
SUBDIR += mpexpr
SUBDIR += mpfr
SUBDIR += mpir
+ SUBDIR += mprime
SUBDIR += msieve
SUBDIR += mtl
SUBDIR += mtrxmath
diff --git a/math/mprime/Makefile b/math/mprime/Makefile
new file mode 100644
index 000000000000..d51476d5ddcf
--- /dev/null
+++ b/math/mprime/Makefile
@@ -0,0 +1,31 @@
+# Created by: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= mprime
+PORTVERSION= 26.6
+CATEGORIES= math benchmarks net
+MASTER_SITES= http://www.mersenne.org/ftp_root/gimps/
+DISTNAME= ${PORTNAME}${PORTVERSION:S/.//}-${OPSYS}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= mersenne.org distributed Great Internet Mersenne Prime Search
+
+LIB_DEPENDS= libcrypto.so.6:misc/compat9x
+
+ONLY_FOR_ARCHS= i386
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+SUB_FILES= pkg-message wrapper.sh
+
+OPTIONS_DEFINE= DOCS
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/mprime ${STAGEDIR}${PREFIX}/bin/mprime-real
+ ${INSTALL_SCRIPT} ${WRKDIR}/wrapper.sh ${STAGEDIR}${PREFIX}/bin/mprime
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.txt ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/math/mprime/distinfo b/math/mprime/distinfo
new file mode 100644
index 000000000000..07f683d4ece0
--- /dev/null
+++ b/math/mprime/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1302303090
+SHA256 (mprime266-FreeBSD.tar.gz) = d4c2c044cfa45311dd7f2c41574f59a0519c989fd6e0ca723505dea12b2ff1fd
+SIZE (mprime266-FreeBSD.tar.gz) = 4233056
diff --git a/math/mprime/files/pkg-message.in b/math/mprime/files/pkg-message.in
new file mode 100644
index 000000000000..46a39c0949cd
--- /dev/null
+++ b/math/mprime/files/pkg-message.in
@@ -0,0 +1,10 @@
+ ATTENTIONATTENTION:
+
+Please, make sure that you read
+%%DOCSDIR%%/license.txt
+and agree to the licensing terms before running this application.
+
+Furthermore, read
+%%DOCSDIR%%/readme.txt
+It contains important information about both configuring and running
+mprime. You will have problems running it if you do not read it.
diff --git a/math/mprime/files/wrapper.sh.in b/math/mprime/files/wrapper.sh.in
new file mode 100644
index 000000000000..3276091dc060
--- /dev/null
+++ b/math/mprime/files/wrapper.sh.in
@@ -0,0 +1,23 @@
+#!/bin/sh
+
+PREFIX="%%PREFIX%%"
+PROGRAM="${0}"
+DIRNAME=${HOME}/.mprime
+
+if [ ! -d ${DIRNAME} ]
+then
+ mkdir -p ${DIRNAME}
+fi
+
+if [ ! -h ${DIRNAME}/${PROGRAM##*/} ]
+then
+ ln -sf ${PREFIX}/bin/${PROGRAM##*/}-real ${DIRNAME}/${PROGRAM##*/}
+fi
+
+echo " ${*} " | grep " \-createdironly " ||
+{
+ cd ${DIRNAME} &&
+ echo Running under ${DIRNAME} &&
+ exec ./${PROGRAM##*/} "${@}" ||
+ echo PROBLEM. Cannot create directory ${DIRNAME}, make sure you have the proper permissions to create it and try again
+}
diff --git a/math/mprime/pkg-descr b/math/mprime/pkg-descr
new file mode 100644
index 000000000000..71fb8376317d
--- /dev/null
+++ b/math/mprime/pkg-descr
@@ -0,0 +1,12 @@
+This program is used to find Mersenne Prime numbers as part of Great
+Internet Mersenne Prime Search initiative (GIMPS) since 1996. See
+http://www.utm.edu/research/primes/mersenne.shtml for a description
+of Mersenne primes.
+
+Mersenne number can be proved composite (not prime) by either finding
+a factor or by running a Lucas-Lehmer primality test.
+
+To use this program you must agree to the terms and conditions, prize
+rules, etc. at http://mersenne.org/legal/.
+
+WWW: http://www.mersenne.org/
diff --git a/math/mprime/pkg-plist b/math/mprime/pkg-plist
new file mode 100644
index 000000000000..dc8c8dae1333
--- /dev/null
+++ b/math/mprime/pkg-plist
@@ -0,0 +1,7 @@
+bin/mprime
+bin/mprime-real
+%%PORTDOCS%%%%DOCSDIR%%/license.txt
+%%PORTDOCS%%%%DOCSDIR%%/readme.txt
+%%PORTDOCS%%%%DOCSDIR%%/stress.txt
+%%PORTDOCS%%%%DOCSDIR%%/undoc.txt
+%%PORTDOCS%%%%DOCSDIR%%/whatsnew.txt